Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 02 Aug 2014, 00:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Google-chrome-5.0.375.70-beta
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Author Message
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Mon 10 May 2010, 22:46    Post subject:  Google-chrome-5.0.375.70-beta
Subject description: new update as of June 4, 2010
 

Hi all I think that the Google chrome team is in overtime here is a new beta they did not give it a beta number just a release number.

Read below for details

Get the pet here:
http://code.google.com/p/mywolfe/downloads/detail?name=google-chrome-5.0.375.70-beta.pet&can=2&q=

and if you have never installed Google-chrome before you will need the libs.
http://code.google.com/p/mywolfe/downloads/detail?name=google-libs-3.pet&can=2&q=

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups

Last edited by GrumpyWolfe on Fri 04 Jun 2010, 10:57; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Wed 12 May 2010, 08:19    Post subject:  

The sandbox now works Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy! However the executable "chrome-sandbox" needs the permission "SUID" for it to work.
Back to top
View user's profile Send private message Visit poster's website 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Mon 17 May 2010, 04:06    Post subject:  

I'm still using Puppy 4.2. Downloaded the above pets of google-chrome and libraries. Chrome will momentarily load then crash.

Couple minor errors of /lib/libz.so.1: no version information availabe

Then "Error reading Preferences: File doesn't exist...

Then error "/usr/bin/google-chrome: symbol lookup errror: /usr/bin/google-chrome: undefined symbol: pango_layout_set_height"

I assume its that pango error that is the problem?

I am still on dialup (and slow connection even for dialup) so just downloading this pet was an adventure, kinda hate to not get it working.
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Mon 17 May 2010, 08:55    Post subject: Pango
Subject description: yes it is
 

there is a way to upgrade your pango but it may affect other programs you already have installed. Did once before can't remember what affect it had. Just got home from work let me sleep awhile maybe I can remember.
_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Mon 17 May 2010, 10:17    Post subject:  

Pango = font system, right? I was searching and couple or three years ago there was a post suggesting disabling Pango when Seamonkey/Mozilla/Firefox was started. Made it run faster on older machines or if the version of pango isnt compatible. So does Chrome absolutely require Pango or could it be simularly disabled?

Ok, here is command:

export MOZ_DISABLE_PANGO=1 and has to be put into mozilla-bin file before it calls seamonkey-bin file.

Is there a way to do this on chrome? And still leave Chrome functional? Somebody mentioned using it on a non-mozilla related program that was throwing up same error but no details.
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Mon 17 May 2010, 20:12    Post subject:  

Never thought about trying it add it as a startup like
google-chrome --DISABLE_PANGO and see if that works, that is the same for disabling the sandbox

If that does not work you can save your save file to a safe place like a thumb drive and install pango from here
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/
This is still a pingo used in the 4 series of puppylinux and I do not believe it will give you any trouble.

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Mon 17 May 2010, 21:39    Post subject:  

The disable Pango doesnt work. Too bad.

I am using full expanded install of Puppy. To try Chrome with the newer Pango, will boot from cd and create a save file on spare hard drive so I dont endanger current Puppy install. But be couple or so days. Alas, there are higher priority things in my life at the moment.
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Mon 17 May 2010, 21:49    Post subject:  

I did not know that you had a full install so you are using a smart move. Let me know how it goes to that others can learn from what you find out. I started to download 4.2 myself but the server was a little busy. And I slept late tonight so not much time and will have to go back to work. May do it tomorrow night.
_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Tue 18 May 2010, 20:24    Post subject:  

Hi mouldy

I am unable to test Puppy 4.2 on my little laptop it does not support my wife card so the best I can suggest is you do a frugal install of 4.2 on your system and then try and see if the upgrade of pango affects anything on your system.

Sorry

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Tue 18 May 2010, 21:55    Post subject:  

Installed Pango 1.22.3-pup4.pet Did bad things to 4.2, crashed the Puppy package manager and wouldnt let me shut down properly and I dont know what all. I was glad I didnt try that with my current Puppy full install, been nightmare trying to straighten it out.

I'll just have to wait until I get broadband access some time and download newer Puppy in order to try Chrome browser.
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Tue 18 May 2010, 22:02    Post subject:  

I am glad that you test it that way too. That is why one of the reason I do mainly frugal install, that and I keep developing newer MyWolfe distro and it would be a real pain to install full install all the time.
_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
nekomaster

Joined: 01 Feb 2010
Posts: 23

PostPosted: Wed 19 May 2010, 22:06    Post subject:  

THis doesnt work, and I need a new browser because firefox keeps freezing every few minutes for a few seconds and its very annoying.

I installed both chrome and the libraries and when I try to start chrome nothing happens, it appers in the proccess manager but it doesnt appear on the desk top.
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Wed 19 May 2010, 22:13    Post subject:  

Hi nekomaster

I would be more than happy to help but I do need more information. Which puppy version are you using would help and also can you open a term window and type google-chrome and tell me what it says.

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Sat 29 May 2010, 10:38    Post subject:  

The new google-chrome-5.0.375.55-stable or beta this one does not have a beta number per say just an number
_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Fri 04 Jun 2010, 10:59    Post subject: some minor updates  

not muck

Quote:
Google Chrome 5.0.375.70 has been released to the Beta channel for Linux, Mac and Windows to fix some crash and stability issues.


Enjoy

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0695s ][ Queries: 12 (0.0047s) ][ GZIP on ]