Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 17:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Lighthouse Pup 4.43 Gu2 215M
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 40 of 46 Posts_count   Goto page: Previous 1, 2, 3, ..., 38, 39, 40, 41, 42, 43, 44, 45, 46 Next
Author Message
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sat 10 Apr 2010, 17:08    Post_subject: Re: Panning in LHP 4.43 G  

moonguard12 wrote:
Is it possible to enable panning in LHP? I tried enabling it from the console, but panning was not an option.

If not, is there a way to upgrade to RandR 1.3? I tried upgrading from the Slackware repos, but it did not work.

Thanks.
I don't know about panning / xrandr. Gslapt states that xrandr is part of X11 so I suppose they would have to be updated together? I'm experimenting with Slackware-current with a newer Xorg 7.5 (in Slackware) and I will see if it can do it. I don't think it's possible to use Slackware's Xorg in LHP though. I wonder whether Xorg has been updated in Quirky or Lucid Pup. I think Barry was testing Xorg 7.5 in Quirky but then rolled back to 7.3 for Wary.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sat 10 Apr 2010, 18:00    Post_subject: Re: updating lhp  

Pete22 wrote:
Hello again,

I was able to update to gu1 even though the file said if failed. But the programs are different so I know it updated.

I did the same for gu2. Which also said it failed

Yes, the files were sitting next to each other.

I have now rebooted with pfix ram

The problem is, some of the fonts are not available. How do I fix that. So some writing looks all like little square boxes.

Also How do I get back to my own save file when I have to make a new one because I am in ram.


Thanks for helping a real greeney


Pete22
Hi Pete22,
What errors did you receive when running 'click-to-verify-LHP' after the xdelta3 update? If the md5s did not match for initrd.gz, vmlinuz or spup-443.sfs, something is amiss and I would delete those updated files and start over. All of the files, including the 'click-to-verify' and SFS add-ons were changed from 4.43f to 4.43Gu1. For Gu2 the SFS add-ons are the same as for Gu1.

After entering 'puppy pfix=ram' at the boot menu, copy your old pupsave to 'spupsave.3fs.save' or similar. The '.save' suffix will ensure that LHP won't try to load it and you'll have that as a backup just in case. Then you can reboot, (at prompt to save your session, choose no/cancel) and this time boot without 'pfix=ram' and then LHP will use your old pupsave with the new version. If things don't work as they should, reboot with pfix=ram and test again. If it still isn't right, I would download the full LighthousePup-4.43-Gu2.iso as the xdelta updates didn't match. If pfix=ram works, but using the old pupsave doesn't, make a new one with pfix=ram. You can always open your backup pupsave in ROX-Filer by clicking on it to mount and then and copy over what you need into your new file system.

The fonts should all work, with the possible exception of non-LHP documents / web pages created in a different language / character set. On occasion a software update will cause the square boxes but restarting X should fix that. If not, a new ISO with verified md5 and a new pupsave is the best option.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1073

PostPosted: Sat 10 Apr 2010, 23:13    Post_subject: Re: Panning in LHP 4.43 G  

tazoc wrote:
I'm experimenting with Slackware-current with a newer Xorg 7.5 (in Slackware) and I will see if it can do it.

tazoc wrote:
Thank you 01micko, LHP444 is in a very early stage, with an updated glibc-2.11


Someone is going to make Christmas come early if he manages to make those two things happen. Razz

Thanks for the help on the vbar. I've made a temporary static one, but it doesn't always fit the bill. I use a laptop and as such I only plug in certain external drives when I need them. So the drives on my system are constantly fluctuating. But thats ok, i'll continue to poke around at it in my spare time. Thanks for the information and help so far. Smile
If you're curious... My current desktop
Back to top
View user's profile Send_private_message Visit_website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sun 11 Apr 2010, 20:31    Post_subject: Two new add-ons for Lighthouse Pup  

@Q5sys,
Those are very cool screen shots and wallpapers! Cool After seeing your vertical Wbars I just figured out how to make the icons line up vertically.
( wbar -pos left -vbar )

@All,
Here are two new add-ons for Lighthouse Pup:

OpenOffice-3.2.sfs 152M (Needs Mariner SFS for Java)
* Based on an SFS by Dingo plus a few minor tweaks for Lighthouse

Graphics-3in1-c.sfs 66M (Needs Mariner SFS for Qt3)

* Includes Blender 2.49a + Inkscape 0.47 + Scribus 1.33.13

Thanks to abushcrafter for locating Inkscape 0.47 Very Happy
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1073

PostPosted: Sun 11 Apr 2010, 22:17    Post_subject: Re: Two new add-ons for Lighthouse Pup  

tazoc wrote:
@Q5sys,
Those are very cool screen shots and wallpapers! Cool After seeing your vertical Wbars I just figured out how to make the icons line up vertically.
( wbar -pos left -vbar )

@All,
Here are two new add-ons for Lighthouse Pup:

OpenOffice-3.2.sfs 152M (Needs Mariner SFS for Java)
* Based on an SFS by Dingo plus a few minor tweaks for Lighthouse

Graphics-3in1-c.sfs 66M (Needs Mariner SFS for Qt3)

* Includes Blender 2.49a + Inkscape 0.47 + Scribus 1.33.13

Thanks to abushcrafter for locating Inkscape 0.47 Very Happy
-TazOC


Yea I had to play around with the offset to get it to get way up there in the corner, it still wanted to sit down quite a bit for me even with the -pos top-left
The full code i went with is
Code:
vbar -config /root/.vbar -vbar -above-desk -jumpf 0.0 -pos top-left -offset -40 -nanim 3 zoomf 2.5 -isize 34 -idist 0 -bpress -balfa 0 -falfa 100 >/dev/null

If anyone wants the two wallpapers ill up them so people can grab them. Both of them are 1280x800. I have a larger version of the Stargate Atlantis one.
Back to top
View user's profile Send_private_message Visit_website 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Mon 12 Apr 2010, 15:00    Post_subject: Re: Two new add-ons for Lighthouse Pup  

tazoc wrote:

@All,
Here are two new add-ons for Lighthouse Pup:

OpenOffice-3.2.sfs 152M (Needs Mariner SFS for Java)
* Based on an SFS by Dingo plus a few minor tweaks for Lighthouse
-TazOC


Any chance of getting the OxygenOffice version of OpenOffice?

It has some extras beyond generic OO.

Thanks for everything you are doing!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send_private_message Visit_website 
turnip

Joined: 10 Feb 2009
Posts: 41

PostPosted: Tue 13 Apr 2010, 02:08    Post_subject:  

Maybe you should advertise this puplet on distrowatch.com, theres absolutely no compiz supporting distro that are lightweight, maybe that can be your catch?

I know I was looking for a long time for one, some people dont have the greatest hardware, and dont want something ugly just because of it. Or maybe people that want to maximize their hardware usage without looking ugly at the same time.
Back to top
View user's profile Send_private_message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 13 Apr 2010, 21:28    Post_subject: Re: Two new add-ons for Lighthouse Pup  

edoc wrote:
Any chance of getting the OxygenOffice version of OpenOffice?

It has some extras beyond generic OO.

Thanks for everything you are doing!
The Linux release of OxygenOffice is at 3.1.1 (Sept 2009) I don't know why 3.2 isn't available yet. I'll see if I can get 3.1.1 for you.
turnip wrote:
Maybe you should advertise this puplet on distrowatch.com, theres absolutely no compiz supporting distro that are lightweight, maybe that can be your catch?
Good idea, I submitted release details of Lighthouse 4.43F to distro@distrowatch.com on Jan 31, 2010 and someone else did as well last August. Never heard back from anyone except that we are on a long waiting list.
Quote:
Lighthouse Pup (submitted on 2009-08-31)
I don't think we're quite lightweight enough to submit as an official Puppy release, and I think that may be about the only way to get announced.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 13 Apr 2010, 22:11    Post_subject: 4.43 G update 3 bug fix PET package for LHP 4.43 Gu2  

Gu3 PET update attached--what's included:

SeaMonkey - fix for spaces in path/filename

CUPS Printer Wizard web interface and network printer detection

MuppyQuickmount can repair ext4 partitions

/etc/init.d/dbus and /etc/rc.d/pup-dip updated

pixman-0.17.14-q library update and /usr/bin/xcompmgr replaced

This PET includes a fix (pixman-0.17.14-q) for black icons in JWM that may result from installing the alternative Xorg/xserver 1.6.3/Intel pets. I recommend installing this Gu3 PET both before, and again after installing the Xorg/xserver 1.6.3 update. This Gu3 PET should be fine for all Gu2/3 machines, but the Xorg/xserver update is recommended only if you have an Intel graphics adapter, as it is not compatible with the proprietary ATI and nVidia drivers in the Mariner add-on.

[Edit 2010.04.14 I updated yesterday's Gu3 PET to '3b' to fix instability in KDE4. If you have the earlier version, just re-install this one.]

-TazOC
LHP_4.43Gu3-G_update3b.pet
Description  4.43 G update 3 bug fix PET package
Recommended for LHP 4.43 Gu2 only
MD5: 43630b926cb76f4b944e996bac0582af
pet

 Download 
Filename  LHP_4.43Gu3-G_update3b.pet 
Filesize  350.36 KB 
Downloaded  815 Time(s) 

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Wed 14 Apr 2010, 13:39    Post_subject:  

I updated the Gu3 PET in the previous post to Gu3b to fix instability with SeaMonkey and KDE4. If you have the earlier version, please install the new one. It includes everything from Gu3. The only change from Gu3 to Gu3b is in the file /usr/bin/mozilla.
Thanks,
TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
gheramagni

Joined: 30 Mar 2009
Posts: 6
Location: Florence, Italy

PostPosted: Wed 14 Apr 2010, 15:50    Post_subject: cannot install pet update LHP_4.43Gu3-G_update3b.pet  

Hi,

I cannot install the pet update, If I doubvle click on it it tries to open an archive file, usually on other puppy version I am able to install pet files simply clicking on it
thanks

bye

Gherardo
Back to top
View user's profile Send_private_message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Wed 14 Apr 2010, 17:51    Post_subject: Re: cannot install pet update LHP_4.43Gu3-G_update3b.pet  

gheramagni wrote:
I cannot install the pet update, If I doubvle click on it it tries to open an archive file, usually on other puppy version I am able to install pet files simply clicking on it
Yes, in ROX-Filer a single left-click should begin the install. What version of Lighthouse are you running? Does the file you downloaded display a PET icon in ROX? Right-click | MD5sumGUI and compare that with the MD5 posted with the Gu3b update. If the MD5sum doesn't match please d/l the update again.

If the MD5sum matches, then right-click on it in ROX-Filer | Set Run Action and enter
Code:
/usr/local/petget/petget "$@"
and click 'Use Command'. Then a left-click should open the PET with Puppy Package Manager.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send_private_message Visit_website 
Newuser

Joined: 31 Mar 2010
Posts: 18

PostPosted: Thu 15 Apr 2010, 08:53    Post_subject:  

Hi people I hope you all good.

Need some advice I dl a mariner sfs this morning and it did not do what I hoped it would do according to lhpuppy the sfs is a older version and not useable does this mean I wasted my time dl it?It did flash a message that there was a sfs converter somewhere.
Any help appreciated as always.
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Thu 15 Apr 2010, 10:16    Post_subject:  

Yes, you downloaded the wrong version. What Lighthouse version are you using? The latest is LHP 4.4.3 Gu2 and your Mariner version should also be the same version 4.4.3 G. If not, you may have problems and the older 3 series versions may not work at all even when converted to 4 series.
_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send_private_message 
Newuser

Joined: 31 Mar 2010
Posts: 18

PostPosted: Thu 15 Apr 2010, 14:59    Post_subject:  

I can confirm that I am using the latest version of lhp the version of mariner is 5-lhp-mar-4f_412sf
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 40 of 46 Posts_count   Goto page: Previous 1, 2, 3, ..., 38, 39, 40, 41, 42, 43, 44, 45, 46 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1216s ][ Queries: 13 (0.0248s) ][ GZIP on ]