Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 14:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
IHU: QT3-based VOIP communication program
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Wed 18 Jun 2008, 08:38    Post subject:  IHU: QT3-based VOIP communication program  

http://ihu.sourceforge.net/

Quote:
IHU is a Voice over IP (VoIP) application for Linux (using Qt), that creates an audio stream between two computers easily and with the minimal traffic on the network.




This has been compiled using qt3 libraries, so needs qt-3.3.8.pet. As well it requires jack, speex, ,libgmp.so.3.4.2 and libgmpxx.so.4.0.2. These last two are included in the ihu .pet.

Run via Menu->Internet->IHU

For usage, please refer to /usr/share/doc/ihu/manual.html.

N.B. Because qt-3.3.8.pet was compiled against openGL, this is also needed for IHU to work. Or, if you want to install the static version of IHU, which doesn't need openGL, jack, speex or QT3 libs, it's available here(2374kbytes): ihu-0.6.0.pet.
ihu-0.6.0.pet
Description 
pet

 Download 
Filename  ihu-0.6.0.pet 
Filesize  281.34 KB 
Downloaded  656 Time(s) 

Last edited by muggins on Tue 04 May 2010, 07:31; edited 1 time in total
Back to top
View user's profile Send private message 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Sun 11 Apr 2010, 04:27    Post subject:  

Which Puppys have the necessary Qt3 included by default?

I am for looking this -- or something that will do a simple point-to-point call like ihu does -- for Puppy 4.31-based installs. I have already had to install qt4-4.3.2.pet to support a static build of Opera.

-Roy
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Sun 11 Apr 2010, 06:38    Post subject:  

Roy,

going on my memory...it was a while back...I think it needs qt-3.3.8.pet.

If you have no luck with this, can you post back & I'll try & work out what it needs?
Back to top
View user's profile Send private message 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Sun 11 Apr 2010, 14:21    Post subject:  

Wow, muggins! I didn't expect such a quick reply!

I am in the process of moving, so will need a while to get things sorted out before trying this.

As a non-expert (read: dumb end-user), I have a small amount of fear that installing qt3 will break something in the later qt4 puppys (and running full installations, I cannot restore everything as quickly as I would necessarily like).

I'll try to report back when I can.

Thank you.

-Roy
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Sun 11 Apr 2010, 18:48    Post subject:  

No, installing qt-3.3.8.pet doesn't disrupt qt4.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10669
Location: Arizona USA

PostPosted: Sun 11 Apr 2010, 20:05    Post subject:  

Muggins, your link to the qt-3.3.8.pet doesn't work for me. There appears to be something wrong with the ibiblio server. Only part of its puppylinux index is working.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Sun 11 Apr 2010, 22:00    Post subject:  

Flash,

can you try it again, as it worked for me 1 minute ago. Might be a temporary ibiblio problem?
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10669
Location: Arizona USA

PostPosted: Sun 11 Apr 2010, 22:30    Post subject:  

The first image is the index. Note the question marks to the left of the file names. The second image is what I get when I click on the link.
Ibiblio index of pet_packages-3.jpg
 Description   
 Filesize   37.03 KB
 Viewed   1487 Time(s)

Ibiblio index of pet_packages-3.jpg

Ibiblio qt-3.3.8.pet.jpg
 Description   
 Filesize   66.53 KB
 Viewed   1492 Time(s)

Ibiblio qt-3.3.8.pet.jpg

Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 11 Apr 2010, 23:44    Post subject:  

Flash wrote:
The first image is the index. Note the question marks to the left of the file names. The second image is what I get when I click on the link.


right click on the link and select "Save Link As"
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10669
Location: Arizona USA

PostPosted: Mon 12 Apr 2010, 00:10    Post subject:  

ttuuxxx wrote:
... right click on the link and select "Save Link As" ...

That worked, at least to download the (3 MB) .pet file. We'll see what happens when I try to install it. Smile
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10669
Location: Arizona USA

PostPosted: Mon 12 Apr 2010, 00:18    Post subject:  

The qt-3.3.8 and ihu.pets appeared to install correctly. When I clicked on IHU VOIP in the Internet category, nothing happened. When I entered ihu in a console I got this:
Quote:
# ihu
ihu: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory
#

_________________
Puppy Help 101 - an interactive tutorial for Lupu 5.25
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 12 Apr 2010, 00:24    Post subject:  

Flash wrote:
The qt-3.3.8 and ihu.pets appeared to install correctly. When I clicked on IHU VOIP in the Internet category, nothing happened. When I entered ihu in a console I got this:
Quote:
# ihu
ihu: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory
#


did you download jack and speek?
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=7867
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-3/speex-1.1.12.pet
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Mon 12 Apr 2010, 01:30    Post subject:  

Flash,

yes, as mentioned by ttuuxxx, you need JAck & Speex. There are links to these in the first post.
Back to top
View user's profile Send private message 
tubby

Joined: 24 Jan 2009
Posts: 317

PostPosted: Mon 12 Apr 2010, 05:05    Post subject:  

As i use skype i have installed IHU on a computer running 431 and it appears to open up ok, a couple of libraries were needed so i used the debian ones i have on another computer and all seems to be ok.
All i need now is an ip address to call.
Back to top
View user's profile Send private message 
tubby

Joined: 24 Jan 2009
Posts: 317

PostPosted: Mon 12 Apr 2010, 08:26    Post subject: connection  

I have succesfully connected two of my computers on my local wireless network using IHU one running 431 and one running Quirky018, allowing port 1793 in the firewall was necessary to stop the call being rejected.
The missing libraries i used were debian ones from one of my other computers, no problems in either builds. Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0993s ][ Queries: 13 (0.0356s) ][ GZIP on ]