Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Jul 2015, 01:20
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Quirky 018 feedback
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 17 Posts_count   Goto page: 1, 2, 3, ..., 15, 16, 17 Next
Author Message
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Wed 07 Apr 2010, 08:20    Post_subject:  Quirky 018 feedback  

The latest and greatest Quirky has arrived!

See blog announcement:


Note the buglets.

Feedback is welcome!

Back to top
View user's profile Send_private_message Visit_website 

Joined: 02 Jul 2008
Posts: 768
Location: West Wales, Britain.

PostPosted: Wed 07 Apr 2010, 08:51    Post_subject:
Sub_title: SFS file to compile drivers

Thanks, Barry. Downloading now.

In a previous post you wrote "I also created an SFS file, so when the next Quirky is released, users will be able to compile drivers." Is this available for download?
Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Dec 2008
Posts: 1462
Location: North Lincolnshire. UK

PostPosted: Wed 07 Apr 2010, 08:53    Post_subject:  

Ooooo, nice. Very Happy

Happy to report all basic setups ran OK and a frugal install created a nice pupsave in ext3.

Network running, internet access OK.

Posting from 018 now.

The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Dec 2008
Posts: 1462
Location: North Lincolnshire. UK

PostPosted: Wed 07 Apr 2010, 09:00    Post_subject:  

Freemem applet seems to be working after running fixmenus.
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send_private_message Visit_website 

Joined: 07 Apr 2009
Posts: 2340
Location: Ontario Canada

PostPosted: Wed 07 Apr 2010, 09:11    Post_subject: Quirky 018 feedback
Sub_title: seamonkey

I downloaded 018 this morning and did a frugal install, looking good so far.Seamonkey in 010 would crash when I tried to play a youtube video but the updated Seamonkey works fine.Lots left to explore Smile
Back to top
View user's profile Send_private_message 

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 07 Apr 2010, 09:37    Post_subject:  

Wow Q015 then never surfaced to us?

Okay so 18 is the number. I dl it and did a frugal and tested mpg and avi but mp4 fails and .flv fails to play. Streaming video in Vesa works as well as on q013 and streaming radio and rm files works good too but I fail to get it to work with nvida in xorg.

I had hoped it would detect the NV correctly.

# report-video
VIDEO REPORT: Quirky, version 018

Chip description:
product: G98 Board - 5610001u Chip Rev

Driver used by Xorg:

Video mode used by Xorg:
Resolution: 1024x768 Depth: 16

...the above also recorded in /tmp/report-video

When I tried the test in Xorg it show a red square on a green background so that one failed to work. Had to start all over with vesa instead.

I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
James C

Joined: 26 Mar 2009
Posts: 6257
Location: Kentucky

PostPosted: Wed 07 Apr 2010, 10:36    Post_subject:  

I also did a quick frugal install on my P3 test box(onboard Intel graphics, sound and network) and everything is working well out of the box. Smile
Back to top
View user's profile Send_private_message 

Joined: 08 Jul 2009
Posts: 5467
Location: Finland

PostPosted: Wed 07 Apr 2010, 10:43    Post_subject:  

VIDEO REPORT: Quirky, version 018

Chip description:
product: M74 01.00

Driver used by Xorg:

Video mode used by Xorg:
Resolution: 1280x800  Depth: 24

Works fine. 6 sfs installed ok. Needs fixmenus before they are in the menu. Open Office 3.1.1 sfs included ok. Works now.
Thunderbird works also. No crashing. Alsaconf and audio ok. Ext3 savefile ok. Acer laptop brightness control works !!!
SNS works with wireless.

Looks really promising. Thanks.
Back to top
View user's profile Send_private_message 
James C

Joined: 26 Mar 2009
Posts: 6257
Location: Kentucky

PostPosted: Wed 07 Apr 2010, 10:59    Post_subject:  

I almost forgot............

VIDEO REPORT: Quirky, version 018

Chip description:
00:00.0 Host bridge: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller (rev 03)

Driver used by Xorg:

Video mode used by Xorg:
Resolution: 1024x768 Depth: 16
Back to top
View user's profile Send_private_message 

Joined: 26 Jul 2007
Posts: 974
Location: England

PostPosted: Wed 07 Apr 2010, 11:03    Post_subject:  

Running live cd on my Intel Celeron 600MHz/ 256MB machine.

Can't see the Share folder on my Windows machine. "Set up file sharing " does not work, (or I can't work out how to use it)..

lameSMBqmount > explore produces no results.

lameSMBexplorer does find the Windows m/c, but then what? Can't work out what I'm supposed to next.

So how do I do what Pnethood used to do?

Back to top
View user's profile Send_private_message 

Joined: 05 Sep 2006
Posts: 9938
Location: Stratford, Ontario

PostPosted: Wed 07 Apr 2010, 12:18    Post_subject:  

Some printing issues:

The file /etc/cups/snmp.conf has the odd ownership root:[7]. This prevents CUPS from detecting network printers. I changed it to root:nobody and did a CUPS restart.

The symlink /usr/lib/cups/backend/smb to /opt/samba/bin/smbspool is missing. This prevents access to Windows shared printers.

The file /etc/opt/samba/smb.conf needs to be world-readable.
Back to top
View user's profile Send_private_message 

Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 07 Apr 2010, 12:50    Post_subject:  

Video report: Intel.

On 700m laptop, intel 855g.
Using "probe"->"more", and 1024x768, 16 depth works fine.
Using vesa allowed 1024x768, 24 depth.

On Dimension 3000pc, intel 82865g, works fine with multiple
resolutions possible.


Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 

Joined: 19 May 2008
Posts: 2460
Location: Texas, USA

PostPosted: Wed 07 Apr 2010, 12:53    Post_subject:  

Hi Barry,

"Latest and greatest." AMEN! Sound and printer set up flawlessly. Fast and stable. Love the new icon set!

One problem, the 4fs save file doesn't work. Using a frugal installation on an ext4 partition, entered system values, rebooted, created a 4fs save file, however it was not recognized on the next reboot. The icons were all messed up also after entering the new setup information. Therefore, I just deleted the corrupt 4fs save file, rebooted using GRUB, went through setup again, and saved as 3fs. The 3fs save file works fine.

EDIT: Created another new 4fs file on an ext4 partition, same results as above.

Thanks for sharing Quirky,
Jim Very Happy

Favorites: Lighthouse 64 and Lucid + theWord

Back to top
View user's profile Send_private_message 

Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Wed 07 Apr 2010, 13:13    Post_subject:
Sub_title: q018 testing

dotdelta(s) dl'd nicely (that is a whack of drivers - hope they fly on a goodly range, are fairly easy to select at boot and end the xorg back'n'forth Neutral ).. buglets may actually be viewed as diagnostic-related testing features (to bodge a phrase from the rox dev-team handbook, Laughing )

will edit-in more L8r..
___100414 update_________
1st session didn't save - lost when it timed out as I was reading. I found the savefile typechoice stuff I was looking for the 2nd time through..

Well, a sort of coldboot+dummy-intermezzo-with-xorg+reboot gets q018 started 'on its own' .. kind of a roundabout workaround but it's doable (if I can remember the dummy steps). Some amenities in and ob in a better 'working trim' (more efficient without a roxpin and pfbpanel 'on-demand' if desired). It was a bit of a struggle getting it correct, but got save2flash to give a choice of save/no-save at reboot or poweroff (gave up on in-session save Neutral , much too dependent on whatever background stuff I unticked maybe).

Other 'box wms are well-suited for this pup (blackbox and fluxbox as well as wmx7).

Tried 01micko's jwm478 (from lupup04 thread) to see if things have changed alpha-wise in relation to that issue - a non-starter that was (needs the 2.11 libc set it seems rather than the 2.10.1). Might be a venue worth investigating for those who prefer jwm as 01micko reported the alpha issue was solved in lupup04?

Playing with pfbpanel - very nice, but (always a but, eh?) a few things.. The menu plugin doesn't stay expanded for long (about 4 sec?) and tends to contract back (good or bad depending on how slow the user is) - twitchy. Panel 'disappears' if dock option is unticked (shows in htop as up but ?, not iconified since it doesn't show in clientmenus - maybe a skip* option is set somewhere). /bin/bash /usr/sbin/pfbpanel stays up after an "OK" (but not a quit) .. may be because I took it off the menu and put it on a launch Neutral . Auto-hidden panel pops out a bit 'early' (maus proximity about twice the distance as panel height), otherwise good response. Probably too much to look for a provision for separate profiles rather than a single default. Some things really need to be wm-specific - like fluxbox already has a systray if the toolbar is on, the pager likely won't work as well as native pagers like afterstep's and even simple plugin-buttons like the minimize/shade can be tricky (depending). Almost hate to say it, but jwm's tray system was/is elegantly simple and efficient. This one's fun, really like the var/local/icons sym-storehouse for getting most icons in a local 'repo' (should come in handy for getting a standard path for many things that use 'em).

It *was* going well. But the new (since q010) fs check thing bit me or I must have made some fatal errors in regard to it - upshot is my savefile for q018 is gone.

All was good, I used the increase savefile size utility to add 32mb to a 64mb savefile since by freemem I only had 41mb left and was planning on doing some fair-sized adds after the reboot-save. Reboot (chose to save) and it saved .. entered "puppy acpi=force" at the splash/prompt, selected the proper savefile .. it started and UHOH.

..reams of error messages streamed - when it finally ended - nnnnnnnnnn is 10 digit numbers
(many mssgs similar to following line)
EXT3-fs error (device sde4): ext3_free_branches: Read failure, inode=28, block=nnnnnnnnnn
...continuing with loading /quirkysave-eighteen.2fs... done
Loading the 'quirky-018.sfs' main file... done
Kernel panic - not syncing: Attempted to kill init!
..and an ungraceful crash (flashing kybd leds, no kybd response on prompt-blink on display->hardoff). Now what? Since it saved oki, decided to check in good old q008 since it's a multisession liveCD and is predictable/similar/can do all the fs and sfs. A quick check of the sde4,ext3 quirky partition looked oki (as expected, the fsckme.err file was gone and the savefile for q018 never got to the point where the size could be increased at reboot). Unmounted and ran a check on it in GParted. Remounted and looked at it again -
do NOT do the following italicized passage..
then I decided to make a new fsckme.err file with content "sde4,ext3,/quirkysave-eighteen.2fs" since I *hate* going thru the freaking xorg runaround when it doesn't find the fsckme.err file and therefore won't find the savefiles and goes to xorg initial setup nonsense. In hindsight it may have been wiser to simply dummy-guess thru xorg on that whacky workaround to coldboot q018 on its own and get to a reboot so it would more-or-less do what it should. .. reboot from q008 (nosave and it pops the q008 disc, throw the bootdisc for q018 in and hit enter) .. q018 splashes, goes to mssgs and hunh it's performing 3fs check on sde4 before it goes to select savefile and aw geeeeez .. no savefile for q018 in the list (it was definitely there when I left q008). Punch the casebutton and get q008 back up and look at the good news. Oh well.
.. as a matter of fact, really try to avoid hardoffs (I didn't quite understand how the fsckme.err file is removed on an orderly shutdown and may just not be such a good idea to create it manually .. add to that the resize and it could quite possibly go to the uh-oh%#&@ stage if things go real wrong.

Sprinkle in the black on blue select colorscheme of console interface once you're there... yah, you know xorg is 'right' when it's quite difficult to read what's selected in the dialogues (makes perfect sense in an xorg way). Now using an ext3 savefile on the thumbdrive, maybe I'll get it more-or-less doable by the time p5xx comes out if I can remember all the ways to mess up Rolling Eyes

Pretty much fixed, even got through the coldboot 'dummy' run with xorg to get to a reboot (when it actually finds the savefiles) - I can get to a prompt if I remember where to detour out after the first few dialogues (pfix=nox doesn't go to it right away..). Got my own icontheme in and used iconswitcher and arrrgh up pops a roxpin in blackbox. Then openbox wouldn't come up? it clicks back to prompt Confused Looked at a few logs and unticked stuff in /root/Startup to make it non-exec (traytemp and vattery seem to be causing probs?) and some other stuff. blackbox and fluxbox are oki, just ob won't start Neutral . (partial log in attach 1)

Perhaps openbox now needs a roxpin to start? Or rox needs to have pinboard and panel unchecked in options? Or what's the deal with having openbox's original oem menu.xml (and it's only the 'main' menu - neither the top or bottom is there as on what was the working full menu.xml)on / dir? (it worked fine in the 'usual' /root/.config/openbox dir .. obmenu-refresh does what it should, etc). As far as I can tell, dbus should still be oki (yah, took a look at /etc/xdg/autostart.sh) and bootmanager->services,messagebus is ticked so ..?

did a very slight mod of Mikachu (attach 2), but since ob won't start in q018 for me now .. bigger image 221k done in the still-going-strong q010 Smile

" tells of two tribes of ancestral spirits who were invited to a feast, but were distracted by the beautiful Sleepy Lizard Women and did not show up. In response, the angry hosts sang evil into a mud sculpture that came to life as the dingo. " (to be continued)
Description  partial bootkernel.log in bootkernel.zip

Filename  bootkernel.zip 
Filesize  2.33 KB 
Downloaded  423 Time(s) 
Description  md5 = 744b0d90a3582c971f138b0355fe0af9

Filename  mikafu.tar.gz 
Filesize  1.4 KB 
Downloaded  446 Time(s) 

Back to top
View user's profile Send_private_message 

Joined: 30 Sep 2005
Posts: 1104
Location: Vienna Austria

PostPosted: Wed 07 Apr 2010, 13:26    Post_subject:  

Nice one!

Sound detected OK
Video detected OK first time using ATI Radeon 3450 video card.
RT73usb WLAN interface detected OK but doesn't connect using either of the wizards. Module may need re-compiling for this latest kernel.

Did a work-around to get the Brother DCP7030 printer/scanner to work. Installed dpkg from Debian Unstable and libc6 also from there.Then created dummy /var/lib/dpkg/status and /var/lib/dpkg/available files. The built-in dpkg in Quirky/Busybox doesn't seem to work. I then ran dpkg -i --force-all "name of driver(s)" from the command-line and all was well. dpkg from busybox does not seem to be able to handle the "--force-all" parameter. Scanning OK using the Brother brscan3 driver.

Seamonkey 2.0.4 is good. It allows a lot more Firefox type extensions to be installed. A big improvement over the Seamonkey 1.1.* series. I have much less need of Firefox now.

General impression is very fast and stable. Will play with it further.

Life is too short to spend it in front of a computer
Back to top
View user's profile Send_private_message Visit_website AIM 
Display_posts:   Sort by:   
Page 1 of 17 Posts_count   Goto page: 1, 2, 3, ..., 15, 16, 17 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1171s ][ Queries: 13 (0.0123s) ][ GZIP on ]