Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 19:12
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Puppy On Laptops
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 8 of 22 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 20, 21, 22 Next
Author Message

Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Wed 17 Mar 2010, 00:07    Post_subject: Toshiba 490CDT
Sub_title: Online at last!

I've installed Puppy 214XRC3 Frugally to this very old laptop (1998) which has
a PII 233MHz CPU; 160MB Ram; 1.4GB HDD; CD Rom; USB Port; and now
an external modem via the Serial Port.

The internal modem wasn't detected by Puppy so I finally remembered that
I had an external modem which should be useful to solve this dilemma.

And it did!

Next will be upgrading the Hard Drive to some bodacious capacity.

Puppy is remarkably fast on this old machine. Wonder of wonders!

Win 98SE remains available as a boot option should there ever be a
need to run from WinDoze, however, I just can't imagine why I would...


P.S. Forgot to mention, I'm online with this old machine right now!

Shuttle Spacewalker HOT-661/P Main Board:
PII-350MHz: 640MB RAM: First Puppy: 2.00
HDD Filesystem: FAT32/NTFS/ext3; Frugal Always
Back to top
View user's profile Send_private_message 

Joined: 18 Nov 2009
Posts: 46

PostPosted: Wed 17 Mar 2010, 06:35    Post_subject:  

i tried to get puppy running on two laptops from the paleolithic era..
they did not have usb ports, one was 133mhz one was 166mhz, both had probably about 32mb ram. it never got past the part where it decompresses vmlinuz or one of those things.
well, i tore those apart..
now i just bought a really nice laptop. kinda plain on the looks, but it's what's on the inside that counts. and for the price of $460, it's unbeatable. 4gb DDR3 (my desktop has 2gb DDr), 320gb hd (which really = about 300gb after that metric conversion. desktop has 1tb but until november2009 it only had 160gb) 2.2ghz dual core pentium. (my desktop has 2.4ghz athlon64. all that and my desktop cost more to build. but that was in 2006.
anyway, i use the windows7 during the day usually, but at night i boot into puppy4.31. i don't even save the configuration to the stick. everytime i change the boot priority in my bios to check the usb first, it resets itself either after i remove the usb stick, or after i let it boot into windows7. that's no problem, i have a reasonable amount of time to press f12 after powering on, to tell it to boot from usb.
the laptop has an HD resolution. 1366x768 i believe. there is a 1360x768 in xorg so i use that when i use xorg. xorg allows my touchpad to function as a scroll wheel on the right side, but strangely also as a back/forward navigation buttons that would be on a mouse, on the very bottom right corner of the touchpad. that can get annoying, because there is no button to toggle power to the touchpad on this laptop. i boot into puppy and pull out the stick, run all night in ram. i do this to keep the hard drive from spinning, because laptops get pretty hot when you use them on a bed.
xvesa is the fastest, but there is no resolution close to 1366x768. the screen still fills up, but hd video is skewed because of it. and the scrollwheel function of the touchpad is not there. that is nice though, because i also dont accidentally leave webpages because of an accidental touch. i just hook up the laser mouse and the scrollwheel works on it. another plus is touch tapping works automatically in xvesa.
but if i want to watch nice looking videos, i go into xorg. then i have to enable touch-tapping and restart x. then since i figured out the bottom right corner functions as a mouse forward/back button, if i swipe left or right, i can take advantage of that, because my mouse's back button always does funky things in puppy.

puppy linux seems to recognize that i have about 3gb of ram, but it always says 1.4G free. but i actually have 4gb. i guess it's because it's DDR3.
puppy works very well.
i bought a similar laptop, but with a sempron cpu and ddr2. it wouldnt boot puppy. i returned it the next day and got this one for $30 more at bestbuy.
if you need a new laptop, you might be interested in the fact that the one i just bought JUST dropped $30 bucks in price. i thought it was awesome for $460 after tax. now it is $400 before tax, which brings it to about $430 after tax. http://www.bestbuy.com/site/Toshiba+-+Satellite+Laptop+with+Intel%26%23174%3B+Pentium%26%23174%3B+Processor+-+Silver/9784839.p?id=1218173777875&skuId=9784839
it runs awesome and i use the wifi on puppy all the time.
Back to top
View user's profile Send_private_message 

Joined: 26 May 2008
Posts: 1575
Location: Austin, TX, USA

PostPosted: Wed 17 Mar 2010, 10:03    Post_subject:  

Sorry, CatDude, just saw this thread.

My most frequently used computer is my Puppy 4.2.1 on a Toshiba Tecra. Works like a dream. Frugal install, love it. Native (internal) wireless runs great. It has an ext2 partition and a swap partition.

I also have another laptop I use but I'll have to get the spec's on it later today; that one is a save file on an old 3.5 gig hard drive that I stuck in there, using a MacPup livecd to boot. The laptop is relatively recent even though the hard drive is older. I use a belkin usb wireless that works great on this one. The drive is ext2 or vfat; can't remember. I don't save anything on that one as it is just 3.5 gigs, so only the save file is on there.

One comment: laptops can run hotter on Puppy than on XP, I've noted. This thread is indispensable in solving that. The 4.2.1 install runs very quiet and cool since I took the steps outlined in that thread, while the MacPup one gets really hot and the fan runs constantly, since I haven't applied anything to that one. I only use it briefly every once in a while (when I don't feel like getting my "real" laptop, the Tecra, out of my back pack) for quick internet access. Cool

Edit: oh, and I installed a custom pinky-ish puppy on my wife's laptop, but have to get the spec's on that one. All of these I periodically use a boot-cd to boot to usb for 4.3.1 to use for cleaning up the save files and cleaning the file-systems via e2fsck.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 28 Apr 2009
Posts: 5

PostPosted: Wed 17 Mar 2010, 23:12    Post_subject:  

I have an Acer Aspire 4730Z that I bought last year for $400, so even though it's new(ish), it's still bottom of the line. It's got a 2.16gz Pentium Dual-Core, an Intel GMA950, and 2 gb of RAM. It's got some sort of Atheros wireless card. I forget the exact model, but it's one that uses ath9k. 250gb hard drive set up to dual boot Slackware 13 and Puppy 4.31. Only thing I had to do to get Puppy running right was install 915resolution. I had to grab one from the forums because the one in the repository didn't recognize my graphics card. Other than that, everything works perfectly. Thanks for that link steve_s, I'll work on that tomorrow.
Back to top
View user's profile Send_private_message 

Joined: 08 Apr 2007
Posts: 259

PostPosted: Thu 18 Mar 2010, 14:26    Post_subject:  

puppy linux seems to recognize that i have about 3gb of ram, but it always says 1.4G free. but i actually have 4gb. i guess it's because it's DDR3.

No, it's because puppy, as all 32 bits os, cas address at max 3 Gb of ram...
Back to top
View user's profile Send_private_message 

Joined: 03 Feb 2009
Posts: 20
Location: Alberta, Canada

PostPosted: Fri 19 Mar 2010, 15:06    Post_subject: Puppy on HP Omnibook  

Ancient but clean HP Omnibook 4150

Mobile Pentium ll , 350 Mhz
256 Meg Memory
14" display (Using 1024X768 right now
PCMCIA CArds: Xircom Ethernet plus modem, D-Link Airplus G wireless.
6.05 gig hard drive
HP optical ps/2 mouse
One USB port - needs a mini hub to use memory sticks as they are too big to fit through the case to the slot.

Preparation: Wipe deleted the HD with Darik's Boot and Nuke. Partitioned:
sda1 fat32 1.55 Gb Win 98 (just used for Freecell!)
sda2 extended:
sda5 EXT3 3.9 Gb
sda6 linux-swap 605.36 Mb

Linux systems:
1. Fast - booted off the CD
Puppy linux 4.3.1 with the kernel
Everything but the sound works, the Neomagic Sound card problems are well documented elsewhere and I usually shut sound off anyway.

2. A bit slower but lots of bling:
Lighthouse Pup (Based on puppy 4.3.1)
I am typing this on it right now using Lighthouse pup booted from the CD with Firefox 3.6. This will also work (a bit slowly) with the Mariner sfs file on a memory stick. The adduser feature is also included for those who don't like going on line as root.

Originally I expanded the memory planning on installing Ubuntu but found Puppy linux does everything well.

It has also given me a taste for warm beer and putting shrimp on the 'Barby' .
Back to top
View user's profile Send_private_message 

Joined: 28 Feb 2010
Posts: 13

PostPosted: Mon 22 Mar 2010, 17:18    Post_subject: Puppy on ancient Sony Vaio  

I'm running Puppy 4.3.1 on a Sony Vaio PCG-F707.
It was a very smart laptop ten years ago - but it's a bit old now!
It has a 600 MHz PIII (Coppermine)
256 MB RAM (I expanded it from the 192 Mb it had when I bought it)
9 GB hard drive
I also have the docking station which has an ethernet port (works with Puppy)
It has a TP-Link branded PCMCIA wireless card I bought from Amazon for less than GBP 10.
The display is 1024 x 768.
I've invested in a new battery as well.

I tried Xubuntu last year - I could run the live CD, but when I installed it the upgrade download made it choke. I couldn't get Puppy to run then. I could get DSL to run, but it wasn't a very nice experience. I did install Win 2K which ran OK (the original OS was Win 98SE). Now I have a frugal installation and Open Office 3 as an SFS.

I haven't had much success with MacPup or Stardust.

Back to top
View user's profile Send_private_message 

Joined: 09 Mar 2008
Posts: 57
Location: Ann Arbor, Michigan Thinkpad T-23, T-60

PostPosted: Mon 22 Mar 2010, 18:16    Post_subject:  

I installed and run Puppy 3.XX on my daughter's IBM Thinkpad (T23) & on my Dell Latitude D420.

The D420 is an Intel dual core 1.2GHz 12.1" widescreen XGA ultra portable. It runs on the slow side due to a 1.8" hard drive. With Puppy 4.3.1 installed on a 8GB Activa & a 2GB PNY USB flash, the D420 is very fast!

Back to top
View user's profile Send_private_message 

Joined: 23 Mar 2010
Posts: 3

PostPosted: Tue 23 Mar 2010, 09:04    Post_subject: Puppy on DELL c600  

Dear People,

I am running Puppy Linux 4.3.1 from live CD on an old DELL Latitude c600 laptop and I am very satisfied. Screen resolutions are great and sound works immediately (which failed with Ubuntu). Surfing Internet goes fast and more than enough other usefull applications.

I helped a friend to configure her new laptop and she gave me this DELL in return. XP runs smoothly but surfing Internet was way too slow. I started experimenting Linux untill I discovered Puppy. XP is still an the HD. I tried installing dual boot but I couldnt get it up and running. Boot from USB is not an option on this oldie.

I was very pleasently surprized Puppy accepted a PCMCIA card for wifi, cuz if wifi had not worked with Puppy I would not use Puppy.

Also I noticed that the laptop doesn't need much extra cooling, the fan is hardly needed Razz

Processor: Intel PIII 700 Mhz Coppermine
RAM: 384 Mb (128 + extra 256)
Wifi: Sweex wireless LAN PC Card 140 Nitro XM (LW 141) PCMCIA
USB2: Sitecom USB2.0 Card (CB-003) PCMCIA

 Filesize   76.04 KB
 Viewed   6233 Time(s)


Back to top
View user's profile Send_private_message 

Joined: 09 Mar 2008
Posts: 57
Location: Ann Arbor, Michigan Thinkpad T-23, T-60

PostPosted: Wed 07 Apr 2010, 10:55    Post_subject: Dell Latitude D420 & IBM Thinkpad T-23
Sub_title: Puppy Laptop

I use Puppy on a classic IBM Thinkpad T-23 (2001), 1MHz and on a Dell Ultra Portable, Latitude D420, duo 1.2MHz (2008).

The Dell D420 --I installed Puppy 4.3.2 onto a Ativa 4GB USB flash Stick, using the Puppy Universal Installer. The main method did not work but the H. Peter Anvin Syslinus works like a charm.

I also have a Puppy 4.31 boot PNY 2GB USB stick that works with the D420

The pwigets 2.0.8 package works well. I use the CPU Temp, Analog Clock & calendar & battery monitor.

I got Firefox 3.6X (firefox-3.6.tar - bz2) installed and working using instructions found in this forum for Firefox 3.5X. NOTE: The instructions describe an earlier version of Puppy. For Puppy 4.31, Archiver looks differerent and is easier to use. You must still FIRST PREPARE Puppy by downloading and installing the 2 dependencies (sbus.pet and dbus-glib.pet)

Puppy makes the ultraportable D420 fly! A USB install & Puppy working from RAM memory works around the slow 1.8" hard drive (4200RPM)
Chhose the 1280x800x24 screen setting. Works well.

The three USB ports, External CD\DVD port, everything works.

My D420 bios is the most recent: A06 2/2/2008

I only use Windows when I have no other choice, which is occasionally.
Back to top
View user's profile Send_private_message 

Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Fri 09 Apr 2010, 18:44    Post_subject:  

I am running on a Toshiba Satellite L505D-S5965. I am also running Debian, Vista(!!!!), and Ubuntu (which broke today). Nothing works with my fn buttons but vista because of the h20 insyde bios. What a pain!
Back to top
View user's profile Send_private_message 

Joined: 20 Jan 2008
Posts: 300
Location: Germany

PostPosted: Mon 12 Apr 2010, 15:48    Post_subject:  

A new netbook: LENOVO S12 with NVIDIA ION graphics.

Edit 2011: With fluppy013 graphics and wifi run out of the box.
Many hotkeys work, too.
Dual Monitor resp. LCD projector work fine, too.
I never installed Puppy on HDD, booting off the USB flash drives works fine.

Original post 2010:
You need jrb's puppy431 modified for the built in broadcom wlan device. And you need gray's special driver package due to the graphics chip.
Puppy runs from a USB flash drive.
The netbook runs Windows 7, I'm going to try now to install Puppy frugal on HD.

Back to top
View user's profile Send_private_message 

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Tue 13 Apr 2010, 05:03    Post_subject:  

Laie wrote:
Puppy runs from a USB flash drive.
The netbook runs Windows 7, I'm going to try now to install Puppy frugal on HD.

I've heard stories that Windows 7 and Vista do not take kindly to having their partitions resized. You might have trouble afterwards getting Win 7 to Boot or, in the most grisly scenarios I've heard about, your Win 7 partition might be Totally Trashed. Doing a Frugal Install on Window 7's existing partition is probably OK, but I'd Backup everything first., including the Partition(s) that are invisible to Windows.

There's also the question of the Bootloader. I haven't heard how Win 7 takes to being Booted from a Grub installed by Puppy. You could continue to Boot from a Puppy CD, then you won't need to mess with the Bootloader until you're sure of what will work. You could do a Google on:

Windows 7 Grub bootloader

to see if you can find some guidance before taking the plunge.

Good luck with it Very Happy Please report back how it all goes.
Back to top
View user's profile Send_private_message 

Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 13 Apr 2010, 06:23    Post_subject:  

I've used Puppy gparted to resize Win98, Win2000, Xp, and Win7.
Then used Grub legacy on the mbr to boot Win and Puppies.
Never had a problem.

I don't recommend it to others that don't have restore disks
and backups.


Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Thu 15 Apr 2010, 02:53    Post_subject:  

I notice you don't mention resizing a Vista partition.

Did you go from XP straight to Windows 7?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 8 of 22 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 20, 21, 22 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1105s ][ Queries: 13 (0.0089s) ][ GZIP on ]