Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 21:57
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy Stardust 007
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 8 of 9 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9 Next
Author Message
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Tue 09 Feb 2010, 12:21    Post_subject:
Sub_title: Trying to install Mplayer
 

Thanks, abushcrafter for your interest.

The reason I'm asking is that I can't seem to get those pakages to install/run on Stardust so I'll quote my older post for refference.

Barkingmad wrote:
Hello

Is there a package of MPlayer that works with the 4.3 series Puppies?

I have tried three different ones so far on Stardust 007 and they all fail in different ways as follows.

First try: this release by big-bass that I've used on Puppy 4.1. This won't install at all -- Petget says "Error package failed to install"

Second was this one by tempstuous. This appeared to install OK and put an entry in the Multimedia menu but nothing appears to happen on clicking it. Trying to run it in a terminal reports a missing library -- libXvMC.

Lastly I tried something newer by MU (Mark). First installing the player then his frontend for it. The controls run but won't play anything so I tried this in the terminal and found a different library missing -- libXxf86dga.

I am about at the limit of my Linux knowledge so any suggestions would by helpful, thank you

Will


I have used bigg-bass's version OK before but on 4.1 series Puppies so I was wanderig if something Zigbert has changed for Stardust is the problem.

Thanks again for your help
Will
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 09 Feb 2010, 13:15    Post_subject:
Sub_title: Trying to install Mplayer
 

Barkingmad wrote:
Thanks, abushcrafter for your interest.

The reason I'm asking is that I can't seem to get those pakages to install/run on Stardust so I'll quote my older post for refference.

Barkingmad wrote:
Hello

Is there a package of MPlayer that works with the 4.3 series Puppies?

I have tried three different ones so far on Stardust 007 and they all fail in different ways as follows.

First try: this release by big-bass that I've used on Puppy 4.1. This won't install at all -- Petget says "Error package failed to install"

Second was this one by tempstuous. This appeared to install OK and put an entry in the Multimedia menu but nothing appears to happen on clicking it. Trying to run it in a terminal reports a missing library -- libXvMC.

Lastly I tried something newer by MU (Mark). First installing the player then his frontend for it. The controls run but won't play anything so I tried this in the terminal and found a different library missing -- libXxf86dga.

I am about at the limit of my Linux knowledge so any suggestions would by helpful, thank you

Will


I have used bigg-bass's version OK before but on 4.1 series Puppies so I was wanderig if something Zigbert has changed for Stardust is the problem.

Thanks again for your help
Will

sounds like your missing a system link from /usr/X11R7/lib to /usr/lib
Those missing files should be /usr/X11R7/lib
but sometimes they are in other locations in other distros.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Tue 09 Feb 2010, 14:03    Post_subject:  

Thanks

No time to look at this now but thats something to check

will
Back to top
View user's profile Send_private_message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Tue 09 Feb 2010, 17:49    Post_subject:  

Read the MPlayer-1.0rc2 post, the is MPlayer-extra-libs.pet in the main post to fix that.
Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 09 Feb 2010, 18:54    Post_subject:  

abushcrafter wrote:
Read the MPlayer-1.0rc2 post, the is MPlayer-extra-libs.pet in the main post to fix that.


Are you sure about that? The missing libs are X-server drivers. That are usually included in older puppy version like 2.14X and 3 series, 4 series doesn't have them by default.
/usr/X11R7/lib/libXvMC.so
/usr/X11R7/liblibXxf86dga are both in 2.14X

but I did find the libXxf86dga and libXvMC.so drivers located in the 20MB full xorg pet. here's the missing 2 deps.

If you need more than those 2 you posted maybe install the full 20MB pet Xorg, but first test the ones I provided below from that large package.
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri-7.3.pet
ttuuxxx
xorg_xorg_dri-7.3-2missing-files.pet
Description 
pet

 Download 
Filename  xorg_xorg_dri-7.3-2missing-files.pet 
Filesize  14.75 KB 
Downloaded  292 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Tue 09 Feb 2010, 19:01    Post_subject:  

Yes I am sure. Here is the contents of the pet:
Code:

libXvMC.so.1      libXvMCW.so.1      libXxf86dga.so.1
libXvMC.so.1.0.0  libXvMCW.so.1.0.0  libXxf86dga.so.1.0.0
Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 09 Feb 2010, 19:06    Post_subject:  

abushcrafter wrote:
Yes I am sure. Here is the contents of the pet:
Code:

libXvMC.so.1      libXvMCW.so.1      libXxf86dga.so.1
libXvMC.so.1.0.0  libXvMCW.so.1.0.0  libXxf86dga.so.1.0.0


wow that's not a good way to do it, those drivers should of stayed with the xorg packages, because it could mess up peoples displays by mix matching Xorg files with 3,4,5 series.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Tue 09 Feb 2010, 19:10    Post_subject:  

What about the fact it was for the 4 series only?
Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 09 Feb 2010, 19:20    Post_subject:  

abushcrafter wrote:
What about the fact it was for the 4 series only?


That's the thing about puppy, people never stick to the series, they user series 2 packages on series 4 etc. Like Gemgame and Bubbles, I had a request for a package for that for 4 series, and since they are both gtk1.2 games It took a bit of work, but they were happy. Smile Or the VLC 8.6h package I made up on 4 series, I managed to get working on 2,3,5 series also. Really that mplayer could work on almost any version of puppy. Its just better to keep the Xorg drivers for the puppy version.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Tue 09 Feb 2010, 19:25    Post_subject:  

ttuuxxx wrote:
abushcrafter wrote:
What about the fact it was for the 4 series only?


That's the thing about puppy, people never stick to the series, they user series 2 packages on series 4 etc. Like Gemgame and Bubbles, I had a request for a package for that for 4 series, and since they are both gtk1.2 games It took a bit of work, but they were happy. Smile Or the VLC 8.6h package I made up on 4 series, I managed to get working on 2,3,5 series also. Really that mplayer could work on almost any version of puppy. Its just better to keep the Xorg drivers for the puppy version.
ttuuxxx


I meant the drivers were for the 4 series. As for mplayer it didn't need that fix for (I think) the 3 series. Look at the thread...
Back to top
View user's profile Send_private_message Visit_website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Tue 09 Feb 2010, 20:47    Post_subject:  

This might be more of a general puppy issue, but I'm getting corruption in the pupsave file every shutdown, even after fixing (both with pfix=fsck and with e2fsck on the file). I stared off all the items that reappeared again after fixing and rechecking following a reboot w/ proper shutdown. My pupsave file is regular ext2 filesystem located within an ext3 partition. I'm running a frugal install.

Code:

pupsave.2fs was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
*Deleted inode 2430 has zero dtime.  Fix<y>? yes

*Deleted inode 2431 has zero dtime.  Fix<y>? yes

*Deleted inode 2432 has zero dtime.  Fix<y>? yes

*Deleted inode 2462 has zero dtime.  Fix<y>? yes

Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts

Pass 5: Checking group summary information
*( different  numbers)Block bitmap differences:  -(22548--22549) -(22556--22562) -(22564--22585) -(22596--22598) -(22612--22620) -(22629--22631)
Fix<y>? yes

*( different group)Free blocks count wrong for group #0 (27589, counted=27635).
Fix<y>? yes

*Free blocks count wrong (100605, counted=100651).
Fix<y>? yes

*Inode bitmap differences:  -(2430--2432) -2462
Fix<y>? yes

*Free inodes count wrong for group #0 (5696, counted=5700).
Fix<y>? yes

*Free inodes count wrong (28882, counted=28886).
Fix<y>? yes
Back to top
View user's profile Send_private_message 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Wed 10 Feb 2010, 12:48    Post_subject:
Sub_title: mplayer
 

Hello ttuuxxx and thanks for your attention

An update to what I've done.

I tried your Library update pet and found that big-basses' mplayer still won't install so tried yours, this now complains of libmad missing so I tried the full Xorg pet that you suggested.

I think this installed OK -- glxinfo returns a load of output -- but libmad is still missing, libXvMC and libXxf86dga are now in /usr/X11R7/lib but there's no sign of libmad. Any idea were to find it?

Thanks again for your trouble
Will
Back to top
View user's profile Send_private_message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Wed 10 Feb 2010, 12:57    Post_subject:  

libmad was removed from stardust, get it here:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/libmad-0.15.1b.pet
Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 10 Feb 2010, 13:15    Post_subject:  

thanks for the post abushcrafter Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Thu 11 Feb 2010, 12:56    Post_subject:  

Hello

Another report.

I installed libmad and followed ashbushcrafter's instructions to fix the menu problem and Mplayer now runs and plays stuff but I think I must still have a video card driver problem.

I've only tried an avi file so far but with these results.

xv and xvmc give sound but no picture.

The open gl options try to play but are so distorted and/or choppy to be unusable
.
x11 plays OK but fullscreen gives a black border without enlarging the video, as I think is reported elsewhere.

Any ideas as I wanted to use Mplayer for it's hardware-scaling option.

I have an ATi X1600 card in this PC and as Zigbert included the latest ATi divers in Stardust I thought this should be a good distro for me.

Thanks again for getting me this far.

Will
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 8 of 9 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0950s ][ Queries: 13 (0.0070s) ][ GZIP on ]