(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
and continue your work there. Thank you.

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 28 Nov 2020, 15:39
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Puppy On Laptops
Moderators: Flash, Ian, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 5 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 22, 23, 24 Next
Author Message

Joined: 30 Oct 2009
Posts: 1438
Location: England

PostPosted: Wed 03 Feb 2010, 13:55    Post subject:  

arr! Did you try the newer version? I can't help you any more thogh as this is all I know (ant used "CPU Frequency Scaling Tool" yet.) sorry.
Back to top
View user's profile Send private message Visit poster's website 

Joined: 02 Feb 2009
Posts: 894

PostPosted: Wed 03 Feb 2010, 14:11    Post subject:  

bee_pipes wrote:
One question for the netbook owners out there - 10" screens. How are they for reading? I was considering the kindles - hate reading at the desktop and the trend of books & manuals seems to be increasingly electronic. How are the small screens for extended reading? Ideally I'd like something that lends itself to loafing on the couch - whether reading, writing or coding.

The bigger question is what you will be reading.

I read a great deal of stuff in electronic format. My primary reading device is an old PalmOS PDA, but I also have an old notebook running Ubuntu and Puppy Linux.

The issue is the format things are in.

The majority of the stuff I have is HTML that has been converted to be used by Plucker, a free, open source offline HTML viewer for Palm OS devices. But I also have material in Mobipocket (used by the Amazon Kindle), ePub (used by the Sony Reader and Barnes and Noble nook), eReader (legacy format for the nook), Word, RTF, PDF, and plain text formats.

I can read all of them on the PDA save ePub, and can convert that to something I can read using an open source product called Calibre.

I can read Plucker, Mobipocket, and ePub documents on the notebook using an open source eBook viewer called FBReader. (A PET of FBReader 0.12.1 exists for Puppy.)

PDF is the biggest problem, as most PDFs are not created with the tagging that lets them reflow to fit smaller screens, and side-scrolling to read documents that don't fit is a pain.

I can read comfortably on both devices. (I use reading glasses, but am not at the point of needing bifocals.)

I'm not interested in a Kindle. Problem number one is that the eInk screen used by the current generation of dedicated reader devices does not support color, and color is a requirement for me. Problem two is vendor lock in. Amazon uses the Mobipocket ebook format (they own them) with a proprietary DRM scheme. Mobi format documents not encumbered by DRM can be gotten from anywhere and read on the Kindle. Current commercial ebook titles for the Kindle can only be purchased from Amazon.

I refuse to be locked in to a single vendor, so Amazon is off my list.
Back to top
View user's profile Send private message 

Joined: 20 Jan 2009
Posts: 2288

PostPosted: Wed 03 Feb 2010, 16:12    Post subject:  

Asus EEEPC 900 Intel Celeron M 900 Hz
2 gig of Ram
4 gig SSD = MacPup Foxy 3.0
16 gig SSD = /home
All formatted as Ext2 file system. Full Install
Webcam and Mic works in Skype. 2.6 gig free on 4gig SSD with tons of stuff added. Touch Pad and Cpu Scaling works also. Macpup Flies on this Netbook. I also run AntiX off External SD Flash Drive on it.

IBM 390E Intel 333 Mhz
256 mb of ram
20 gig hardrive=Puppy 4 Dingo full install/ AntiX 7.5
Wireless via Belkin F5D7010 PCMCIA Cardbus
CDRW drive

Amrel RT 686 Rocky II Intel 500 Mhz (passive touch screen)
256 MB of Ram
Touch Pad works. No need for CPU scaling. Has no fan. Just a monster aluminum Heatsink.
Hot swappable 6 gig Hardrive = Puppy 3.01 full install
PCMCIA DVDROM Plays Movies in Puppy
Wireless works via a DLink WNA 1330 PCMCIA G Cardbus
3.01 flies on this Laptop
Update: Running Puppy Dingo 4 now.

Amrel RT786 EX. I have LightHouse 5.03 installed Frugal on 3 gig IDE Hardrive. 512MB of ram. 700 MB of swap partition. 1.9 gig for save. Everything works, Tap, Sound, CDRW,
Flash,Java, No problemos.

Ibm A22 Intel 1000 Mhz
256 mb of ram
20 gig hardrive = Puppy Dingo 4 Full Install/Mint 7 XFCE 4.6
Has the red button in middle of keyboard.
DVDROM Plays Movies.
Wireless using a Belkin F5D7010 PCMCIA Cardbus
Update: Puppy 5.2 frugal install now running on this laptop. Everything works.
Upgraded ram to 512MB.

IBM T23 Intel 1.6 Ghz
1 gig of Ram
80 gig hardrive = Puppy 4.31 Full Install(on 8 gig dedicated Puppy partition)/AntiX 8.2/AntiX 8.5/ Windows 2000 Pro (for tuning motorcycles)
Wireless using Belkin F5D 7010 PCMCIA Cardbus (I have a few of these because ver 6 cards are Linux compatible)
Update: Puppy 5.2 full install works on this laptop.

Panasonic CF-48 Intel 1.8 Ghz
1.2 gig of ram
100 gig Hardrive = LightHouse Pup Mariner Frugal Install on 10 gig partition for just Puppy/Ubuntu 8.04 LTS/ AntiX 8.2
Internal Intel Wireless a/b/g chipset. All Distros work with wireless.
Update:Macpup 5.1 Full install works on this Laptop also. Everything works

My Motorcycle shop Desktop is a IBM M41 running wirelessly with AntiX 8.2 dual boot with a full install of a older version of Puppy 4.6 (back when it was first released as testing)
Update: BrunoPup,Puppy 5.2, TL-Os all frugal installs. Works with Patriot Wireless USB G pendrive.

I have another Amrel RT 686 EX Laptop.
Intel 800 hz. 512 mb of ram. DVDROM. That I can Hotswap the hardrive from the other Amrel RT 686 and use Puppy 3.01 on it also.

All my boxes fly with Puppy Linux. Antix flies pretty fast also on the boxes I have it installed on also. I also run swap partitions on all my installs except for the Asus EEEPC.

Edit again: June 18, 2012

IBM A22M just recieved via UPS. Pentium 3 , 700 hz cpu, 192MB of ram,empty 20 gig hardrive right now. Running Puppy 4.31 posting this right now via live cd session with a Netgear MA 521 wireless B pcmcia card. Wireless and sound works. Details at thread below.

Last edited by rokytnji on Mon 18 Jun 2012, 23:35; edited 3 times in total
Back to top
View user's profile Send private message 

Joined: 11 Oct 2007
Posts: 76
Location: West Gloucestershire, UK

PostPosted: Thu 04 Feb 2010, 04:42    Post subject:  

I've got a Dell Latitude Cpi, 192MB RAM, 400Mhz P2 and 6GB HDD. The later kernels don't seem to work too well with it, but I'm running a modified 4.2.1 ' Deep thought '. I've got an Edimax cardbus wi-fi adaptor - Rt61 driver - which worked out of the box, although I've added Pwireless2 for roaming capability, and it doesn't really have the grunt to handle flash, so ' noscript ' is a useful browser addition. Other than that my customisation has been merely personal preference - search engine of choice etc. Not bad for a machine built for Win 98!
Back to top
View user's profile Send private message 

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Thu 04 Feb 2010, 10:07    Post subject: Puppy on a Laptop  


I'm running Puppy 4.2.1 on an Acer TraveMate 8200 laptop made on 2004, which I paid 5 dollars for at the Garbage Recycling Depot in January 2010.

I have found that Puppy is the ONLY operating system that will run this laptop. Windows XP was installed when the laptop left the Acer factory, but due to a conflict between XP and BIOS (I think) the laptop crashes every time I itry torun XP on it. Some poor sod paid a shit-load of money for this thing when it was new. I paid 5 dollars for it, which is about $4.99 more than it's worth.

I've installed Puppy 4.2.1 as a Frugal install to an Ext3 Partition, with a GRUB bootloader in the MBR giving me a choice between Puppy and XP at Startup. XP resides in a 10 Gb Partition and I only have it on the laptop for those rare occasions when I XP will do a specific job. For example, if I need to "reset" my Wireless Internet USB Modem, I will need XP to do that.

But the rest of the time I use Puppy Linux.

Starting this thread was a damn good idea.
Back to top
View user's profile Send private message 

Joined: 03 Jan 2007
Posts: 1573
Location: UK

PostPosted: Thu 04 Feb 2010, 12:42    Post subject:  


Once again, thankyou to all for your contributions,
they are very much appreciated.

Having said that, i thought i would add something about the Toshiba Portege 7010CT
rather than just posting a link to thread, i thought i would reproduce it here (like i said, gather it all in one place)

    I have got a Toshiba Portege 7010CT

      CPU = Pentium II 300 MHz
      RAM = 160 MB
      HDD = 20 GB (I added this)

    The HDD is partitioned as such: (All sizes = approx)

      hda1 = ext3 = 50 MB (Used for GRUB only, flagged as boot)
      hda2 = ext3 = 5 GB
      hda3 = ext3 = 5 GB
      hda4 = Extended
      hda5 = ext3 = 8.3 GB
      hda6 = linux-swap = 256 MB

    Current OS's installed are:

      hda2 = Puppy-4.00 FULL Install
      hda3 = Macpup-Foxy-E17 FRUGAL, Puppy-215CE FRUGAL and BackTrack3
      hda5 = Puppy-411-retro FRUGAL

    I initially pulled the HDD out and connected it via an adapter into one of my desktops,
    then used a Puppy-LiveCD to format/partition the HDD using GParted.
    After that i created a FULL install, and installed GRUB

    Each of the FRUGAL installs where done by mounting a USB HDD
    and then copying the necessary files onto the internal HDD.
    Then adding an entry to the menu.lst
    boot up whatever Puppy i was trying to install
    and then reboot and create a pup_save.2fs file.

    There was a problem with Puppy-215CE, not sorting out the video (xorg or vesa)
    but following the advice from BarryK in this thread: Neomagic problem with 2.13 solved
    i eventually got it installed.

    If you do decide to try 215CE
    follow the advice from BarryK in the above link,
    but where it is suggested to do:

    mp /usr/X11R7/bin/xwin

    Try using this instead:

    e3 /usr/X11R7/bin/xwin

    Then after commenting out the lines in /usr/X11R7/bin/xwin
    save and exit the editor, then type:


    Then just answer the questions that follow.
    If it will help, here are a couple of things that i chose: (in no particular order)

      Chose "yes" to view the card database
      selected "Neomagic"
      Horizontal sync frequency of "31.5 - 37.9"
      Vertical refresh of "50 - 70"
      Video RAM "2048"
      Edited Modes so there was nothing above 800x600

    Setting up the connection was a PITA to be honest,
    that's probably to do with my card though (Buffalo Air Station Turbo G - WLI-CB-G54HP),
    the only Puppy that did succeed without any problem whatsoever
    was Macpup (Well done prit1 & runtt21)

I have also got an old IBM ThinkPad T21 on which i have had various Puppy versions running OK.
But at present i cannot fire it up to get more details, as it is suffering from a well known problem called BoD (Blink of Death)
apparently this does not just affect the T21 but most if not all of the T2x-series ThinkPads.

In my particular case, it is a bit of a lottery whether or not i can get it to start up,
sometimes it will, and most times it wil not.

If (and when) i manage to get it started, i will post more details as to what Puppy versions i have on it.

I have also added a link to the old wikka page Working Laptops
in the very first post of this thread.



Back to top
View user's profile Send private message 

Joined: 07 Apr 2006
Posts: 40
Location: Eltham, NZ

PostPosted: Thu 04 Feb 2010, 22:01    Post subject: Puppy On Laptops
Subject description: IBM T22

Hi Cat Dude,
I run an IBM t22, pIII900, 384mb sdram, and have tried lots of puppies.
At present have retro kernel 431( full hd and frugal installs, tuxx 420puppies frugal, 301 frugal, 109CE full and an older mepis.
431 full is my main 'grunt' system.
Was given this baby a few years ago with Win2000pro on it, but wiped that after it got all buggy and slow and I didn't have any install discs. By that time I was a puppy convert anyway. I run Wine 0.9.22 for a couple of Windows progs that I need (MS Works - some old docs I need occasionally that I never converted to Office, and a theology dictionary. BTW, have found later versions of wine don't run these two as well as 0.9.22.)
Hardware - in a nutshell, puppy is great. Some details:
Dialup - still run this at home. All puppies since the 2 series have autodetected my lucent winmodem. Even 109CE still has a downloadable ltmodem module which is a piece of cake to install. However, all the 4 series pups I have tried autoload martian_dev at bootup, which is the latest driver. This doesn't work on my T22. Thankfully puppy4 includes the older ltmodem module as well - easy enough to select that one over the martian one, but caught me out first time.
From 217 up, puppy loads my old airo 350 pcmcia wireless card - 80211b, although later network wizards more reliable than earlier.
gtkam detects and runs my little Fujifilm A170 camera, and also my ancient Intel Pocket PC. I must admit though that Digikam on Mepis is a more capable camera manager.
Had to hunt for the drivers for the HP Deskjet f2180- needed hpliplite and libnetsnmp pets - but going good. BTW, 431 is the first pup I've had in which the sane software has given me scanning capability. (May be my ineptness with software though)
Hard disks - I downloaded 430 with a later kernel, and for some reason it won't load on my t22 - can't find the puppy files. Looks like a hard disk detection problem. (Wondered if it was a crook burn, but the disk boots fine on other computers. Gave up on 430 until I found 431 retro, which works normally)

I have also found that full installs boot and run a bit faster than frugals, which is why I prefer them, but it is great to boot my frugals with pfix=ram to experiment safely - good way to learn linux stuff. Just reinstalled 109CE lately after finding the disk hiding away in the bottom of my old laptop bag - it's fast! But a bit limited now - no scanning, cameras etc - well perhaps not without a lot of mucking around.
Finally - found the T22 Thinkwiki informative and helpful - http://www.thinkwiki.org/wiki/Category:T22.

Cheers - thelash, happy puppy user.
Back to top
View user's profile Send private message 

Joined: 03 Jan 2007
Posts: 1573
Location: UK

PostPosted: Fri 05 Feb 2010, 17:30    Post subject:  


I have added the following link to my first post, as it mentions a few laptops in there.
List your system



Back to top
View user's profile Send private message 

Joined: 05 Feb 2010
Posts: 3

PostPosted: Mon 08 Feb 2010, 19:38    Post subject:  


My Puppy is a Dell Inspiron 2200 which died and crunched the HD when my significant other dropped it. Puppy 4.3.1 on a usb rescued it.

I use it for watching videos on my TV mostly, and kids use it for web browsing. Boots in seconds rather than minutes. Will be installing a small HD (less than a tenner) as v little data was ever stored on the laptop.

Here's a picture

Back to top
View user's profile Send private message 

Joined: 23 Jan 2010
Posts: 33
Location: Potsdam NY USA

PostPosted: Wed 10 Feb 2010, 20:01    Post subject: Dell Inspiron B130  

Puppy 4.3.1 FULL HD INSTALL on an Intel Celeron M 420,1.6 GHz, 256 MB RAM, 14.1 widescreen. Intel Graphics Media Accelerator 900 GM. 40 GB HD, 802.11a/g, DVD-ROM/CD-RW.

Purchased new in Jan 2006 with Windows XP

Running Puppy for 2 months now - FAST FAST FAST! Onboard microphone is not recognized (chipset problem?) Otherwise all hardware works well*

*One peculiar side. When I installed Pup into 2 separate bootable partitions (ext2) the second partition invariably fails to detect the wireless card. No idea why.

Battery life seems a bit shorter than with windows. And DO NOT drain the battery - Xwindows HATES that!

Finally, some add-on .pets are bad for its health (mplayer especially - results in the need to reinstall) Granted a more experienced user might find a way around this but not the UberNoob!


Follow the misadventures of "Timmy and his new puppy"
About My Puppy: 4.3.1 FULL on a DELL INSPIRON B130
Back to top
View user's profile Send private message 

Joined: 08 Apr 2007
Posts: 259

PostPosted: Thu 11 Feb 2010, 07:13    Post subject:  

Hi UberNoob,
for your mic problem have you tried already dealing with alsamixer? In my Acer notbook I have to switch to "front mic" in order to make it work. For the mplayer problem are you referring to the fact that after installed if you launch it from the menu everything locks and you have to exit x? If this is the problem you just need to add an "&" to the /root/.jwmrc file as said here http://www.murga-linux.com/puppy/viewtopic.php?t=26511
Back to top
View user's profile Send private message 

Joined: 22 Oct 2007
Posts: 65

PostPosted: Fri 12 Feb 2010, 00:10    Post subject: MaxSpeed MaxBook 810  

This was one of the original "NetBooks", from about 2003. Targeted at corporate users, it lacks a hard drive, boots from an internally-mounted Compact Flash drive. I've been running Puppy 3.x on it for a few years, just updated to 4.3.1 - it found everything, including the CompactFlash slot on the left side that 3.x never recognized, and my WiFi card, which I had a hell of a time getting working on 3.x. Love the new Puppy!

Back to top
View user's profile Send private message 

Joined: 24 May 2008
Posts: 59

PostPosted: Fri 19 Feb 2010, 23:23    Post subject:  

Hello Catdude,

I have a laptop, the current state with this laptop using Puppy 4.3.1 is outstanding! Everything works perfectly except maybe one miner thing that could be major for others but for me it's working quite well. My laptop is a Gateway 3550 GH or a GZ, I am not sure which one but both different versions are pretty much the same I think.

The only problems I have encountered with this laptop using puppy 4.3.1 is I had it turn off on it own on me a couple times. Getting Puppy Linux working on this machine is a marvel since this laptop was designed for Xp, yet Xp proved to be none functional. But it stopped turning off when I started to use the "CPU frequency scaling tool", which solved my problem and it hasn't turned off since. The second problem was well small for me, it was easy to fix. When I used my Afla long range wifi wireless card I had to plug it in at a certain time and make sure I use Ndiswrapper when I wanted to connect wirelessly, although my internal wireless card worked perfectly without me even having to find any drivers for it.

Everything else, Graphic, network card, USB, Mouse, and cd rom work great. If I want to get sound working on this laptop it is just a matter of turning off the external amplifier and it stays that way which is good.

The only thing I dislike about this laptop is I have to continue to adjust and monitor the temperature of the CPU other wise it will just turn off by it self, not to put Gateway down, but I believe I am not the only Gateway user who has this problem but it is manageable.
Back to top
View user's profile Send private message 

Joined: 24 Dec 2009
Posts: 20
Location: Zurich, Switzerland

PostPosted: Sat 20 Feb 2010, 10:05    Post subject:  

Hi all,

i use Stardust 4.3.1_007 frugal, boot from USB-Stick
on my DELL LATITUDE 110L from year 2006.
ADSL Router P623-ME.
Installation without problems - audio - graphic - touchmouse all running.

Very Happy

Back to top
View user's profile Send private message 

Joined: 21 Feb 2010
Posts: 7
Location: Saskatchewan, Canada

PostPosted: Tue 23 Feb 2010, 20:52    Post subject:  

I am triple-booting TinyCore, Puppy and Vector off an old TTX laptop from 2000. What the heck is a TTX, anyways? Shocked
It has a P3 processor and 118 MB RAM.

Internet connection was a snap, with automatic recognition of high-speed DSL. I am still a total noob at all of this, but everything seems to be working on this laptop.

Except the laptop volume control on the front. I figure I will tackle that problem next....after I figure out how I broke my desktop. lol.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 22, 23, 24 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 1.0206s ][ Queries: 13 (0.7441s) ][ GZIP on ]