Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 04:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
XFProt virus scanner fix for Puppy 431
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
tasmod


Joined: 04 Dec 2008
Posts: 1462
Location: North Lincolnshire. UK

PostPosted: Mon 25 Jan 2010, 13:00    Post subject:  XFProt virus scanner fix for Puppy 431  

I posted this in the Stardust 006 thread also.

In Puppy 431 the XFProt application errors out, it has a defective gui and missing directory.

So I put together this pet with a fixed gui and a further directory.

It will work either way, if you've not downloaded f-prot or if you have and it doesn't work. This will fix it.
XFProt-0.2.pet
Description 
pet

 Download 
Filename  XFProt-0.2.pet 
Filesize  129.69 KB 
Downloaded  3127 Time(s) 

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Wed 27 Jan 2010, 15:36    Post subject:  

Thank you Rob, it works great and I included the fix in Lighthouse Pup 4.43 Final. Very Happy
TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
yorkiesnorkie


Joined: 04 Jun 2007
Posts: 505
Location: George's Island

PostPosted: Tue 16 Feb 2010, 19:07    Post subject: bugfix doesn't seem to work  

I gave it a try but I get the same error as usual. xf prot can't find the version. I get past the installation, I install to the defaults, I download the updates, but it won't run.

I ran the pet before the installation, and then afterward when I got the error message. I also tried rebooting.

I'm running Puppy 4.3.1 with the add on pet that updates it.

Yorkiesnorkie
Smile
error.png
 Description   xf prot can't find version error message.
 Filesize   7.87 KB
 Viewed   5299 Time(s)

error.png

Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10845
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 02 Apr 2010, 05:21    Post subject:  

hi tasmod yorkiesnorkie mentioned an error, will that happen if I install the pet? or is it a one-off ?
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
tasmod


Joined: 04 Dec 2008
Posts: 1462
Location: North Lincolnshire. UK

PostPosted: Fri 02 Apr 2010, 05:26    Post subject:  

I think it must be a one off. I tried it in your 432-v2 and it worked OK.
_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
amsk98

Joined: 20 Feb 2010
Posts: 23

PostPosted: Fri 02 Apr 2010, 14:55    Post subject:  works pefectly  

works pefectly

& up to date

thanks
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1498
Location: Pecos/ Texas

PostPosted: Tue 06 Apr 2010, 22:51    Post subject: Puppy 4.31 Full
Subject description: xfproto 2.4
 

Quote:
hi tasmod yorkiesnorkie mentioned an error, will that happen if I install the pet? or is it a one-off ?

I think it must be a one off. I


I guess it is a 2 off(sorta, my message is binary not found). As I experience the same problem as Yorkie. Screenshot of running xfprot in terminal below.
2010-04-06_21-40-38.jpg
 Description   
 Filesize   37.66 KB
 Viewed   1681 Time(s)

2010-04-06_21-40-38.jpg

Back to top
View user's profile Send private message Visit poster's website 
tasmod


Joined: 04 Dec 2008
Posts: 1462
Location: North Lincolnshire. UK

PostPosted: Wed 07 Apr 2010, 04:06    Post subject:  

That appears to be an installation error.

Does this appear if you try from the menu entry or does it run correctly?

There are numerous files and directories installed in a correct installation, check for these.

There are two directories in /usr/local

One is xfprot with run scripts

Other is f-prot with virus definitions, updater, licence and first run install script.

Two important files:-

/usr/local/bin/xfprot ----- ----- this is the exec file run from menu, it calls up a GUI where the choices for xfprot are run.

/usr/local/xfprot/xfprot-gtk ---the gtk gui script.

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
rokytnji


Joined: 20 Jan 2009
Posts: 1498
Location: Pecos/ Texas

PostPosted: Sun 11 Apr 2010, 09:29    Post subject:  

Quote:
Does this appear if you try from the menu entry or does it run correctly?


No it did not run from the menu and yes the warning banner came up when using the menu. That was why I tried running from terminal. No error message in terminal other than the banner though.

Also. No need to waste time with me tazmod. I went and tried installing avast rpm instead. This all started when I ran Kazehakase browser and got a can't connect to paypal popup when I was not even trying to connect to paypal. So in a late night fit of paranoia I started on this trek.

Long story short. I broke my Puppy 4.31 full install when Avast froze up halfway through scan. Lost X. Tried using my saved sfs files in etc/X11/xorg.conf and that startup file in /root/home (Can't remember the exact name but it was like .inixtrc ) and still wouldn't give me a desktop and xorgwizard would just go in circles as far as if you didn't get X run Xorgwizard. I finally gave up. So 4.31 is gone. I use my other partition with MacPup Foxy 3 which has xfprot working just fine. Used the same steps to install in Macpup as I did in 4.31. So it is a wonderment. But since Puppy 4.31 is gone. The point is moot.

Quote:
/usr/local/bin/xfprot ----- ----- this is the exec file run from menu, it calls up a GUI where the choices for xfprot are run.

/usr/local/xfprot/xfprot-gtk ---the gtk gui script.


I investigated and all files were present. That was why I head scratched, then tried avira, which was just adding fuel to the fire to burn down Puppy.
Back to top
View user's profile Send private message Visit poster's website 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Sun 11 Apr 2010, 20:34    Post subject:  

rokytnji wrote:
Quote:
Does this appear if you try from the menu entry or does it run correctly?


No it did not run from the menu and yes the warning banner came up when using the menu. That was why I tried running from terminal. No error message in terminal other than the banner though.

Also. No need to waste time with me tazmod. I went and tried installing avast rpm instead. This all started when I ran Kazehakase browser and got a can't connect to paypal popup when I was not even trying to connect to paypal. So in a late night fit of paranoia I started on this trek.

Long story short. I broke my Puppy 4.31 full install when Avast froze up halfway through scan. Lost X. Tried using my saved sfs files in etc/X11/xorg.conf and that startup file in /root/home (Can't remember the exact name but it was like .inixtrc ) and still wouldn't give me a desktop and xorgwizard would just go in circles as far as if you didn't get X run Xorgwizard. I finally gave up. So 4.31 is gone. I use my other partition with MacPup Foxy 3 which has xfprot working just fine. Used the same steps to install in Macpup as I did in 4.31. So it is a wonderment. But since Puppy 4.31 is gone. The point is moot.

Quote:
/usr/local/bin/xfprot ----- ----- this is the exec file run from menu, it calls up a GUI where the choices for xfprot are run.

/usr/local/xfprot/xfprot-gtk ---the gtk gui script.


I investigated and all files were present. That was why I head scratched, then tried avira, which was just adding fuel to the fire to burn down Puppy.


I use full installs almost exclusively. When I "break" one, I load the
live cd and run full install again. This time just use "upgrade", skip
the grub install, and in most cases it fixes original install.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
yorkiesnorkie


Joined: 04 Jun 2007
Posts: 505
Location: George's Island

PostPosted: Mon 03 May 2010, 08:58    Post subject:  

I still can't get this to work. I still get the cannot detct f-prot version error message.

I tried re-installing 4.3.0, running it from the menu, so the updates are downloaded, then installing the pet to fix it. No joy.

I downloaded f-prot and installed it from the website. I re-compiled xfprot from source and installed it. No joy.

I'm going to verify that f-prot will work from the command line. I'm going to check for the missing directories you mention. Also f-prot has i686 in it's tar.gz filename. I've got a pentium-mmx, so I'm wondering if that might be a factor, and/or if I should upgrade my puppy to 4.3.1

y.

_________________
www.busygamemaster.com
Back to top
View user's profile Send private message 
KusaNoKaito


Joined: 19 Feb 2010
Posts: 99
Location: Florida

PostPosted: Tue 04 May 2010, 23:31    Post subject:  

Quote:
I'm going to verify that f-prot will work from the command line. I'm going to check for the missing directories you mention. Also f-prot has i686 in it's tar.gz filename. I've got a pentium-mmx, so I'm wondering if that might be a factor, and/or if I should upgrade my puppy to 4.3.1


Perhaps you should, It works great of 431.
Back to top
View user's profile Send private message Visit poster's website 
tomaszek

Joined: 10 Feb 2010
Posts: 2

PostPosted: Sat 19 Jun 2010, 15:35    Post subject: fport for Puppy 4.3.1  

Dear All,

Do I have to compile fport from source? I can not find fport in repos.

Regards,

tomasz
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sun 20 Jun 2010, 06:20    Post subject:  

Hello Tomaszek,

it's available here.
Back to top
View user's profile Send private message 
yorkiesnorkie


Joined: 04 Jun 2007
Posts: 505
Location: George's Island

PostPosted: Sun 04 Jul 2010, 07:10    Post subject: fpscan works from the command line  

Hi,

I finally got back to this. I can't get xfprot to work but f-prot will work from the command line. I opened up a terminal and entered:
Code:
fpscan -a | tee report.txt

I send the content of the rxvt to a log file for review

you can get help with the application
Code:
fpscan -h


Interestingly it found a virus on a windows parition, so f-prot is working! Smile No luck with the xfprot GUI though.

Y.

_________________
www.busygamemaster.com
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0943s ][ Queries: 13 (0.0039s) ][ GZIP on ]