Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 11:36
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to setup 5.1 surround sound in puppy2a
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message
dominic

Joined: 30 Jan 2006
Posts: 66
Location: UK

PostPosted: Fri 17 Feb 2006, 06:49    Post_subject:  How to setup 5.1 surround sound in puppy2a  

Hi, i've been trying to setup the surround sound, and i found a small bit of info that seems to be enough to do it, it's from the gentoo wiki, its slightly modded because at the moment, puppy2 doesn't have all the user configuration files for ALSA (that baffled me, i spent ages looking for the little blighters, only to realise there arn't mandatory for stereo speakers so they probably wouldn't be in puppy2a)

So here goes:

Quote:
Duplicating across all channels

To have the sound from mp3s and other stereo sources duplicated across all channels, not just front and rear, use your sound config file (For puppy, you need to create this file, simply navigate to ~ or to etc (for a universal setting, it doesn't really matter as user accounts don't really apply to puppy.) Create a new file called .asoundrc) like this:

pcm.!dmix {
type dmix
ipc_key 1024
slave {
pcm "hw:0,0"
channels 6
period_time 0
period_size 512
buffer_time 0
buffer_size 1024
}
}
pcm.!default {
type plug
slave.pcm "dmix"
slave.channels 6
route_policy duplicate
}

This will make the sound come from your subwoofer as well as the smaller speakers in a 5.1 set. 5.1 streams are unaffected. If the sound messes up try

period_size 1024
buffer_size 8192

Remember to use alsamixer to unmute and turn up the volume on at least 'Master', 'PCM', 'Surround', 'Center' and 'LFE'; and also to change 'Channel' to 6ch from 2ch. Mute 'Duplicate'


Right, this should work, but I just thought i would say, i havn't got it working, but that besause i use the nForce2 sound chip on my board, which im sure you all know, nvidia currently only has basic 8bit sound drivers for. However i have managed to get sound out of 4 of my speakers with that setup and playing with alsamixer.

Could someone with another card please check it works? I think it should.

Thanks

Dom
Back to top
View user's profile Send_private_message MSNM 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0385s ][ Queries: 12 (0.0032s) ][ GZIP on ]