Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 01:28
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
error while loading shared libraries:libdbus-glib-1.s0.2....
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Vipin

Joined: 24 Dec 2009
Posts: 3

PostPosted: Thu 24 Dec 2009, 07:37    Post subject:  error while loading shared libraries:libdbus-glib-1.s0.2....  

I was trying to install seamonkey 2.0.

I used the readme.txt file that came with the software and followed the steps mentioned there. But wen i ran the script named 'seamonkey', following error occured:

error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory

Please help me how can i remove this error.

I am very keen to learn puppy and customize it for my desktop. Pets are not so easily found for every popular software on the net. So i want to learn how to compile available source code in to .pet file. Can anyone give me address of some good tutorials on compiling softwares in puppy.
Thanks!
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Thu 24 Dec 2009, 23:42    Post subject:  

dbus.pet
dbus-glib.pet
Back to top
View user's profile Send private message 
Vipin

Joined: 24 Dec 2009
Posts: 3

PostPosted: Fri 25 Dec 2009, 00:26    Post subject: Problem still persists..  

I have installed both of the above given pets. But same error message still appear.

While installing pets, i didnt get any 'installation complete' message
Is it any fault?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Fri 25 Dec 2009, 06:36    Post subject:  

OK, try doing this. Open a console, (Menu>Utility>Rxvt), then enter this command:

Code:
ln -s /usr/lib/libdbus-glib-1.so.2.1.0 /usr/lib/libdbus-glib-1.so.2
Back to top
View user's profile Send private message 
Vipin

Joined: 24 Dec 2009
Posts: 3

PostPosted: Fri 25 Dec 2009, 10:56    Post subject:  

I got the problem sorted out...

Actually even after installing .pet files given above, the required library files didn't appear in /usr/lib directory. I got the library files at following address:

http://www.murga-linux.com/puppy/viewtopic.php?p=343968

copied them to /usr/lib/, and now everything is working fine Very Happy . I installed new and better seamonkey.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Fri 25 Dec 2009, 18:56    Post subject:  

Yes, I had another squizz at the two .pets, & they, oddly, install the libraries to local directories. Anyway glad you sorted it out in the end.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0447s ][ Queries: 12 (0.0039s) ][ GZIP on ]