Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 20 Nov 2014, 22:45
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Common UNIX Printing System (CUPS) v1.3.11
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 5 [65 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 28 Sep 2009, 01:08    Post subject:
Subject description: Canon cnij-common drivers
 

Patriot wrote:
Hmmm .....

During the recent troubleshooting of plankenstein's canon ip2600, I have encountered a bug in several canon cnij (InkJet) drivers


I guess this relates to Canons own drivers rather than the included Gutenprint options? I ask because I have had no problems with native Gutenprint driver for ip4600.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Mon 28 Sep 2009, 01:57    Post subject:
Subject description: Canon cnij-common drivers
 

Hmmm .....

DaveS wrote:
..... I guess this relates to Canons own drivers rather than the included Gutenprint options? I ask because I have had no problems with native Gutenprint driver for ip4600.


Yes, it affects canon's own drivers prior to v3.00. The ip4600 uses v3.00 drivers and is not affected by this. If you have tried the canon ip4600 drivers that was extracted directly from .deb or .rpm then that's where the problem begins ...

Canon drivers are somewhat distro dependent (to be precise: directory layout dependent). If any one of the symlinks or files is not in the expected location, it borks out ... I noticed this behaviour during the ip2600 troubleshooting ... We need to hunt down where they should actually be ... The best solution is to completely rebuild from the sources for puppy ...


Rgds
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Fri 02 Oct 2009, 13:26    Post subject:  

Could you answer a few questions for me as I'll be trying to use CUPS 1.3.9 in NOP 4.13 and probably recycling old computers;

In the list you have CUPS, Gutenprint, HPLIP, PNM2PPA, SPLIX, FOO2ZJS
What are all these? Are they components of CUPS or alternatives to CUPS or are they all the inter-related components needed to make CUPS work ?

[EDIT] I've just hopped over to the HPLIP site and this reads as if it is an alternative to CUPS, is this true. If I had an HP printer would I use HPLIP instead of CUPS ?

To get CUPS to work is it sometimes as simple as finding the appropriate .ppd file and putting it in /usr/share/cups/model and then opening CUPS and adding the printer ?

Is this the basic way of getting CUPS to work, and only when this doesn't work do we head into problem solving issues ?

Where are the sites to find .ppd files
http://www.cups.org/ppd.php
anywhere else ?

Thanks.
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Fri 02 Oct 2009, 18:57    Post subject:  

setecio

http://www.linuxfoundation.org/en/OpenPrinting/Database/PPDDocumentation

http://www.openprinting.org/download/PPD/

http://www.linuxprinting.org/kpfeifle/LinuxKongress2002/Tutorial/III.PostScript-and-PPDs/III.PostScript-and-PPDs.html

HTH

Aitch Smile
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Fri 09 Oct 2009, 07:48    Post subject:  

Hmmm .....

I have inadvertently uploaded CUPS-1.3.11 pet package with a broken installer script. I apologize to the 24 downloaders of the recent cups-1.3.11 package .....

The cause of the broken installer script was due to an extra 'curly bracket' left dangling within the script. This has been fixed, checked, double-checked and installation process re-tested. The correct CUPS-1.3.11 package have been uploaded.

Any inconveniences caused by this is regretted .....


Rgds
Back to top
View user's profile Send private message 
slmeyer

Joined: 11 Nov 2009
Posts: 1

PostPosted: Wed 11 Nov 2009, 09:24    Post subject: Still getting - Permission denied error?
Subject description: I am getting the "Unable to open file "/var/spool/cups/d0x-0x" - Permission denied" error?
 

I don't have lp in groups or users list, but I have this error.

Spool ls shows this:
-rw------- 1 root nobody 771 2009-11-11 12:53 c00001
-rw------- 1 root nobody 767 2009-11-11 12:53 c00002
-rw-r----- 1 root nobody 17353 2009-11-11 12:53 d00002-001
drwxrwx--T 2 root nobody 1024 2009-11-11 12:39 tmp

What else can it be Question
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Fri 13 Nov 2009, 07:46    Post subject: Re: Still getting - Permission denied error?
Subject description: I am getting the "Unable to open file "/var/spool/cups/d0x-0x" - Permission denied" error?
 

Hmmm .....

slmeyer wrote:
........
What else can it be Question


I have no idea .....

Details? Puppy version? Cups version? printer model? printer driver?


Rgds
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Mon 30 Nov 2009, 15:01    Post subject:  

foo2xxx_r220909-0.0-i486.pet and HP Laserjet 1020 works fine. Built-in support for "hp-firmware-hotplug" mechanism really works. Much easier than HPLIP, hp-setup from console.
USB Hotplug folder with files and symlinks makes life easy.

With best regards
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 02 Dec 2009, 11:11    Post subject:  

Hmmm .....

pemasu wrote:
foo2xxx_r220909-0.0-i486.pet and HP Laserjet 1020 works fine. Built-in support for "hp-firmware-hotplug" mechanism really works. ........

Thanks for the test report and confirmation. It is much appreciated ...


Rgds
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8609

PostPosted: Wed 09 Dec 2009, 17:10    Post subject:  

Ok installed cups 1.3.10 onto puppy 4.12.

Mostly ok but some problems.
It seems cups needs UTF-8 ...... not sure how this is related.
Running the canon ink monitor only works if locale is set to UTF-8 or C.
Whatever the setting I cannot get the printer to show up in the gnome print dialog... firefox and leafpad for example. Other apps are ok...eg epdfview and abiword and anything using lpr.

Any clues on this one..apparently the locale affects samba use.

mike
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Thu 10 Dec 2009, 22:21    Post subject:  

Hmmm .....

mikeb wrote:
.....
It seems cups needs UTF-8 ...... not sure how this is related.
Running the canon ink monitor only works if locale is set to UTF-8 or C.
........

Ok, Mike ... I'll try to duplicate this and see what crops up ...


Rgds
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8609

PostPosted: Sat 12 Dec 2009, 16:14    Post subject:  

cheers patriot.

Guess I'm not the only one...
http://www.murga-linux.com/puppy/viewtopic.php?p=371302#371302

I suspect gnomeprint or something small and silly....same cups version and gtk on nimblex works ok and that is set to en_US ..no UTF-8 (Wireless works better on puppy so it's not all one way Very Happy )

regards

mike
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Sun 13 Dec 2009, 02:53    Post subject:  

Hmmm .....

I couldn't find anything there, Mike ... I have some screenshots taken ... I've tested on p412 k26217 and p421 k262516 ... both gives same output: printer is available for selection/options ...

The p421 was a pfix=ram with cups-1310 +dbus+ffox+canon-ip4600 driver ... The p412 was my one of my testbed, has cups-1311, gtk+2.12.12, dbus-1.2.12, dbus-glib-0.80, glib.2.20 and many many others I don't remember off-hand ... ffox-3.5.5 was tested, leafpad as-is, geany-0.18 .... Lang=en_US ...

I also tested most gtk apps with printing option and they all open the printer tab the same way ... (I'm unable to see the ink monitor tab since I don't have a real canon printer around ...) Wink

Did I miss something to bork it properly ?


Rgds


Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8609

PostPosted: Sun 13 Dec 2009, 11:49    Post subject:  

Quote:
Did I miss something to bork it properly

well I have this knack of confusing my own issues.

As mentioned a very similar setup on nimblex is fine and my puppy 4.12 setup is pretty standard as is apart from using xfce.....
...actually I just realised I included the gtk2 xinput update for firefox crashes and wacom tablet...I bet thats it...hmm there were 3 versions of that....the slaxer one might be the cure.....No good reverting to the original as it was too unstable......I bet the other person has the same update.

Well in a roundabout way I have a lead. Actually I could probably use the nimblex libraries Very Happy ...pass me the duct tape.

regards

mike

ps this must be it...I tried an early compilation of gtk 2.10 once and guess what, the printing did not work either as the gnome print libraries were incomplete. Whoever builds these needs buying a printer Very Happy
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8609

PostPosted: Sun 13 Dec 2009, 16:02    Post subject:  

Eureka...that was it
I dropped in /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so from nimblex and the canon appeared in the list...jumped for joy and did a test print. Smile ...I guess it was compiled against the older cups or some config that was particular about versions.

The print monitor still complains so I launch it with

Code:
#!/bin/sh
export LANG=C
cngpijmonip4600

and its happy.

regards

mike
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 5 [65 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0846s ][ Queries: 13 (0.0048s) ][ GZIP on ]