Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 01:36
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 5.x » Bugs (5.x dev)
No dependency resolution on Enlightenment DR17 Debian repo
Moderators: BarryK, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
shankargopal

Joined: 03 Dec 2005
Posts: 295

PostPosted: Fri 02 Oct 2009, 12:08    Post subject:  No dependency resolution on Enlightenment DR17 Debian repo  

I've been trying to get the E17 repositories set up in dpup 476j. One of the problems I already encountered is described here. However, after getting past that, it now seems that dependency resolution is a problem. When I try to install the main e17 package (which I have not yet been able to do due to download problems as described in that earlier thread), I am told that no dependencies are required. But I know for a fact that the package requires a large number of dependencies (all of which are in the same repository), as also described in the Packages file generated by PPM:

Code:

e17_0.16.999.062+svn41533|e17|0.16.999.062+svn41533|1|Desktop|5780K|pool/lenny/binaries-20090807/main/e|e17_0.16.999.062+svn41533-1_i386.deb|+libasound2,+libc6,+libcurl3,+libdbus-1-3,+libecore-con-svn-03,+libecore-evas-svn-03,+libecore-fb-svn-03,+libecore-file-svn-03,+libecore-imf-svn-03,+libecore-input-svn-03,+libecore-ipc-svn-03,+libecore-job-svn-03,+libecore-svn-03,+libecore-txt-svn-03,+libecore-x-svn-03,+libedbus-svn-03,+libedje-svn-03,+libeet1,+libefreet-svn-03,+libeina-svn-03,+libembryo0,+libevas-svn-03,+libgnutls26,+libpam0g,+libx11-6,+libxext6,+e17-data,+libevas-svn-03-engine-software-x11,+libedje-bin|The Enlightenment DR17 Window Manager|


The original Packages file from the repository is available at the repo here: http://packages.enlightenment.org/debian/dists/lenny/main/binary-i386/Packages. Any idea why the dependency resolution does not seem to be working?
Back to top
View user's profile Send private message 
runtt21


Joined: 07 Jun 2008
Posts: 1649
Location: BigD Texas

PostPosted: Wed 18 Nov 2009, 21:56    Post subject:  

I havent run Dpup yet so I can't help you with the repo issue. But it looks like they have just enough of the the EFL parts to make e17 work.I build mine from snapshot off the enlightenment site. So when I build enia and eet and efreet ,I have the whole set of libs not just part . It looks like they have split stuff up for DEV etc..... That should work But you wont be able to run the extra modules or elementary .You will also need to fix some things for puppy to work with it. If dpup uses the rox pinboard you will need to turn that off. You may also have problems with menus and shutdown.
_________________

www.macpup.org http://macpup.org/runtt21
Back to top
View user's profile Send private message Visit poster's website 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Wed 18 Nov 2009, 22:36    Post subject:  

The Lenny repos enlightenment package, assumes that the devx is installed to start with...a bad assumption in the case of dpup...I think the best idea, is that you build it as runtt21 says...

The problem will not be much of a drama once APT/Synaptic is available for 482 series Dpup(26th November)...but at this stage 47x series will not be catered for...that will change once 482 is a bit more mature...we are going to backport all the 482 features to 47x series with a new retro kernel.


Cheers

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
runtt21


Joined: 07 Jun 2008
Posts: 1649
Location: BigD Texas

PostPosted: Thu 19 Nov 2009, 19:01    Post subject:  

Or you can just wait a few days until Prit and I release the next Macpup . It has version e17_0.16.999.062 compiled from source......
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 5.x » Bugs (5.x dev)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0483s ][ Queries: 12 (0.0036s) ][ GZIP on ]