Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 18:10
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Xorg no good for Neomagic 128V [NM2090] graphics
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
Delboy

Joined: 30 Jan 2006
Posts: 33

PostPosted: Thu 02 Feb 2006, 11:13    Post subject:  Xorg no good for Neomagic 128V [NM2090] graphics  

This is not news just a gentle reminder, perhaps, of a persistent old problem with Neomagic graphics chips which, in my experience, is still not remedied by the move to Xorg.. My old laptop chip Neomagic 128V [NM2090] which works fine with a framebuffer server in Damnsmall linux never worked with Xvesa at all. Xorg officially provides full support for the above chip and appears to include a framebuffer video option too in the 'Xconfig' routine. With Puppy 1.07 on this machine, framebuffer option just doesn't load at all - X won't start and with the "Neomagic [Generic]" driver option selected either manually or by autoprobing, the Gui opens up but leaves a little to be desired:
The GUI display, whilst sized/positioned correctly for the LCD panel and without any other obvious errors is still not that great - Menus, toolbars, desktop icons and text all a little oversized and with lack of definition to fonts, lines, edges and colour junctions. Not as good as framebuffer I am afraid. Having spent a week googling, reading and tweaking Xorg I am having to call it day. Hope this gets sorted out some day as Puppy is the ideal distro for my needs on this machine (Digital Hinote).
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Thu 02 Feb 2006, 13:15    Post subject:  

Did you install the framebuffer-Kernel modules with pupget?
They are required to run xvesa or xorg in framebuffer-mode.

Also see here:
http://www.murga.org/~puppy/viewtopic.php?t=4082
Mark
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0392s ][ Queries: 12 (0.0042s) ][ GZIP on ]