Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 04:41
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy Arcade v5 - new files (29 Dec 2009)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 11, 12, 13 Next
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Tue 29 Sep 2009, 14:45    Post_subject:  

Makoto wrote:
I tried renaming the [kega] file without the extension and seeing if it would run...

Yeah I tried that too, had no effect at all for me.. Also, I noticed in the readme you supplied, and then on the website, that OpenGL is required to play games with any decent speeds... This doesn't really fit the Puppy Linux ethos, so the emulators I choose need to run well on low end PCs..

Gens and MasterGear work well without OpenGL, using SDL.. This is much better for lower end machines. Any emulators that work well with SDL, even seem to work well on Xvesa.. Gens emulates SegaCD/MegaCD and 32X systems, with good compatibility, so we're not actually missing much if Kega is not included.
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Tue 29 Sep 2009, 15:08    Post_subject:  

Ah, okay. I'll give up on trying to run it for the time being, then. Smile
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
hypnobluez


Joined: 28 Sep 2009
Posts: 4
Location: Sydney, AUSTRALIA

PostPosted: Tue 29 Sep 2009, 22:32    Post_subject: TREASURE  

Thanks a MILLION for creating and sharing this treasure with us sc0ttman.
YOU ARE THE MAN!!!

Thanks for contributing Makoto.
YOU ROCK!!!
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Wed 30 Sep 2009, 07:26    Post_subject: Compiled Emulators and ROM Browsers
Sub_title: .pets, source and .tar.gz
 

[UPDATE] ROM Launchers and Managers! Smile

These are front-ends for multiple emulators, allowing you to centralize all of your emulator/ROM launching needs. They are open ended enough to allow the launching of most emulators (xmame, snes9x, xmess, vgb, uae, gens, etc, etc) from one place.

The PETs below can be added to any version of Puppy that has the dependency listed.

Requirements:

pLauncher (PERL), emuexec (PERL), glaunch (various), gromlist (Python,PyGTK), tuxarcade (PERL), lowemu (Python), rombrowser (Java)..

I have uncluded these rom loaders as .pet packages for anyone who has these dependencies installed Smile

However, I have found a few ROM launchers that I would like to compile or convert. Gelide is a ROM loader - a frontend for multiple emulators, which may work in Puppy. Also Game Launcher could work well in Puppy, but needs to be compiled.

Here are also a couple of ROM good managers - advancescan and mamory.. They do not have a frontend at all, so you have to view the readmes, or run in terminal for usage details.

I added the latest version of iNES.. And I've also added fbzx2.1 - this is an ZX80 emulator.. Not tested! Requires glibc 2.7!!

Hope some of this is useful.. Smile
iNES-3.6.pet
Description  iNES 3.6 - NES/Famicom emulator
pet

 Download 
Filename  iNES-3.6.pet 
Filesize  189.85 KB 
Downloaded  1599 Time(s) 
fbzx-2.1b-2.fc10.i386.pet
Description  spectrum/ZX80 emulator - requires glibc, found in above
pet

 Download 
Filename  fbzx-2.1b-2.fc10.i386.pet 
Filesize  91.17 KB 
Downloaded  581 Time(s) 
mamory-0.2.25-3.fc10.i386.pet
Description  rom manager, no gui
pet

 Download 
Filename  mamory-0.2.25-3.fc10.i386.pet 
Filesize  90.26 KB 
Downloaded  521 Time(s) 
advancescan-1.13-2.fc7.i386.pet
Description  rom manager - no gui
pet

 Download 
Filename  advancescan-1.13-2.fc7.i386.pet 
Filesize  354.3 KB 
Downloaded  514 Time(s) 
tuxarcade-0.2.pet
Description  rom browser
pet

 Download 
Filename  tuxarcade-0.2.pet 
Filesize  989.37 KB 
Downloaded  561 Time(s) 
rombrowser-0.3.pet
Description  rom browser
pet

 Download 
Filename  rombrowser-0.3.pet 
Filesize  682.13 KB 
Downloaded  561 Time(s) 
loemu_0.3.1_i386.pet
Description  rom browser
pet

 Download 
Filename  loemu_0.3.1_i386.pet 
Filesize  59.25 KB 
Downloaded  522 Time(s) 
gromlist-0.3.2.pet
Description  rom browser
pet

 Download 
Filename  gromlist-0.3.2.pet 
Filesize  58.37 KB 
Downloaded  511 Time(s) 
emuexec-1.2-2.i386.pet
Description  rom browser
pet

 Download 
Filename  emuexec-1.2-2.i386.pet 
Filesize  176.85 KB 
Downloaded  695 Time(s) 
gl098s.zip
Description  Game Launcher Source Code.
zip

 Download 
Filename  gl098s.zip 
Filesize  349.57 KB 
Downloaded  513 Time(s) 
gelide-0.1.3.tar.gz
Description  Gelide source code - needs compiling.. Requires Python, etc... Run in terminal for full list of dependencies!
gz

 Download 
Filename  gelide-0.1.3.tar.gz 
Filesize  1.65 MB 
Downloaded  526 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Sun 04 Oct 2009, 14:33    Post_subject:  NEW VERSION AVAILABLE
Sub_title: PUPPY ARCADE V2
 

NEW VERSION: Puppy Arcade V2

The new versions have many more features, are VERY easy to use and only slightly larger!!

'Puppy Arcade V2' comes in 3 flavours:

All versions feature many emulators and are identical, except that the 'goffice' version contains the 'goffice' suite (abiword, gnumeric, inkscape), while the 'openoffice' version features 'OpenOffice2.2' (base, calc, writer, impress & draw).

(Both office versions feature working CUPS, but printer drivers not included.. get gutenprint etc)
______________________________________

Download 'Puppy Arcade V2':
http://www.sendspace.com/file/p5vcvg (104MB, MD5: bbf63866bfae2f7b9ebf51df10dba831)

Download 'Puppy Arcade V2 + goffice':
http://www.sendspace.com/file/2mrucp (120MB, md5: da926e991801c847e9f25b940ad5f936)

Download 'Puppy Arcade V2 + openoffice':
http://www.sendspace.com/file/2s7kys (203MB, md5: cbd329834237c8362206fcb6a1721213)
_____________________________________

'Puppy Arcade V2' (all versions above) include emulators for the following systems, all with frontends:

Amiga, Atari, Amstrad, Arcade Machines, Colecovision, Commodore 64, GameBoys (GB, GBC, GBA), GameGear, Genesis, Intellivision, MasterSystem, MS DOS, NeoGeo, NeoGeo CD, NES/Famicom, PC Engine/TurboGrafix 16, PSX, Scumm, SNES.

V2 also includes:

- PupSaveConfig - easily create save files before logoff
- GtkHash - check/verify file integrity for downloads
- PStreamVid - watch online TV through Gxine
- Wish Rush- tiny dual pane file manager
- Office and productivity suite via online services (zoho, editgrid, etc)
- AdvanceScan - ROM Manager, type 'advscan' in the terminal for details
- Right-click conversion/extraction of .deb, .rpm, tgz and pet files!! Smile
- Improved shutdown menu and options
- LOADS of great bookmarks and bookmarklets (inc fireBug!!) , nicely organised in FirePup Very Happy

This puplet does not include any BIOS files for Amiga, PSX, etc, or any roms.
______________________________________

To play Amiga roms: Download the kickstart files (kick13, kick20, kick31), and put them in /usr/lib/uae.. Then create a symlink called 'kick.rom' that points to the required kickstart file. Use the 'CPU Type: 68020' and the 'Full ECS' chipset.. Works fine for me!!
______________________________________

Thanks to Makoto, Ale, Dingo, dejan555, ttuuxxx, zigbert, Feel, tikbalang, MU and others for all your files, suggestions, examples and help.

Edited_times_total
Back to top
View user's profile Send_private_message 
Ale


Joined: 30 Nov 2007
Posts: 34

PostPosted: Sun 04 Oct 2009, 18:53    Post_subject:  

Just tested it briefly to see how the guis we talked about turned out. They work basically and functional. If you wanted to you could include some roms you could go to http://www.pdroms.de/ they are all free. Some are not the latest versions.

I think that an 8 bit styled puppy logo would be a good way to emphasize the arcade idea.
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Mon 05 Oct 2009, 01:26    Post_subject:  

Ale wrote:
Just tested it briefly to see how the guis we talked about turned out. They work basically and functional. If you wanted to you could include some roms you could go to http://www.pdroms.de/ they are all free. Some are not the latest versions.

I think that an 8 bit styled puppy logo would be a good way to emphasize the arcade idea.

Thanks for the link, I decided not to include any roms in the ISO, freeware or otherwise, simply to keep the filesize as small as possible... And thanks for your help on the GUIs.... MUCH appreciated Smile
Back to top
View user's profile Send_private_message 
Dingo


Joined: 11 Dec 2007
Posts: 1425
Location: somewhere at the end of rainbow...

PostPosted: Mon 05 Oct 2009, 05:59    Post_subject:  

Downloaded, burned, loaded and... Hu, Ho! Huston, We have a problem!

UAE (Amiga emulator), seems unable to read my Amiga kickstart (1.3 and 3.1 both) that are read fine by E-UAE

I select the MEMORY TAB in UAE
click on kickstart location

but path is not retained in UAE, so emulator can't start

I have installed E-UAE (and deleted .uaerc in /root/) and kickstart are read and games start. I'll further ijvestigate in order to help to solve problems

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send_private_message Visit_website 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Mon 05 Oct 2009, 07:10    Post_subject:  

Dingo wrote:
UAE (Amiga emulator), seems unable to read my Amiga kickstart (1.3 and 3.1 both) that are read fine by E-UAE

Hmmmmmmm.... I have it working fine - I'm playing 'Another World' right now, using kickstart files from btjunkie... But I guess I should've just gone with E-UAE like you said, Dingo!! Confused

But, if anyone else is having problems, this is how I got it working..

I downloaded the kickstart files (kick13, kick20, kick31), and put them in /usr/lib/uae.. I then created a symlink called 'kick.rom' that points to the required kickstart file.

By the way, I am playing using the 'CPU Type: 68020' and the 'Full ECS' chipset.. Works fine for me!! Very Happy
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 05 Oct 2009, 09:00    Post_subject:  

sc0ttman, removing RP-PPPOE is a bad choice.
You should know that there are A LOT of users using A/DSL connections.

Also, how about replacing some emulators with more accurate / better ones? The emulators included in Puppy Arcade are a bit on the lame side Sad

For example:

* bsnes - the best SNES emulator is now GPL / Open Source. It emulates 99.9% of the SNES games with absolute perfection.
http://byuu.org/

* Gambatte - the best and most accurate Game Boy / GB Color emulator for Linux - also Open Source.
http://sourceforge.net/projects/gambatte/

* NEStopia - the *KING* of NES emulators and a true showcase of what the power of Open Source can do. Beats any NES emulator on the planet.
http://rbelmont.mameworld.info/?page_id=200

* KEGA Fusion - the best SEGA Genesis / SEGA CD / Master System / Game Gear / SG-1000 emulator now has a Linux version as well.
http://www.eidolons-inn.net/tiki-index.php?page=Kega

* VBA-M - it's light years above VBA in compatibility , accuracy , features and playability. The best GBA emulator ever.
http://sourceforge.net/projects/vbam/

* Mednafen is one of the best Open-Source TurboGrafx and multisystem emulators. It emulates the PCEngine (TurboGrafx16 + SuperGrafx), Atari Lynx, Neo Geo Pocket (Color), NEC PC-FX, WonderSwan (Color) and more Smile
http://mednafen.sourceforge.net/

* Yabause - the one and only Open Source SEGA Saturn Emulator for Linux
http://yabause.org/

Edited_times_total
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 05 Oct 2009, 09:17    Post_subject:  

One more thing: Please upgrade Puppy Arcade to Puppy Linux v4.3.1 (when it's released). Puppy 4.3 is faster, better and supports newer ATI and NVIDIA cards and drivers.
(i.e. It's impossible to install newer ATI Catalyst or NVIDIA ForceWare drivers on Puppy 4.2)
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Mon 05 Oct 2009, 09:54    Post_subject:  

panzerpuppy wrote:
sc0ttman, removing RP-PPPOE is a bad choice.
You should know that there are A LOT of users using A/DSL connections.

If someone downloaded the ISO, they can download PPPoE if they want it..

panzerpuppy wrote:

Also, how about replacing some emulators with more accurate / better ones? The emulators included in Puppy Arcade are a bit on the lame side

I've seen all those other emulators, and are not including any of them for the reasons I have already stated in previous posts - either they have large dependencies (QT etc), high system requirements (Kega), couldn't be compiled (VBA-M) or have poor speed, compatiblity or playability (Yabause). Remember, Puppy Arcade is for low-end PCs... I always said I intended to keep the basic version around 100MB... So most of those emulators are simply not suitable for what I wanted to create.

panzerpuppy wrote:
One more thing: Please upgrade Puppy Arcade to Puppy Linux v4.3.1 (when it's released).

If 4.3 worked with Pet-be-Gone, then I would have... But I have already said I will try to make a sfs file of all the emulators I used in Puppy Arcade, so they can be added as needed.. Even if they are 'lame'.

By the way, if anyone feels Puppy Arcade V2 isn't good enough for their needs, feel free to improve it, remaster it and post your own ISO on this thread. I'm sure it's not perfect, but I'm done!
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Mon 05 Oct 2009, 11:55    Post_subject: Puppy Arcade V2 SFS Files Available
Sub_title: Add Puppy Arcade to any 4.2 or 4.3 installation!! :)
 

SFS Files for Puppy Arcade V2: Add to your own puppy install to get the emulators listed below!!

Amiga, Atari, Amstrad, Arcade Machines, Colecovision, Commodore 64, GameBoys (GB, GBC, GBA), GameGear, Genesis, Intellivision, MasterSystem, MS DOS, NeoGeo, NeoGeo CD, NES/Famicom, PC Engine/TurboGrafix 16, PSX, Scumm, SNES.

Download 'Puppy Arcade V2 SFS' for Puppy 4.2:
http://www.sendspace.com/file/jcijku (31MB, md5: d542eb1c3a5c85dc26eb1c92424ce159)

Download 'Puppy Arcade V2 SFS' for Puppy 4.3:
http://www.sendspace.com/file/cb6csr (31MB, md5: aa61adab0bdcf04242603a4d5cdac155)

Add these files to the same directory as your 'pup_42*.sfs' or 'pup_43*.sfs' files... You will need to rename the end of the files to match your puppy version.. Example: Change '_420.sfs' to '_421.sfs' for version 4.2.1

Hope you enjoy! Smile
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Mon 05 Oct 2009, 16:05    Post_subject:  

Dingo wrote:
Downloaded, burned, loaded and... Hu, Ho! Huston, We have a problem!

UAE (Amiga emulator), seems unable to read my Amiga kickstart (1.3 and 3.1 both) that are read fine by E-UAE

I select the MEMORY TAB in UAE
click on kickstart location

but path is not retained in UAE, so emulator can't start

I have installed E-UAE (and deleted .uaerc in /root/) and kickstart are read and games start. I'll further investigate in order to help to solve problems

Thanks Dingo, if you let everyone know, that will be great.. I'm not going to update Puppy Arcade any further, so people will have to make any changes themselves.. People may like to share any puplets created that use the Puppy Arcade SFS/PET file on this thread.

I'm out! Shocked
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Mon 05 Oct 2009, 19:54    Post_subject:  

In regard to the SFS version... ah, now I don't have to risk ruining my pup_save file. Very Happy (Although, I might end up doing that anyway if I do experiment with Puppy 4.3...)
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 11, 12, 13 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1151s ][ Queries: 13 (0.0071s) ][ GZIP on ]