Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 04:29
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Puppy 4.3 APM won't power off [solved]
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
noabody

Joined: 08 Jun 2009
Posts: 14

PostPosted: Wed 23 Sep 2009, 18:51    Post_subject:  Puppy 4.3 APM won't power off [solved]  

Racked my brains on this one. Finally found the key to the answer here: http://www.rigacci.org/docs/biblio/online/debian_survival/APM_Power.html

Essentially some older APM based machines won't power off if they don't have the apm=power-off kernel option. As that web page states, the kernel option on the boot line is only applicable if apm was built into the kernel. That is clearly not the case with the 2.6.30.5 in Puppy 4.3.

grep apm /etc/rc.d/rc.*

revealed that /etc/rc.d/rc.sysinit has a modprobe apm line.
As per the instructions on the noted website, I altered this line to read as modprobe apm power_off=1.

For me this was line 247 and it originally looked like:
[ ! -d /proc/acpi ] && modprobe apm #v406
changed to
[ ! -d /proc/acpi ] && modprobe apm power_off=1 #v406

So don't waste your time with kernel boot options for loaded modules when you need an apm power down workaround.

Hope this helps somebody, I figured the change had to occur on the first instance of modprobe apm so I don't think there is any other solution to this problem.
Back to top
View user's profile Send_private_message 
Gunny


Joined: 07 Dec 2008
Posts: 10
Location: Florida

PostPosted: Wed 23 Sep 2009, 23:01    Post_subject:  

You could edit your GRUB configuration file '/boot/grub/menu.lst' by adding acpi=force

kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal acpi=force
Back to top
View user's profile Send_private_message 
noabody

Joined: 08 Jun 2009
Posts: 14

PostPosted: Thu 24 Sep 2009, 19:10    Post_subject:  

Sorry but I was quite vague on my initial post. It is accurate if you have a problem computer that only supports APM. For me this was an Inspiron 7000 laptop. Dell simply did not release an ACPI bios for it. I tried almost every conceivable ACPI and APM option on the kernel boot line of /boot/grub/menu.lst and none of them worked.

For me I get errors when I try to modprobe acpi. I have /proc/apm, dmesg indicates that APM is loaded - pretty much everything indicates that I have an APM machine so no ACPI option will have any effect on it.

That's why I made this forum post. There are certain things that just work for 99% of everybody out there. Every forum search I made said use acpi=force but it didn't do a thing for me. My computer would shut down right to the point where it said "system halted" and just remain on. I knew linux could power the computer off because I had it working in Puppy 4.2 but I think apm was built into that kernel so the command line option apm=power-off worked. I do remember that it took quite some time to get it working in Puppy 4.2 so maybe the solution was the same but I never bothered to post what I did and then I forgot about it - until I decided to do a fresh install of 4.3.

So for the poor folks out there stuck with an ancient APM based computer that needs that magical power-off workaround. Hopefully you'll find this post regardless of what linux distribution you are using. And hopefully I'll find it again the next time I forget what I did to fix it.
Back to top
View user's profile Send_private_message 
davids45


Joined: 26 Nov 2006
Posts: 652
Location: Chatswood, NSW

PostPosted: Thu 24 Sep 2009, 20:02    Post_subject:  

G'day noabody,

Thanks for finding this line 247 fix for computers that only half turn-off with 4.3 (in my case, Pups 4.24 and 4.25).
My non-ancient Medion 8818 desktop would not shut down with 4.3 betas (and a few other newer kernel Pups) whereas my older Medion 8383 desktop was fine.
With these Pups, I have to boot the 8818 using acpi=off and I assumed this incomplete shut down was a consequence of this start-up necessity.

Thank you for your great sleuthing, even for some newish computers!

David S.
Back to top
View user's profile Send_private_message 
James186282


Joined: 08 Sep 2009
Posts: 142
Location: Minnesota

PostPosted: Tue 27 Oct 2009, 01:39    Post_subject:  

I'm using a Compaq Armada M700 laptop and it won't shut down unless I do a control alt backspace to dump the screen.

I've tried all the suggestions on this link but??? This did work in previous versions of puppy. I'm using 4.30 now and its really annoying me.

Thanks for any ideas.
Back to top
View user's profile Send_private_message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 27 Oct 2009, 03:28    Post_subject:  

My laptop powers off fine, but pc says "system halted".

A quick push on the power button turns the pc off safely.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 
James186282


Joined: 08 Sep 2009
Posts: 142
Location: Minnesota

PostPosted: Tue 27 Oct 2009, 10:51    Post_subject:  

I found the solution after searching other threads. It seems that the screen needed to sleep for a second then kill X in a different way. Happily it works perfectly as this was very "widowesc" having had a number of machines that would not shut down. VERY annoying. I rather wish our OS was able to just shut off in an instant but I have to admit waiting 5 or 6 seconds is a HUGE improvement over the minutes of grinding that the Windows os seems to need to do to get ready for its next 10 minute start up. SIGH...

Anyhow, consider this SOLVED.
Back to top
View user's profile Send_private_message 
olsonm3915

Joined: 14 Nov 2009
Posts: 2

PostPosted: Sat 14 Nov 2009, 11:35    Post_subject:  

noabody wrote:
Sorry but I was quite vague on my initial post. It is accurate if you have a problem computer that only supports APM. For me this was an Inspiron 7000 laptop. Dell simply did not release an ACPI bios for it. I tried almost every conceivable ACPI and APM option on the kernel boot line of /boot/grub/menu.lst and none of them worked.
[snip]

So for the poor folks out there stuck with an ancient APM based computer that needs that magical power-off workaround. Hopefully you'll find this post regardless of what linux distribution you are using. And hopefully I'll find it again the next time I forget what I did to fix it.


I'm typing this on a Dell Inspiron 7000 laptop with a 300MHz Pentium II processor. Your information was exactly what I needed to get my old yet still useful system to automatically power off. Thank you!
Back to top
View user's profile Send_private_message 
olsonm3915

Joined: 14 Nov 2009
Posts: 2

PostPosted: Sat 14 Nov 2009, 11:37    Post_subject:  

noabody wrote:
Sorry but I was quite vague on my initial post. It is accurate if you have a problem computer that only supports APM. For me this was an Inspiron 7000 laptop. Dell simply did not release an ACPI bios for it. I tried almost every conceivable ACPI and APM option on the kernel boot line of /boot/grub/menu.lst and none of them worked.
[snip]

So for the poor folks out there stuck with an ancient APM based computer that needs that magical power-off workaround. Hopefully you'll find this post regardless of what linux distribution you are using. And hopefully I'll find it again the next time I forget what I did to fix it.


I'm typing this on a Dell Inspiron 7000 laptop with a 300MHz Pentium II processor. Your information was exactly what I needed to get my old, but still useful system to automatically power off. Thank you!
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Fri 27 Nov 2009, 16:12    Post_subject:  

noabody,
Thanks for posting your solution to the shutdown problem. It works on my ~1997 Aptiva. I have added a comment to Issue 21 ("acpi on/of/force shutdown problems") of the new puppy 4.4CE bug tracking system, suggesting this as a fix that might be made permanent, unless anyone knows why it should not be -- or if some conditions apply.

http://code.google.com/p/puppy-development/issues/detail?id=21
Richard
Back to top
View user's profile Send_private_message 
Mitchellray

Joined: 07 Dec 2009
Posts: 87

PostPosted: Wed 16 Dec 2009, 18:52    Post_subject: apm power_off=1 worked - two questions  

Hello,
'power_off=1 worked' on my desktop.
I had to turn on the APM switch in bios.
Oddly, I had a similar problem when I started using Slackware a while back, and acpi=off added (believe it that I can not remember where I put it) seemed to solve the problem.

Two question:
1. Where is the script command for system shutdown if acpi=off and apm power_off=1 are not present in 4.3.1?
I ask because Puppy could already shutdown my Asus1005HA without adding those commands.

2. Where is that /boot/grub/menu.lst file (4.3.1), because I would like to try that approach to see if it would work (even though you found one solution) since I know my machine has acpi?
Mitchellray
Back to top
View user's profile Send_private_message 
bugman


Joined: 20 Dec 2005
Posts: 2131
Location: buffalo commons

PostPosted: Wed 23 Dec 2009, 18:43    Post_subject:  

THANK YOU

the computer i am setting up puppy 4.31 on does not really shut off if you push the button [it hibernates], i've been unplugging the damn thing--until now!

Code:
power_off=1


Cool

_________________
. . . the machines are clean
and the machines are not corrupted


- lee "scratch" perry
Back to top
View user's profile Send_private_message Visit_website 
yorkiesnorkie


Joined: 04 Jun 2007
Posts: 505
Location: George's Island

PostPosted: Mon 01 Mar 2010, 13:01    Post_subject:  

noabody wrote:

Quote:
Racked my brains on this one. Finally found the key to the answer here: http://www.rigacci.org/docs/biblio/online/debian_survival/APM_Power.html

Essentially some older APM based machines won't power off if they don't have the apm=power-off kernel option. As that web page states, the kernel option on the boot line is only applicable if apm was built into the kernel. That is clearly not the case with the 2.6.30.5 in Puppy 4.3.

grep apm /etc/rc.d/rc.*

revealed that /etc/rc.d/rc.sysinit has a modprobe apm line.
As per the instructions on the noted website, I altered this line to read as modprobe apm power_off=1.

For me this was line 247 and it originally looked like:
[ ! -d /proc/acpi ] && modprobe apm #v406
changed to
[ ! -d /proc/acpi ] && modprobe apm power_off=1 #v406

So don't waste your time with kernel boot options for loaded modules when you need an apm power down workaround.

Hope this helps somebody, I figured the change had to occur on the first instance of modprobe apm so I don't think there is any other solution to this problem.


Brilliant!

I have puppy 4.3.0 with the service pack installed. This was the first puppy that wouldn't shut down all the way on its own.

I modified line 249 of /etc/rc.d/rc.sysinit

Quote:
[ ! -d /proc/acpi ] && modprobe apm #v406
changed to
[ ! -d /proc/acpi ] && modprobe apm power_off=1 #v406


...and then I shut down. Of course it didn't work that time. However, on the next reboot after I was done with my computer and shut down using the menu, it actually shut down my PC, which is an IBM 380 XD with mmx.

So, THANK YOU noabody! This is an awesome bugfix.

Yorkiesnorkie
Smile
Back to top
View user's profile Send_private_message 
Bud

Joined: 27 Apr 2010
Posts: 4

PostPosted: Sun 03 Oct 2010, 15:55    Post_subject:  
Sub_title: Thanks!
 

Awesome, thank you noabody, this was driving me nuts and substituting that line did the job! Old Vaio shuts down like a clam. Smile
Back to top
View user's profile Send_private_message 
JesseKnows

Joined: 10 Mar 2012
Posts: 1

PostPosted: Sat 10 Mar 2012, 18:15    Post_subject:  

This worked for my Dell Latitude CPi (P2 366MHz) with Puppy 4.3.1.

Thanks, OP!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1191s ][ Queries: 12 (0.0324s) ][ GZIP on ]