Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 19:26
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Display resolution set to 1280 X 1024 but still doesn't fit
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Sun 06 Sep 2009, 13:56    Post_subject:  Display resolution set to 1280 X 1024 but still doesn't fit  

my monitor display should be 1280 X 1024 @60Hz
On Puppy, it is set that way but the display is short by between 30 and 40 pixels on the right and left sides. I'm wondering what can be done about that. I have Puppy 4.1 and my settings are saved to a pen drive. I also have the NVidia driver installed for my GeForce FX 5200 graphics card and I use X.org.
Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1847
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Mon 07 Sep 2009, 03:23    Post_subject:  

Hello gymnart,
I had the same problem because my NVIDIA driver was not the latest one !
Try this :

http://files.wildspad.com/afecelis/linux/puppy/drivers/NVIDIA-177.82-k2.6.25.16.pet

Regards
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6458
Location: Auckland, New Zealand

PostPosted: Mon 07 Sep 2009, 03:30    Post_subject:  

I take it that you can't simply adjust the monitor settings?
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Mon 07 Sep 2009, 16:52    Post_subject:  

@disciple: no, I can't adjust the monitor because I use it on SuSE and everything works/looks fine with that distro. If I change anything to suit puppy, then the settings will be messed up for SuSE.

@Argolance: Thanks I'll have to try it out.
Back to top
View user's profile Send_private_message Visit_website 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 16 Sep 2009, 11:16    Post_subject:  

ok, now I've tried that latest Nvidia driver but still, the display does not take up the entire screen.

When I clicked on the Nvidia settings, it said something about using nvidia xconfig. I don't know how to get to that. I don't even know if that would fix this.
Back to top
View user's profile Send_private_message Visit_website 
piratesmack


Joined: 16 Sep 2009
Posts: 100

PostPosted: Wed 16 Sep 2009, 11:23    Post_subject:  

gymnart wrote:
@disciple: no, I can't adjust the monitor because I use it on SuSE and everything works/looks fine with that distro. If I change anything to suit puppy, then the settings will be messed up for SuSE.


Can you post your SUSE /etc/X11/xorg.conf?
And your Puppy one, too
Back to top
View user's profile Send_private_message 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 16 Sep 2009, 11:43    Post_subject:  

Well, here's another thing about the new driver: Now OpenGL does not work.
How can I go back to the one that Open GL worked? Or how do I get it to work with this newer one?
ok, now I gotta find my x11 stuff to post for you. Smile
Back to top
View user's profile Send_private_message Visit_website 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 16 Sep 2009, 11:51    Post_subject:  

From Puppy:
Code:

#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
    Load        "type1"
    Load        "freetype"

# This loads xtrap extension, used by xrandr
    Load       "xtrap"

# This loads the GLX module (if present)
    Load       "glx"

# This loads dri module (if present)
    Load       "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath   "/usr/X11R7/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/X11R7/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R7/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R7/lib/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102"
   Option      "XkbLayout" "us" #xkeymap0
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   Option       "Device" "/dev/mouse"
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
   #DisplaySize     380   300   # mm
   Identifier   "Monitor0"
   VendorName   "SAM"
   ModelName    "SyncMaster"
   ### Comment all HorizSync and VertRefresh values to use DDC:
   Option       "DPMS"
   HorizSync    30.0-81.0
   VertRefresh  56.0-71.0
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1280x1024"
   EndSection
   
Section "Modes"
   Identifier "Modes0"
   #modes0modeline0
EndSection

Section "Device"
   ### Available Driver options are:-
   ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
   ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   ### [arg]: arg optional
   #Option     "SWcursor"              # [<bool>]
   #Option     "HWcursor"              # [<bool>]
   #Option     "NoAccel"               # [<bool>]
   #Option     "ShadowFB"              # [<bool>]
   #Option     "UseFBDev"              # [<bool>]
   #Option     "Rotate"                # [<str>]
   #Option     "VideoKey"              # <i>
   #Option     "FlatPanel"             # [<bool>]
   #Option     "FPDither"              # [<bool>]
   #Option     "CrtcNumber"            # <i>
   #Option     "FPScale"               # [<bool>]
   #Option     "FPTweak"               # <i>
   #Option     "DualHead"              # [<bool>]
   Identifier  "Card0"
   Driver      "nv" #card0driver
   VendorName  "nVidia Corporation"
   BoardName   "NV34 [GeForce FX 5200]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
    DefaultDepth 16
    Subsection "Display"
        Depth       16
        Modes       "1280x1024"
    EndSubsection
EndSection

#PuppyHardwareProfile=NVIDIASyncMaster


From SuSE:
Code:

# /.../
# SaX generated X11 config file
# Created on: 2007-04-13T16:01:46-0400.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/local"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/URW"
  FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
  FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/kwintv"
  FontPath     "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath     "/usr/X11R6/lib/X11/fonts/uni:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/CID"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/ttyS0"
  InputDevices "/dev/ttyS1"
  InputDevices "/dev/ttyS2"
  InputDevices "/dev/ttyS3"
  InputDevices "/dev/ttyS4"
  InputDevices "/dev/ttyS5"
  InputDevices "/dev/ttyS6"
  InputDevices "/dev/ttyS7"
  InputDevices "/dev/ttyS8"
  InputDevices "/dev/psaux"
  InputDevices "/dev/logibm"
  InputDevices "/dev/sunmouse"
  InputDevices "/dev/atibm"
  InputDevices "/dev/amigamouse"
  InputDevices "/dev/atarimouse"
  InputDevices "/dev/inportbm"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/mouse"
  InputDevices "/dev/usbmouse"
  InputDevices "/dev/adbmouse"
  InputDevices "/dev/input/mice"
  InputDevices "/dev/input/event0"
  InputDevices "/dev/pointer0"
  InputDevices "/dev/pointer1"
  InputDevices "/dev/pointer2"
  InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "v4l"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "pc104"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  DisplaySize  377 301
  HorizSync    30-81
  Identifier   "Monitor[0]"
  ModelName    "SYNCMASTER 4S"
  Option       "DPMS"
  VendorName   "SAMSUNG"
  VertRefresh  56-75
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline    "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
  Modeline    "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
  Modeline    "1280x960" 126.27 1280 1368 1504 1728 960 961 964 1001
  Modeline    "1280x960" 107.32 1280 1360 1496 1712 960 961 964 995
  Modeline    "1280x800" 104.35 1280 1360 1496 1712 800 801 804 835
  Modeline    "1280x800" 88.68 1280 1352 1488 1696 800 801 804 830
  Modeline    "1152x864" 102.08 1152 1224 1352 1552 864 865 868 901
  Modeline    "1152x864" 86.70 1152 1224 1344 1536 864 865 868 896
  Modeline    "1280x768" 99.17 1280 1352 1488 1696 768 769 772 801
  Modeline    "1280x768" 84.35 1280 1344 1480 1680 768 769 772 797
  Modeline    "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
  Modeline    "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
  Modeline    "800x600" 47.53 800 840 920 1040 600 601 604 626
  Modeline    "800x600" 40.19 800 832 912 1024 600 601 604 623
  Modeline    "768x576" 43.52 768 800 880 992 576 577 580 601
  Modeline    "768x576" 37.37 768 800 880 992 576 577 580 598
  Modeline    "640x480" 29.84 640 664 728 816 480 481 484 501
  Modeline    "640x480" 25.10 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      32
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "GeForce FX 5200 (0x0322)"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection

Back to top
View user's profile Send_private_message Visit_website 
piratesmack


Joined: 16 Sep 2009
Posts: 100

PostPosted: Wed 16 Sep 2009, 12:25    Post_subject:  

Well, it looks like your xorg is configured to use the nv driver and not the nvidia driver (probably why opengl isn't working also)

So try this:

In the "Device" section of puppy's xorg, change
Code:

Driver      "nv" #card0driver


To

Code:
Driver      "nvidia" #card0driver


Then restart X and see if it helped.

If that doesn't work, try using this xorg.conf:
Code:

#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
    Load        "type1"
    Load        "freetype"

# This loads xtrap extension, used by xrandr
    Load       "xtrap"

# This loads the GLX module (if present)
    Load       "glx"

# This loads dri module (if present)
    Load       "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath   "/usr/X11R7/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/X11R7/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R7/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R7/lib/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102"
   Option      "XkbLayout" "us" #xkeymap0
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   Option       "Device" "/dev/mouse"
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
   DisplaySize     377   301   # mm
   Identifier   "Monitor0"
   VendorName   "SAM"
   ModelName    "SyncMaster"
   ### Comment all HorizSync and VertRefresh values to use DDC:
   Option       "DPMS"
   #HorizSync    30.0-81.0
   VertRefresh  56-75
   UseModes     "Modes0" #monitor0usemodes
   #Option      "PreferredMode" "1280x1024"
   EndSection
   
Section "Modes"
   Identifier "Modes0"
   #modes0modeline0
   Modeline    "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
   Modeline    "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
   Modeline    "1280x960" 126.27 1280 1368 1504 1728 960 961 964 1001
   Modeline    "1280x960" 107.32 1280 1360 1496 1712 960 961 964 995
   Modeline    "1280x800" 104.35 1280 1360 1496 1712 800 801 804 835
   Modeline    "1280x800" 88.68 1280 1352 1488 1696 800 801 804 830
   Modeline    "1152x864" 102.08 1152 1224 1352 1552 864 865 868 901
   Modeline    "1152x864" 86.70 1152 1224 1344 1536 864 865 868 896
   Modeline    "1280x768" 99.17 1280 1352 1488 1696 768 769 772 801
   Modeline    "1280x768" 84.35 1280 1344 1480 1680 768 769 772 797
   Modeline    "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
   Modeline    "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
   Modeline    "800x600" 47.53 800 840 920 1040 600 601 604 626
   Modeline    "800x600" 40.19 800 832 912 1024 600 601 604 623
   Modeline    "768x576" 43.52 768 800 880 992 576 577 580 601
   Modeline    "768x576" 37.37 768 800 880 992 576 577 580 598
   Modeline    "640x480" 29.84 640 664 728 816 480 481 484 501
   Modeline    "640x480" 25.10 640 656 720 800 480 481 484 498
EndSection

Section "Device"
   ### Available Driver options are:-
   ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
   ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   ### [arg]: arg optional
   #Option     "SWcursor"              # [<bool>]
   #Option     "HWcursor"              # [<bool>]
   #Option     "NoAccel"               # [<bool>]
   #Option     "ShadowFB"              # [<bool>]
   #Option     "UseFBDev"              # [<bool>]
   #Option     "Rotate"                # [<str>]
   #Option     "VideoKey"              # <i>
   #Option     "FlatPanel"             # [<bool>]
   #Option     "FPDither"              # [<bool>]
   #Option     "CrtcNumber"            # <i>
   #Option     "FPScale"               # [<bool>]
   #Option     "FPTweak"               # <i>
   #Option     "DualHead"              # [<bool>]
   Identifier  "Card0"
   Driver      "nvidia" #card0driver
   VendorName  "nVidia Corporation"
   BoardName   "NV34 [GeForce FX 5200]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
     Depth      15
     Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
   EndSubSection
   SubSection "Display"
     Depth      16
     Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
   EndSubSection
   SubSection "Display"
     Depth      24
     Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
   EndSubSection
   SubSection "Display"
     Depth      32
     Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
   EndSubSection
   SubSection "Display"
     Depth      8
     Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
   EndSubSection
EndSection

#PuppyHardwareProfile=NVIDIASyncMaster
Back to top
View user's profile Send_private_message 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 16 Sep 2009, 12:55    Post_subject:  

ok, I tried that but it looks like puppy is not using the new one. It looks like it went back to using the previous one and "insists" on use the nv driver and not "nvidia".

Can I uninstall this newer driver? After that, can I install the older one without rebooting or something? That's what I think I will try.
Back to top
View user's profile Send_private_message Visit_website 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 16 Sep 2009, 13:16    Post_subject:  

Well ok, now I have that newer Nvidia driver uninstalled (I think) and I'm pretty sure that I'm back to the older one (173.14.12-k2.6.25.16) but still, OpenGL is not working. I did a dependency check for Armagetron and it said that it was missing libgluso.1. When I try using SweetHome3D, it still tells me that I should update my directx/opengl drivers. I did not get this message before trying out that newer nvidia driver (177.82-k2.6.25.16)

Nvidia settings don't even show up in the menu like it used to before I tried that newer driver.

On top of all that, when I boot back into SuSE, the boot screen is moved over to the left too far now! It was not like that before, it used to be nicely centered. Once I'm all booted into SuSE, then the display seems to be ok. When I'm shutting it down, that shutting down screen is moved too far over to the left.

This is the Device section of Puppy's X11.conf:
Code:

Section "Device"
   ### Available Driver options are:-
   ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
   ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   ### [arg]: arg optional
   #Option     "SWcursor"              # [<bool>]
   #Option     "HWcursor"              # [<bool>]
   #Option     "NoAccel"               # [<bool>]
   #Option     "ShadowFB"              # [<bool>]
   #Option     "UseFBDev"              # [<bool>]
   #Option     "Rotate"                # [<str>]
   #Option     "VideoKey"              # <i>
   #Option     "FlatPanel"             # [<bool>]
   #Option     "FPDither"              # [<bool>]
   #Option     "CrtcNumber"            # <i>
   #Option     "FPScale"               # [<bool>]
   #Option     "FPTweak"               # <i>
   #Option     "DualHead"              # [<bool>]
   Identifier  "Card0"
   Driver      "nv" #card0driver
   VendorName  "nVidia Corporation"
   BoardName   "NV34 [GeForce FX 5200]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
    DefaultDepth 16
    Subsection "Display"
        Depth       16
        Modes       "1280x1024"
    EndSubsection
EndSection

#PuppyHardwareProfile=NVIDIASyncMaster


Like I said, when I had tried to edit it, Puppy didn't seem to use it, the file seemed to just go back to the info it had before.
Back to top
View user's profile Send_private_message Visit_website 
Makoto


Joined: 03 Sep 2009
Posts: 1811
Location: Out wandering... maybe.

PostPosted: Thu 17 Sep 2009, 04:05    Post_subject:  

gymnart wrote:
@disciple: no, I can't adjust the monitor because I use it on SuSE and everything works/looks fine with that distro. If I change anything to suit puppy, then the settings will be messed up for SuSE.


You might check to see whether or not your monitor has an automatic-adjust feature. That way, it might attempt to set the screen properly for both distros.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Fri 18 Sep 2009, 13:06    Post_subject:  

Yes, my son-in-law found it and adjusted it while SuSE was booting up and it said "auto adjust in progress". I hope it stays put next time I boot SuSE.

It does not seem to auto adjust for Puppy though and I am still concerned that if I mess with the monitor settings, that it would affect the settings for SuSE. (the monitor is a Samsung SyncMaster 930B)

Anyway, since OpenGL no longer works on my puppy now, I think I will delete this save file and replace it with my previously saved session (before the driver update attempt.)
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6458
Location: Auckland, New Zealand

PostPosted: Mon 21 Sep 2009, 05:29    Post_subject:  

FWIW the "correct" answer to the original question should be:
- Menu
- Setup
- Xorg Video Wizard
- xvidtune
- play with the settings

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1893s ][ Queries: 12 (0.0256s) ][ GZIP on ]