Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 03:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Ati Catalyst 9.7+9.8 graficsdrivers for Puppy 4.3beta1
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 15 Aug 2009, 13:53    Post subject:  Ati Catalyst 9.7+9.8 graficsdrivers for Puppy 4.3beta1
Subject description: for NEW Ati-cards
 

update:
for Puppy 4.3 beta 2/3 go here:
http://www.murga-linux.com/puppy/viewtopic.php?t=46507

------------------------------------------------------------------------------

supported cards:
http://dotpups.de/puppy4/dotpups/XServer/catalyst_97_linux.pdf

You need a HD2000 or newer, older models are not supported by Catalyst 9.7/9.8!
This is for kernel 2.6.29.6 only, and does not work with older Puppys!

If your card is not supported, please try the older driver 9.3:
http://www.murga-linux.com/puppy/viewtopic.php?t=45601


Download 9.7:
http://dotpups.de/puppy4/dotpups/XServer/ati-catalyst-9.7-K2.6.29.6-puppy4.3beta1.pet
mirror:
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/XServer/ati-catalyst-9.7-K2.6.29.6-puppy4.3beta1.pet (user: puppy, password: linux)

Download 9.8:
http://dotpups.de/puppy4/dotpups/XServer/ati-catalyst-9.8-K2.6.29.6-puppy4.3beta1.pet
mirror:
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/XServer/ati-catalyst-9.8-K2.6.29.6-puppy4.3beta1.pet (user: puppy, password: linux)

You need more than 100 MB free diskspace to install it, and it does not automatically check, if you have enough Exclamation

The installation requires 2 steps:
1) install the pet
2) exit X, then type:
xorgwizard
There, select the Ati catalyst driver.

Step 2 uses an adapted new xorgwizard from Newyearspup, it will extract a archive that I made, and delete files, that might conflict with the driver.

NOTE:
If you do not use a US keyboard, you might not have your custom layout any more.
To fix that, you should modify the file /root/.xinitrc.
Add there after the line "#!/bin/sh" a new line, so that it looks like:

Code:
#!/bin/sh
setxkbmap -layout `cat /etc/keymap | cut -f1 -d.`

To compile the driver 9.7, I used this patch:
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/XServer/29patch/
from:
http://www.linuxquestions.org/questions/linux-hardware-18/fglrx-9.3-patch-for-2.6.29.x-kernel-722858/
9.8 no longer needs this patch.

Mark
catalyst_95_linuxscaled.jpg
 Description   screenshot of version 9.5
 Filesize   94.41 KB
 Viewed   5153 Time(s)

catalyst_95_linuxscaled.jpg


_________________
my recommended links

Last edited by MU on Sat 12 Sep 2009, 13:11; edited 4 times in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 15 Aug 2009, 20:53    Post subject:  

I updated the pet, the old one included an outdated xorgwizard.

And now it uses Catalyst 9.7 instead of 9.5.
If you already had installed 9.5, simply install the new one, without un-installing the old.
And you may delete the file:
/usr/local/graficsdrivers/ati.tgz
It is no longer needed.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sun 16 Aug 2009, 19:02    Post subject:  

@MU:

Catalyst 9.8 is out and it's a HUGE improvement over 9.7 Smile

- Linux kernel 2.6.29.x and 2.6.30.x support - no need for kernel patches
- Full OpenGL 3.1 and partial OpenGL 3.2 support
- Various performance and stability improvements
- XRandr 1.2 (screen rotation and multiple display arrangement via the CCC)
- Lots of bugfixes

For modern ATI cards only (HD2000,HD3000 and HD4000 series)

Direct download link:

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-9-8-x86.x86_64.run

MU wrote:
You need more than 100 MB free diskspace to install it, and it does not automatically check, if you have enough


Frugal install warning:
----------------------------
To install Catalyst using the official ATI installer,you'll need a pup_save of at least 768MB.
(the driver needs more than 300MB just for unpacking the files to a temporary directory)


panzerpuppy

Last edited by panzerpuppy on Tue 18 Aug 2009, 04:09; edited 9 times in total
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 17 Aug 2009, 14:57    Post subject:  

Thanks Panzerpuppy, I added a pet of driver 9.8.
I have only OpenGL 2.1 with it, though I use a "high end" card donated by a Puppy user (a HD4850).
I think, for OpenGL 3 we might need Xorg 7.5, not 7.3.

However, there are no real applications yet supporting OpenGL 3, as far as I know, so it should not matter.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 17 Aug 2009, 22:23    Post subject:  

OpenGL 3.x support requires creating a GL3 context.
The support IS there - you don't need a newer Xserver to enable/use it.

Even when using the OpenGL 2.1 context, you still get the benefit of the additional extensions included in Cat. 9.8 Smile
Back to top
View user's profile Send private message 
linvnguyen

Joined: 06 Sep 2009
Posts: 5

PostPosted: Sun 06 Sep 2009, 01:19    Post subject:  

Hi MU
I have run ati*9.8*run to install on kernel realtime 2.6.29.4-rt19, after reboot the monitor is out of range.
Would you like to guide how to build/install on that new kernel.

I am looking forward to hearing from you

Thanks and best regards
Back to top
View user's profile Send private message 
garcot

Joined: 11 Jul 2009
Posts: 20

PostPosted: Sun 06 Sep 2009, 03:40    Post subject:  

Hi MU,

Could you please let me know, how I could install NVIDIA latest driver installer in 4.3 beta1? I am getting errors with gcc version conflicts, which doesn't happen in Fatdog2 Beta.

What I am missing ?

Thanks for your time.

Garcot
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 06 Sep 2009, 10:33    Post subject:  

garcot,
I will see if I find time to add nvidia drivers for Puppy 4.3x this week.

linvnguyen,

you need the devx and kernelsource sfs for your puplet.
Add to the bootmanager, reboot.
Now you could install the original driver from Ati, or update my pet.

1.) install the Ati driver
download it from the link that panzerpuppy gave before.
Save it on a Linux-drive with a lot of free space.
Then "cd" there and type:
bash ati-driver-installer-9-8-x86.x86_64.run
Follow the instructions then.


OR:
2.) update the installation from my pet
Install my pet of the 9.8 driver.

Then download the attached zip, and extract it in /tmp/.
http://dotpups.de/puppy4/dotpups/XServer/fglrx-9.8source.tar.gz (1.6 MB)
Then type:
cd /tmp/fglrx/build_mod
./make.sh


This should compile a file called fglrx.ko.

Then extract:
/usr/local/graficsdrivers/atilatest.tgz

You then get
/usr/local/graficsdrivers/lib/modules/2.6.28.5/kernel/drivers/char/drm/fglrx.ko
Delete that, and instead add something like
/usr/local/graficsdrivers/lib/modules/2.6.29.4/kernel/drivers/char/drm/fglrx.ko
(with the new module you just compiled)

Then zip it again:
cd /usr/local/graficsdrivers
rm -f atilatest.tgz
tar -czvf atilatest.tgz etc lib usr
rm -rf etc
rm -rf lib
rm -rf usr


Then run xorgwizard again, and choose the "atilatest" driver.
Now my pet that you installed should use the new kernelmodule.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
garcot

Joined: 11 Jul 2009
Posts: 20

PostPosted: Sun 06 Sep 2009, 14:33    Post subject:  

Hi MU,

Thanks for your reply. There was no problem however, installing NVIDIA drivers in puppy 4.3 Beta 2 (Puppy 424 ). Except in the end it cried for some dependencies and depmod -a solved that issue. Latest Nvidia driver is installed and working flawlessly in AMD64 machine with HD install ext4.

Next is to try and install compiz, though I think, I will wait until the production version is released.


Thanks again,
Garcot
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sun 06 Sep 2009, 19:00    Post subject:  

@MU: Catalyst 9.10 BETA is out and can be found at the Ubuntu 9.10 repository.

This driver has some big fixes for WINE and native games,much better 2D performance, improved compositing,new OpenGL extensions and kernel 2.6.31 support.

Can you make a Puppy 4.3 package out of the Ubuntu package?
Back to top
View user's profile Send private message 
linvnguyen

Joined: 06 Sep 2009
Posts: 5

PostPosted: Sun 13 Sep 2009, 01:02    Post subject: Black screen on HD4350 also  

Hi MU,
I have tried two ways, but the first is also black screen after reboot.
The second, I can not compile fglrx, it inform some errors.

I am trying 9.9

Thanks & best regards

Linvnguyen
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 13 Sep 2009, 05:15    Post subject:  

linvnguyen,

the latest version 9.9 requires a newer xorg.
Use instead 9.8:
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-9-8-x86.x86_64.run

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sun 13 Sep 2009, 08:19    Post subject:  

@MU : We really need a modified Puppy 4.3 with k2.6.31, Xorg 7.4 (preferably with X.org 7.5 + Xserver 1.7 when it's released [this month]) and ALSA 1.0.21a.

This puppy (puplet?) will solve most of our problems with new and old hardware. Almost perfect for newer ATI cards if you use the Catalyst drivers.

k2.6.32 is even more interesting - it will include DRI and 3D support for R600 and R700 cards out of the box Smile

Why is DRI / 3D for xfree86-radeon so important? Because it greatly speeds up 2D as well (EXA will run much faster/snappier) Smile R600/R700 cards use 3D processing to display 2D stuff,unlike the older (R200/R300) cards which have dedicated chips.
Back to top
View user's profile Send private message 
linvnguyen

Joined: 06 Sep 2009
Posts: 5

PostPosted: Sun 13 Sep 2009, 23:29    Post subject:  

@MU
Even installing catalyst 9.8 pet on 4.3beta3, the screen is also black as default. I must use aticonfig as: aticonfig --initial --dtop=clone --hsync=0,30-71 to create xorg.conf again, And it is ok now.
on kernel-2.6.30.5, it is alright to compile fglrx.
on kernel-2.6.29.4-rt19, I can not compile fglrx, it inform some error.
=============================================
=============================================
Back to top
View user's profile Send private message 
linvnguyen

Joined: 06 Sep 2009
Posts: 5

PostPosted: Mon 14 Sep 2009, 05:42    Post subject:  

Hi MU
It is great to be automatically to detect the GPU and load suitable 3D GL libraries, kernel module for that GPU. How to do that ?

I see that features is very suitable, interesting for end user, because they don't know much about IT. And Puppy OS Framework will be usable in many fields, like me building media on puppy.

I am looking to hearing from you.

Best regards,

LinhNguyen
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0850s ][ Queries: 13 (0.0082s) ][ GZIP on ]