Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 05:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Ati Catalyst 9.3 graficsdrivers for Puppy 4.3beta1
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 15 Aug 2009, 17:57    Post_subject:  Ati Catalyst 9.3 graficsdrivers for Puppy 4.3beta1
Sub_title: for OLDER Ati-cards
 

This is version 9.3.

Use this driver, if the newer 9.7 does not support your card.
Look for more info and general usage of the catalyst driver here:
http://www.murga-linux.com/puppy/viewtopic.php?t=45594

Driver 9.3:

supported cards:
http://dotpups.de/puppy4/dotpups/XServer/catalyst_93_linux.pdf

Download:

http://dotpups.de/puppy4/dotpups/XServer/ati-catalyst-9.3-K2.6.29.6-puppy4.3beta1.pet
mirror:
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/XServer/ati-catalyst-9.3-K2.6.29.6-puppy4.3beta1.pet (user: puppy, password: linux)

Mark

_________________
my recommended links

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 15 Aug 2009, 20:52    Post_subject:  

I updated the pet, the old one included an outdated xorgwizard.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Vyse


Joined: 15 Aug 2009
Posts: 30

PostPosted: Mon 17 Aug 2009, 03:11    Post_subject:  

Thanks for the .pet, MU. Great work again!!

I just got myself a HD 4350 based graphics card, and it works wonderfully ( I am running Oblivion using Cedega)

If only there was a driver for my NVIDIA 7600GT which actually worked...
Back to top
View user's profile Send_private_message YIM 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Mon 17 Aug 2009, 15:08    Post_subject:  

I can try to add a recent Nvidia driver next weekend.
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Vyse


Joined: 15 Aug 2009
Posts: 30

PostPosted: Tue 18 Aug 2009, 07:34    Post_subject:  

MU wrote:
I can try to add a recent Nvidia driver next weekend.
Mark


That would be really great. Thanks!!
I already tried the latest drivers (185.18.14) but they arent working. X just doesnt start. Ahh well, it doesnt matter much.

Just one more thing..is it possible that my 7600GT is not working on Puppy due to some hardware fault? Because I am getting some strange errors with that card on Vista ( but not on XP).

Thanks again for the .pet and your support.
Back to top
View user's profile Send_private_message YIM 
Schism


Joined: 12 Dec 2008
Posts: 78

PostPosted: Sat 22 Aug 2009, 10:25    Post_subject: Nvidia drivers  

I'm running Puppy 4.2.3 (k 2.6.29.6)with a Nvidia GeForce 7000M card would love the drivers. The only thing i don't like about Puppy 4.2.3 is no 12800x800 resoulution. Upup476 worked out of the box with the resolution.
Back to top
View user's profile Send_private_message 
ice2642

Joined: 06 Sep 2009
Posts: 2

PostPosted: Sun 06 Sep 2009, 18:48    Post_subject:  

Sorry for my terrible english.

I try use this catayist pet driver and it not work with my card.

the X open, but the mouse pointer is a lot of pixels in a square format, not can se the background, the menus open, but not draw the texts and paint the backgrownd when it open.

but work if you imagine the locations of things in it and you can go out the X.

after it go out, the prompt screen show the text about use the xwin fvwm95|jwm text to correct the X using etc...

My hardware is a netbook gatewat LT31 with one ATI x1270 on a chipset M690 256mb ram. CPU AMD L110

I am using the pup beta 4.3.1 kernel 2.6.29

the ATI can not found a directory with the ATI hardware information I believe. The out screen talk about not found some ATIHARDWAREOM or some thing like this, is the same directory in the xorg script.

sorry for not much technical information, I am new with puppy.

Best regards.
Back to top
View user's profile Send_private_message 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Tue 13 Oct 2009, 18:13    Post_subject:  

Thanks for making this but I do have some problems with the installation.

I took the ATI option when launching and it appeared to finish OK. Restarting X was OK and it looks good. The resolution is now correct at 1440 x 900.

BUT: none of the utilities work. The Catalyst Control Centre, antinspect and the atigraphicscard temperature menu options all crash X without any messages.

How can I troubleshoot this? Are there any log files?

Thanks.

_________________
Nick
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 13 Oct 2009, 19:05    Post_subject:  

/var/log/Xorg.0.log

You should make a backup if X crashes, to be able to attach it here (as it gets overwritten at next start of X):
cp -ax /var/log/Xorg.0.log /root/
gzip /root/Xorg.0.log


Another file that might contain information is /tmp/xerrs.log.

The crashes that you describe indicate, that programs using OpenGL crash.
This is the case, if "fglrx.ko" was not loaded.
Type:
lsmod
to see, if the fglrx module is loaded.
If not, type:
modprobe fglrx
to see, if you get an error-message.
Maybe you just need to reboot to be able to use it.
This can be the case, if the free radeon drivers were loaded before.
Or exit X, then type:
rmmod radeon
rmmod drm
xwin


Sometimes this works.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Wed 14 Oct 2009, 15:13    Post_subject:
Sub_title: X crash
 

Thanks for the instructions.

I've attached the log file.

The command
Code:
modprobe fglrx
returns
Code:
FATAL: module fglrx not found


The radeon and drm modules are missing when the rmmod command is tried.
Xorg.0.log.gz
Description  Xorg.0.log file
gz

 Download 
Filename  Xorg.0.log.gz 
Filesize  7.54 KB 
Downloaded  825 Time(s) 

_________________
Nick
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Thu 15 Oct 2009, 18:40    Post_subject:  

Nick,
you use Puppy 4.3. It has Kernel 2.6.30.5.

But the Catalyst was compiled for Puppy 4.3-beta1, with Kernel 2.6.29.6.
This has a different Kernelmodule and cannot be used.

The beta1 is no longer available for download, and I cannot upload it in the next days, as I use a slow mobile internet connection this week.
So to get that, you had to wait until next week.

Unfortunately the Catalyst 9.3 driver does not work correctly with your newer Kernel 2.6.30.5. Ati no longer supports that driver Sad
And the newer drivers do not support your "ATI Technologies Inc Radeon Mobility X1400".

See the experimental 9.3 pet there:
http://www.murga-linux.com/puppy/viewtopic.php?t=46507



So concerning Puppy 4.3, you have 2 bad choices:
use 4.3 beta1 (has bugs) with a good working catalyst 9.3
or
use 4.3 final (less bugs) with a badly working catalyst 9.3.


Alternatives for your card:
Puppy 4.12 with catalyst 8.12:
http://www.murga-linux.com/puppy/viewtopic.php?t=38516

Ultrapup with Catalyst 9.3
Iso:
http://www.murga-linux.com/puppy/viewtopic.php?t=39154&start=75
Catalyst:
http://puppyisos.org/isos/2009-01-to-06/Newyearspup02/tests/ati-nvidia-proprietary/
(user: puppy, password: linux)


Newyearspup rc10 midi or maxi (includes catalyst 9.3):
http://www.murga-linux.com/puppy/viewtopic.php?t=37960

Finally, If you need only video accelleration, but no 3D, you can use an updated free driver for Puppy 4.3:
http://www.murga-linux.com/puppy/viewtopic.php?t=46266

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Sat 17 Oct 2009, 17:07    Post_subject:  

@MU Thanks for this reply and for the time you have given.

As the only real reason I load these drivers is to get the correct screen resolution (I don't do games or anything really taxing to the graphics sub-system) and as your .pet did fix that then I think I'll live with it not working as well as it should. It's OK for me!

I'm so glad that you understand the mysteries of which kernel works with which driver (or should that be the other way round?) and can advise us.

Thanks for all you do.

_________________
Nick
Back to top
View user's profile Send_private_message 
paokman


Joined: 23 Apr 2010
Posts: 18
Location: Athens / Geneva

PostPosted: Tue 07 Dec 2010, 07:42    Post_subject:  

Confused
I don't seem to be able to find a proper driver for my ATI X1100 for Puppy 4.3.1 and Puppy Arcade in order to run some emulators that require openGL. When I install your pet package and try to run a game the system freezes... Any advice?
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.4515s ][ Queries: 13 (0.1726s) ][ GZIP on ]