Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 19:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Navit: a car navigation system with routing engine.
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Wed 12 Aug 2009, 01:51    Post subject:  

I've edited the first post, and re-uploaded navit, gpsd & speech-dispatcher.
Back to top
View user's profile Send private message 
DavidM348

Joined: 06 Aug 2009
Posts: 3

PostPosted: Fri 14 Aug 2009, 18:24    Post subject: Muggins New Navit Compile  

Muggins,

Thanks for taking the time to do all of this! I got the pet's loaded (still needed a libray file for espeak, but found it after a google search). After a little playing with gpsd (mainly just learning how to use it and test it), launched Navit with GPS support! I am currently downloading OpenStreetMaps, US region (its kinda BIG), to use with Navit. Haven't tested speech yet, but I'll update you on how it goes.

Thanks again for all of your help!

-David
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Sat 15 Aug 2009, 04:49    Post subject:  

David,

just curious what the missing library for espeak was?
Back to top
View user's profile Send private message 
DavidM348

Joined: 06 Aug 2009
Posts: 3

PostPosted: Sat 15 Aug 2009, 21:36    Post subject: Navit  

Sorry, was my fault. I missed the portaudio .pet you had posted on the first note of this thread. The library I was missing something like libportaudio.so.2, which was in that .pet package. Every thing needed for Navit is on that first page.

My osm map of Louisiana looks good in Navit. I still haven't tried out the speech yet, but will let you know. BTW, this ND-100 really is nice. I get satelite fix inside the house (near a window). I may take on the road tonight to check it out some more.

Thanks!

-David
Back to top
View user's profile Send private message 
GeePS

Joined: 30 Jul 2009
Posts: 19

PostPosted: Fri 21 Aug 2009, 22:58    Post subject: Navit trials, part 943.2  

Muggins and DavidM348,

I was out camping with the family for a week, so took a break from the computers for a bit.. Wink Thought I would update you on what has transpired on my end.

Thanks Muggins for emailing the instructions on how to correctly back up and save folders. I had been taking advantage of the auto save and the save.sfs file layers to create backup USB sticks of my working system (the machine I am working on has no hard drive - running off a flash stick). Your instructions will make things much easier for me. I was able to use GPSD with your new compile, and was able to start it in debug. I was also able to find some instructions on how to test the gps device using gpsd, and discovered that the device I have can't be made to work. It is a newer model of the one that was on the approved list, so I am now selling it on ebay and getting the same stick the DavidM348 has.
I also have Michigan map working, and am playing with some of the other controls, but won't be able to test it on the road until I get the new GPS stick - $32 - can't believe this kind of technology sells for these prices!

Thanks again for all the assistance.
Back to top
View user's profile Send private message 
rgs

Joined: 21 Aug 2008
Posts: 38
Location: New England, USA

PostPosted: Wed 27 Oct 2010, 16:51    Post subject:  

Can someone help me to get a map installed in navit?

I installed navit using Muggin's pet package. It seems to have installed OK. Next I went to the navit wiki and downloaded an openstreet map of about 162 M. I have tried about every way I can to get the map into navit with no luck. I downloaded it to root, then copied it into usr/share/navit/maps.

I edited the navit.xml template for openstreetmaps : <mapset enabled="yes">
<map type="binfile" enabled="yes" data="/user/share/Navit/maps/osm_bbox_73.9, 40.5,-69.0,45.2.bin"/>

I guess I need clearer instructions than I find on the navit wiki.

Can someone please let me know how to get a map installed?
Back to top
View user's profile Send private message 
WindUpToy


Joined: 21 Oct 2008
Posts: 89
Location: melbourne.au Slick525DVD

PostPosted: Thu 17 Mar 2011, 18:38    Post subject:  

Hi,
Are the .pets available anywhere else, now that the original site is extinct?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Thu 17 Mar 2011, 21:09    Post subject:  

Hello WindUpToy,

I've still got the original .pet, and can upload it somewhere, but I wonder, if you're running a lupu version pup, if you could instead try the newer portable Navit:

http://sourceforge.net/projects/portable/files/Navit%200.2.0/download

and let us know if it works OK?

Last edited by muggins on Mon 21 Mar 2011, 17:09; edited 2 times in total
Back to top
View user's profile Send private message 
WindUpToy


Joined: 21 Oct 2008
Posts: 89
Location: melbourne.au Slick525DVD

PostPosted: Thu 17 Mar 2011, 21:36    Post subject:  

hmmm,

Navit must put a jinx on d/l sites:

"Sorry, there is a problem accessing this item. It may not exist."

bummer
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Fri 18 Mar 2011, 04:32    Post subject:  

Hello WindUpToy,

don't know what's happened there, as it definitely was available a few weeks back. In any case please check the first post of this thread, as I've re-uploaded them. Let us know how it goes, as I've only compiled the .pets and, having no GPS equipment, have no real ability to test.

cheers
muggins
Back to top
View user's profile Send private message 
WindUpToy


Joined: 21 Oct 2008
Posts: 89
Location: melbourne.au Slick525DVD

PostPosted: Fri 18 Mar 2011, 07:08    Post subject:  

It seem the gods dont want me to have Navit.

I got gspd, espeak, portaudio ok, but for the others all I got was html pages.
I tried numerous times and with different browsers Sad

I dont think adrive.com is much good.

Thanks anyway.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Fri 18 Mar 2011, 19:25    Post subject:  

OK, I'll try & find another site to upload them to. I did also upload to myotherdrive, but they seem to have removed the ability to lnk to the actual files! I'll get back to you, I'm just in transit at the moment.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Mon 21 Mar 2011, 17:08    Post subject:  

Hello WindUpToy,

I'll need to recompile Navit, as I've got muddled dependencies at the moment, but if you still wanted to try the portable Navit, I've altered the link above, and it appears to be working.

cheers
Back to top
View user's profile Send private message 
WindUpToy


Joined: 21 Oct 2008
Posts: 89
Location: melbourne.au Slick525DVD

PostPosted: Tue 22 Mar 2011, 04:11    Post subject:  

I should just admit defeat with this.
I got the portable, made a pet, installed it, checked the installation.. all OK.

Not running from .desktop file.

In terminal..
bash: ./navit: cannot execute binary file

Checked permissions..
root +r+w+x

???????

that's the limit of my knowledge.


BTW, I have been searching for a GPS sensor.
In Aus I have only found one, a Garmin, about $98.
Around the world there are about 50, from ~$20 to $100.
Any clues, anyone?

_________________
It's not easy being incompetent.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Tue 22 Mar 2011, 21:49    Post subject:  

Which puppyversion are you using? If you run, in a console, navit, what errors are you getting?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0625s ][ Queries: 13 (0.0066s) ][ GZIP on ]