Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Jul 2014, 09:29
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
ultratiny html viewer - PuppyBrowser 0.5 + embeddedbookmarks
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 9 [123 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
smokey01


Joined: 30 Dec 2006
Posts: 1795
Location: South Australia

PostPosted: Wed 17 Jun 2009, 17:23    Post subject:  

MU wrote:

Smokey,

the configfile for the embedded bookmarks is:
/root/.EmbeddedBookmarks/channels2.txt

The bookmarks of Puppybrowser itself are:
/root/.PuppyBrowser/bookmarks.rc

I can't promise, when I find time to enhance the normal bookmarks to support categories, too.


Mark I deleted the embedded link and all is working again.

Thanks

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
capoverde


Joined: 28 Jun 2006
Posts: 233
Location: Sanremo (Italy) with fine seaview

PostPosted: Thu 18 Jun 2009, 03:14    Post subject:  

(posted with Puppybrowser 0.5 on Puppy 4.21)

Browsed around with Puppybrowser 0.5 on Ppup476 tonight; it hung twice after playing some Youtube videos, say 5 or 6, but restarted normally after killing it.
Seem to remember this did happen with some older SeaMonkey version, can't say which; or maybe it still happens now? I rarely watch several Youtube vids, must try out.

Also: the default setting for password saving is "Yes", but IMHO "No" would be safer.

It's already my favorite browser anyway. Cool
Back to top
View user's profile Send private message 
kilon

Joined: 19 Jun 2009
Posts: 17

PostPosted: Fri 19 Jun 2009, 09:14    Post subject:  

puppy-browser does not start , it complaints that it needs "libgee.so.0"

any idea how to install this library ?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 19 Jun 2009, 09:32    Post subject:  

A libgee pet is attached to the message, where you can download the browser.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
kilon

Joined: 19 Jun 2009
Posts: 17

PostPosted: Fri 19 Jun 2009, 09:57    Post subject:  

MU wrote:
A libgee pet is attached to the message, where you can download the browser.
Mark


works like a charm. I forgot to download it , stupid me....lol

thanks
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Thu 24 Sep 2009, 06:21    Post subject:  

I just run puppy browser the default install in 430-small and It has some bugs, 2 actually. First of all I used it in order to write an e-mail at hotmail.

The e-mail I wrote was in Greek and I had problems whenever I wanted to type an accent character. To explain it exactly in order to accent a letter in Greek I have to use the button next to "L" which in english gives the semistop ";" or ":". Whenever I was pressing it the cursor was just disappearing and had to tick with the mouse in the text box every time.

Second bug I found was that Greek letter "Σ" was looking as "Z". Both of them are in the alphabet but they are different. The strange is that the small "Σ" was looking as it suppose to be "σ". Also when pasting the text to geany "Σ" was looking perfect. So the encoding was correct but the look was wrong Confused

If you want any more details or anything to test tell me.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Thu 24 Sep 2009, 07:37    Post subject:  

Mark, do you think it might be possible to get Simple Mail to work? That would then be moving toward a very lightweight browser/mail app.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 24 Sep 2009, 08:18    Post subject:  

DaveS wrote:
Mark, do you think it might be possible to get Simple Mail to work? That would then be moving toward a very lightweight browser/mail app.

Dave its a frontend like skipstone, you still need a working backend like seamonkey, and its not compatible with FF3 series or webkit yet, But hopefully in the future Smile So adding simplemail wouldn't save that much space over seamonkey mail.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10926
Location: Arizona USA

PostPosted: Thu 24 Sep 2009, 10:12    Post subject:  

I just discovered this browser in 4.3 final and watched quite a few youtube videos without any problem, unlike SeaMonkey, which closes sometimes apparently because Flash gets overloaded.

Is there any way to import bookmarks from SeaMonkey?

_________________
Puppy Help 101 - an interactive tutorial for Lupu 5.25
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 24 Sep 2009, 15:31    Post subject:  

Flash wrote:
I just discovered this browser in 4.3 final and watched quite a few youtube videos without any problem, unlike SeaMonkey, which closes sometimes apparently because Flash gets overloaded.

Is there any way to import bookmarks from SeaMonkey?


you can use this script, but might have to set the path to your seamonkey bookmarks first.

Code:
#!/bin/bash

######################################################
### convert seamonkey bookmarks for PuppyBrowser
######################################################
### enter here the path to your seamonkey bookmarks!

sb=/root/.mozilla/default/r3y1skkw.slt/bookmarks.html

#######################################################


outfile=/root/.PuppyBrowser/profiles/default/bookmarks.rc$$

touch $outfile

cat "$sb" | grep 'HREF=' |while read a;do


b=`echo $a  |sed -e "s#</A>##" -e "s#.*>##" -e "s/|/-/g"`

c=`echo $a  |sed -e "s#.*HREF=\"##" -e "s#\".*##"`

echo "$b|$c" >>$outfile

done

echo -----------------------------
echo created: $outfile
echo
echo Please rename it or add the contents to:
echo /root/.PuppyBrowser/profiles/default/bookmarks.rc


Save it as "/root/seamonkey2PB".
Then make it executable by typing:
chmod 755 /root/seamonkey2PB
Then run it by typing:
/root/seamonkey2PB

Mark

_________________
my recommended links

Last edited by MU on Thu 24 Sep 2009, 15:53; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 24 Sep 2009, 15:38    Post subject:  

DaveS wrote:
Mark, do you think it might be possible to get Simple Mail to work? That would then be moving toward a very lightweight browser/mail app.


No, PuppyBrowser is a simple pure Gtk Application.
Simple Mail is a Firefox addon using the special firefox framework (XUL I think).
It is not possible to use extensions in PuppyBrowser, that's the price for the reduced, small backend.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 24 Sep 2009, 15:50    Post subject:  

Michalis wrote:
If you want any more details or anything to test tell me.


thanks for your report!

PuppyBrowser is using a profile called "MU" from Seamonkey for the default settings.

You may test this, please:
run seamonkey.
When it starts, it should show the selection of a profile, "default" and "MU".
Choose "MU".
Then try if you can reproduce the errors there.
If yes, try to change language or font settings.
If that fixes your issue, exit and start PuppyBrowser.
Maybe it works correctly now.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10926
Location: Arizona USA

PostPosted: Thu 24 Sep 2009, 23:31    Post subject:  

Mark,

Bookmarks -> Manage Bookmarks -> Tools -> Export bookmarks creates an html file. Rather than trying to use the bookmarks in /root/.mozilla/ and so forth, it seems to me that it would be simpler to use that file. Also, I believe other browsers create the same sort of file to use for backing up and importing/exporting their bookmarks, so it would be a more general solution.
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Fri 25 Sep 2009, 05:22    Post subject:  

MU wrote:
run seamonkey.
When it starts, it should show the selection of a profile, "default" and "MU".
Choose "MU".


It doesn't ask me anything. Also I went to: tools --> Switch Profile, and has only the deafault one, no MU.

I'm using seamonkey and puppy browser which come with 430 small. I'll try to find the MU profile in the system and copy it to the profile folder of seamonkey and report back.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 25 Sep 2009, 10:07    Post subject:  

Michalis wrote:
MU wrote:
run seamonkey.
When it starts, it should show the selection of a profile, "default" and "MU".
Choose "MU".


It doesn't ask me anything. Also I went to: tools --> Switch Profile, and has only the deafault one, no MU.

I'm using seamonkey and puppy browser which come with 430 small. I'll try to find the MU profile in the system and copy it to the profile folder of seamonkey and report back.


So maybe it was left out, when Barry repackaged it for Puppy 4.3.
I must check this in detail later.
You could start seamonkey, and then create a new profile "MU".
Tools - switch profile - manage profiles - create profile.

I had used this e.g. to modify the
preferences - appearance - fonts.
There I had replaced all fonts with "Deja vu Sans", so instead of serife fonts you see sans-serif, what I prefer on a monitor.
Modifying the font settings you quickly can verify, that PuppyBrowser really is using that profile from seamonkey.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 7 of 9 [123 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0893s ][ Queries: 13 (0.0057s) ][ GZIP on ]