Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 15:46
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
I can't hear sound-Acer Laptop
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 31 Dec 2005
Posts: 3

PostPosted: Sun 01 Jan 2006, 02:04    Post_subject:  I can't hear sound-Acer Laptop  

I'm trying to get the sound to work on my:
Acer Note Light 370 PC P133 which has a ESS1688-Soundchip. I found a module on the internet: (http://www.huwig.de/linux/acer_ess1688.c) and put it in /root/ and then did "insmod /root/acer_ess1688" into the console command-prompt-type-thing which told me no such file. I tried renaming the file .o instaed of .c but it said it wasn't a valid ELF file. I saw some other sites addressing my laptop's soundcard problem but they were just too confusing to understand. Does anyone know what I'm doing wrong or if there is a easier solution? I saw some stuff about ALSA but I'm not sure how to install it or anything Embarassed If anyone has a tutorial or something I would be grateful as I've never used linux in my life so it's a little bit confusing Embarassed

Back to top
View user's profile Send_private_message 

Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Wed 04 Jan 2006, 01:57    Post_subject:  


Instructions included.
Back to top
View user's profile Send_private_message 

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Wed 04 Jan 2006, 03:15    Post_subject:  

These early ESS chipsets are fully SoundBlaster compatible, so the OSS audio driver for them is sb.o. OSS drivers are already in Puppy, so you could simply first try -
modprobe sb io=0x220 irq=5 dma=1 isapnp=0
You could also try dma=0.

Personally, I use ALSA with my ESS ES1879 chip, but if OSS works there's no need to go for ALSA.

That customised acer_ess1688.c module you tried to use was from 1998, to suit pre 2.0.31 kernels!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0437s ][ Queries: 12 (0.0031s) ][ GZIP on ]