Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Sep 2014, 00:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Trouble getting OpenOffice .sfs to work -- SOLVED
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Mon 25 May 2009, 21:29    Post_subject:  

Béèm wrote:
Glad that one worked too.
Now can you do a favor to fellow posters and edit the subject of the initial post by adding [SOLVED]


Done!
Back to top
View user's profile Send_private_message 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Sat 06 Jun 2009, 08:49    Post_subject: Trouble with OpenOffice 3.1sfs
Sub_title: CUPS disabled
 

Oops, solved - not quite.

Goxan's problem - that installing OO3.1 from the sfs file in /mnt/home trashes CUPS has not been addressed as far as I can see.

It's unfortunate, but true! OO3.1 is super-fast under Puppy 4.2, but that doesn't help much if you can't print (from OO3.1 or any other application).

As Goxan notes on another thread,

<http://www.murga-linux.com/puppy/viewtopic.php?t=23982>

removing OpenOffice-3.1.sfs from /mnt/home and rebooting allows CUPS to recover. The following solution worked for me:

1. Move the offending sfs file to a new directory. I used /root/openoffice3.1, but any directory should do.

2. Reboot.

3. Set up your network connection and start pnethood to make sure that you can access the printer.

4. In "set up CUPS printing" (click Puppy Setup icon), choose your printer (manage printers), click on it and (under maintenance) cancel all print jobs, pause the printer and "resume" it. Try printing a test page from the CUPS manager. If this is successful, you should now be able to print from other applications, assuming, of course, that they allowed printing before you installed OpenOffice-3.1. Try printing a test document from Leafpad to make sure.

5. Using ROX, open the directory where you put OpenOffice-3.1.sfs (in my case, /root/openoffice3.1). Click on the icon for the .sfs-file and ROX will unsquash it and mount if for you. In the subdirectory, /opt/openoffice.org3/program, you will find the program icons which you can click on directly or drag to the desktop.

Now, you should be able to print from OpenOffice as well.

Note that when you reboot, the desktop icons will be orphaned with the triangle and "!". The regular icons will reappear after the squash file is mounted.
Back to top
View user's profile Send_private_message 
polocanada

Joined: 21 Mar 2008
Posts: 4

PostPosted: Sun 28 Jun 2009, 11:12    Post_subject: Moved my question to a new post.  

I moved my question with problem automount and icons for Open Office to a new post. I didn't realize this is closed post. Sorry.

http://www.murga-linux.com/puppy/viewtopic.php?t=44047
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0492s ][ Queries: 12 (0.0061s) ][ GZIP on ]