Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 03:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Gimp 2.6 (updated to 2.6.3)
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 13 Jan 2009, 22:49    Post_subject:  

gymnart,
Gimp 2.6.4, but I compiled it in Ultrapup, it will not work in Puppy 4.12 I fear, because we use a newer glib there.
I made an Iso "newyearspupMU.iso" that contains it.
In addition you will need python+gdesklets_411.sfs.
Get all from here:
http://murga-linux.com/puppy/viewtopic.php?p=263003#263003

It compiled the python plugins, but I did not check them yet, if they really work.
What I can see quickly is, that there is a menu-entry:
Filters - Python-FU - Console
Can you tell me, what other filter should be available?

Script-Fu also is included.
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 14 Jan 2009, 10:22    Post_subject:  

Is the Animation filter there? How about UFraw?

For the python+gdesklets_411.sfs, would it need to be loaded at startup each time like the OpenOffice .sfs? For some reason, the version of Puppy that I run was having some trouble with that (I boot Puppy from the CD and save all my settings, etc to my usb stick.)

As for new libraries, I thought Puppy 4.1.2 had the newest.
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 14 Jan 2009, 12:21    Post_subject:  

animation filters are included.
ufRaw: I created a PET, that can be downloaded there, too.
Made from a slackware package.
Works standalone, or as Gimp-filter.
It is engaged, when you open a file like:
http://www.rawsamples.ch/raws/canon/1dm2/RAW_CANON_1DM2.CR2

Ultrapup has recompiled libraries, they are not identical with the one from Puppy.
For me here, it works Smile
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
gymnart


Joined: 10 Dec 2008
Posts: 105

PostPosted: Wed 14 Jan 2009, 19:55    Post_subject: XSane plugin?  

I tried out the Gimp from jcoder24 and it seems to work.

I have a question though: Where do you find this new Gimp's scanner plugin? Was that included? The menus are a bit changed around from the 2.2 series that I am used to. I'm accustomed to going to File > Acquire > XSane Device Dialog and then it opens the necessary windows to use my scanner.
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 14 Jan 2009, 20:04    Post_subject:  

if I remember well, my version 2.6.4 did not compile it, as I had no xsane source installed. So it might be required to compile it on your own, if you need that. Or post a request in the additional software forum.

**edit: xsane plugin is here:
http://www.murga-linux.com/puppy/viewtopic.php?t=37694

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
cklammer


Joined: 26 Apr 2008
Posts: 28
Location: Abu Dhabi, United Arab Emirates

PostPosted: Tue 27 Jan 2009, 12:48    Post_subject: Gimp 2.6 (updated to 2.6.3) install under PL4.1.2 conflict
Sub_title: Gimp 2.6 (updated to 2.6.3) installation under Puppylinux 4.1.2 conflicted with existing GIMP 2.4
 

Hallo everyone,

I downloaded the Gimp 2.6.3 from the OP and (greedily) installed it by mistake on top of the existing GIMP 2.4.x install under 4.1.2. That didn't work out at all with GIMP crashing at program invocation every time.

I ended up un-installing every "gimp-*" with the package manager and completely removing the directory /root/.gimp-2.6 manually. Then I re-installed the "gimp-2.6.*" packages.

After that the problem was fixed.

Hope that helps somebody, Rolling Eyes
cklammer
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1096
Location: Australia

PostPosted: Tue 24 Feb 2009, 18:01    Post_subject:  

Hi,

Thanks for compiling Gimp, but I can't seem to download gegl, and glib.

Thanks,
Battleshooter
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 24 Feb 2009, 18:42    Post_subject:  

battleshooter wrote:
Hi,

Thanks for compiling Gimp, but I can't seem to download gegl, and glib.

Thanks,
Battleshooter


you might have to close your browser and try again.
I also had problems, it seems to have to do with the password in the link.
After restarting the browser it worked.
I think I used Opera.
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 24 Feb 2009, 18:45    Post_subject:  

or try:
ftp://ftp.servage.net/jcoder24/

user: puppy
password: puppylinux

This might log you in "correctly".

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
battleshooter


Joined: 14 May 2008
Posts: 1096
Location: Australia

PostPosted: Tue 24 Feb 2009, 22:51    Post_subject:  

Yup. It worked. Good stuff. Thanks Mark. Smile
Back to top
View user's profile Send_private_message 
verycd8

Joined: 10 Dec 2008
Posts: 34

PostPosted: Sat 14 Mar 2009, 22:37    Post_subject:  

ok
gimp 2.6
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sat 23 May 2009, 03:41    Post_subject:  

The original link is broken... I would upload somewhere, but I only have a copy of the 2.6.2 package - does anybody have 2.6.3? Maybe we should compile the latest...
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Sat 23 May 2009, 03:46    Post_subject:  

look at ibiblio in pet packages 5 if you are willing to test woof/upup
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 23 May 2009, 07:08    Post_subject:  

mirror:
http://dotpups.de/puppy4/dotpups/Graphics/Gimp-2.6.3/

I also added 2.6.4 there, but don't know, if it also will work, as I compiled it for newyearspup.
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0686s ][ Queries: 12 (0.0041s) ][ GZIP on ]