Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 02:35
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Slaxer_Pup slackware 12.2 SMP kernel boots puppy 4.12
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [41 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sat 02 May 2009, 19:03    Post subject:  

Hello big_bass and all other interested parties.

Lately I've been using three puplets per se. Slaxer-pup, NYP and spup I built from woof-3.1alpha.

NYP is nice, but that's not what I'm here to discuss.

This suggestion might be a little too far ahead ATM, but I think it's worth a mention.

THE ultimate would be the Slaxer-pup kernel dropped into spup. I'm sure this could be done with woof, but I wouldn't have a clue! (Yet Wink ). This way we would almost have a true Slackware with the speed and versatility of Puppy. Slaxer-pup is great with hardware detection and so far for me has been very stable. OTOH spup has been super-fast and also very stable and it has the advantage of petget drawing straight from the Slackware official or the Slacky.eu repos.

Dunno if you tried woof, but it isn't hard and I'm sure the scripts could be hacked to accommodate the Slackware kernel with the necessary patches.

Just some food for thought!

Cheers, Mick

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Keef


Joined: 20 Dec 2007
Posts: 649
Location: Staffordshire

PostPosted: Sun 03 May 2009, 04:30    Post subject:
Subject description: ndiswrapper not found
 

I tried booting Slaxer on on USB stick but got the dreaded 'pup_412.sfs not found' message. No good reason for this, nothing to do with my menu.lst, just an occasional Puppy 'feature' I think.
Anyways, this was on a 1.7g Dell laptop, so I did another manual frugal install to my steam-powered 300mhz Armada 3500 (CF card in adapter).
This booted up fine of course...
Oh yes, and the point of my post is:
I use a Netgear USB dongle in both machines, that needs ndiswrapper to load the MS drivers.
The networkwizard tells me ndiswrapper cannot be found.
Running modprobe from a console gets the same 'fatal error'.
Any ideas why this should be?

[EDIT] Well the obvious reason is that it just aint there...
I copied a ndiswrapper.ko from ChoicePup and ran depmod, and the module was found. Unfortunately I have the retro version so it doesn't work Embarassed , but I've solved it in principle. I think.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 03 May 2009, 10:02    Post subject:  

Keef

I had the woes with ndiswrapper too. I think it needs to be compiled in the kernel.

As to your netgear usb dongle(s). What version are they? I have a wg111v2 that runs (with tweaks) ok with the rtl8187 module.

Cheers

Mick

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Keef


Joined: 20 Dec 2007
Posts: 649
Location: Staffordshire

PostPosted: Sun 03 May 2009, 18:15    Post subject:  

@ 01micko

Its the WG111T, which I believe has a different chipset (Atheros), and won't work out of the box on Linux as far as I can find out.
Still, there's always wires....
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 03 May 2009, 18:44    Post subject:  

Wires it is then!

I found the best USB dongle to be the TP-link el cheapo! Uses Ralink chipset and sets up and runs fast in all Puppies and puplets. TL-WN321G

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
kayan


Joined: 14 Feb 2008
Posts: 90
Location: India

PostPosted: Mon 04 May 2009, 03:30    Post subject: 3G usb modem works in Slaxer_Pup  

@big_bass

Finally i can browse internet using my 3G Wireless Data Terminal ZTE MG478/AC8700 usb modem,in puppy using your Slaxer_Pup, by just editing WvDial Config.
but in all other puplets including Deep Though 4.2 ,modem not found was the standered error reported (even after editing WvDial Config)
Thanks !!!

_________________
SAHARA laptop intel celeron M 1.4 GHz/ 768Mb Ram /40GB ,SIS 661 chipset,
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Wed 06 May 2009, 20:16    Post subject:  

Quote:
kayan
Finally i can browse internet using my 3G Wireless Data Terminal ZTE MG478/AC8700 usb modem,in puppy using your Slaxer_Pup, by just editing WvDial Config.



thanks for posting I know their are many more succsessfull

installs that aren´t posting yet

could you please post back in this thread exactly what you edited
as a code snippet

you will help many others by doing that
a big thanks in advance


Joe ...aka big_bass

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
kayan


Joined: 14 Feb 2008
Posts: 90
Location: India

PostPosted: Sun 10 May 2009, 03:59    Post subject: edited WvDial.conf  

i edited modem= from /dev/ttys0 to /dev/ttyUSB0
i removed the activation string from init2=
set carrier check to no
Baud = from 460800 to 980800
just that is it Very Happy
Following is the edited WvDial script
Quote:

[Dialer Defaults]
Modem = /dev/ttyUSB0
Baud = 980800

Init1 = ATZ
Init2 =
Carrier Check = no
Dial Command = ATX1DT
Phone = #777
Username = 4272102118
Password = 4272102118
Auto Reconnect = yes

[Dialer isp2]
Phone = MY2ISPPHONENUM
Username = MY2USERNAME
Password = MY2PASSWORD
Auto Reconnect = yes


@big_bass

I have to Give you A BIG THANK YOU Very Happy for making it possible for me to browse INTERNET using your Puplet

kayan

_________________
SAHARA laptop intel celeron M 1.4 GHz/ 768Mb Ram /40GB ,SIS 661 chipset,
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 19 May 2009, 18:01    Post subject:  

Ok, I've been playing with Slaxer_Pup... literally. Smile

I installed a new (to me) graphics card, ATi Raedon 9200, 128ddr and slaxer_pup was fine with it, even changing the res in the boot-up screen messages. Cool Funny thing, I got Slackware 12.2 and it doesn't like this card, must be the Xorg they are using.

Anyway, I found an old .pup of Tuxracer-0.6.1 and installed it. Needed a few more libs so I scrounged around for libs. Ok, didn't work so I ran PETget and found in the Puppy 4 repo Xorg-7.3.1. It has DRI and OpenGL support. I installed that and away Tux went, sliding fast as aver down that mountain!

I had some problems with the card in MU's NYP but in Slaxer it was fine ootb. It seems ok in 4.2 also. No good with BK's spup, but he is using Xorg-7.4. I'll report it too him.

Just thought this might be of interest. Wink

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 19 May 2009, 20:36    Post subject:  

Hmmmm...

No dev_x... Stock 412 dev_x doesn't work (didn't think so, but I tried anyway!). I checked your repo on .ca, no dev_x.

EDIT: After a couple of goes dev_x mounted ok.

I typed
Code:
#gcc
in a term and got "no input files". Yay, it works!
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Tue 19 May 2009, 22:19    Post subject:  

Quote:
miko
I installed a new (to me) graphics card, ATi Raedon 9200, 128ddr and slaxer_pup was fine with it, even changing the res in the boot-up screen messages. Cool Funny thing, I got Slackware 12.2 and it doesn't like this card, must be the Xorg they are using.


that's a nice surprise when the screen does that auto adjust to the smaller size in the boot up and if you add a vga=791 to the kernel option you get the little tux penguin image during boot up

my box does that too and I was wondering when someone else
got that also Very Happy

about the the devx
there is a good reason for "the moment"I am using the standard devx
this is to sort out any compile related issues while auto building packages from source with src2pkg which there is no expected errors with that the expected
is updating the devx then adding the kernel headers too

I also want to maintain package compatibility

any module compiled on your 12.2 install would work
for the moment

but the standard devx is working fine building packages


Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 19 May 2009, 22:31    Post subject:  

Yep, dev_x is all good. Cool

Compiled joewings latest build, all went well. Installed Val-ide and compiled BarryK's "hello world" gtk example. I think this is gonna be my main system for a while Razz .

Games work, everything just works, except I haven't tried printing yet, oh, and I did have that ndiswrapper issue covered in previous posts.

I've just upgraded all the P series to latest versions and installed MU's Puppy-browser (fast!) and Picture-browser. Screeny over in eyecandy forum. Next is a late model gimp, don't know whose yet, may even compile it.

TY Joe

Mick

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Tue 19 May 2009, 23:40    Post subject:  

micko
this is a special gimp its gimp"photoshop" I compiled and amigo patched the source
this is a rare one havent seen it listed anywhere else

http://puppylinux.ca/tpp/big_bass/Slackware_Packages/gimphoto-1.4.3-patched.pet

main site info
http://www.gimphoto.com/


Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Wed 20 May 2009, 00:07    Post subject:  

Got it.

Thanks. Based on 2.4.3 so it is later than the one in the puppy4 repo and I'll check out the extras.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Wed 20 May 2009, 06:26    Post subject:  

01micko wrote:
Yep, dev_x is all good. Cool

Good to hear that it works Razz

Do we have the kernel source sfs for 2.6.27.7 anywhere? I'm trying to install the Nvidia driver for my box but it complains about needing the kernel source tree Confused

Paul

_________________
Testing Puppy since v0.9.2 - my desktop OS since v1.0.7
Running SlaxerPup-4.12 - Puppy with a Slackware 12.2 heart Cool
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [41 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0847s ][ Queries: 13 (0.0064s) ][ GZIP on ]