Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 03:50
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Java - Neither dotpup installer working on 1.07
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Semi-Tec
Guest


PostPosted: Sat 31 Dec 2005, 14:37    Post_subject:  Java - Neither dotpup installer working on 1.07  

Happy New Years Eve to all

Please celebrate safely!

I was just trying to install Java in 1.07 and both dotpup installers (1.5.0_02 and 1.5.0_4) fail.

1.5.0_4 reports an md5 sum error and bails, while 1.5.0_02 just says it failed and that Java is not installed.

Is this a dotpup problem or is something different in 1.07 )?
I know I had no problem installing Java in 1.06.

Is there perhaps a setting in a script somewhere that needs to be altered for the Java dotpups to work in 1.07?

Matsoh Gratsoh for any help.

Semi-Tec
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 31 Dec 2005, 14:53    Post_subject:  

They are too old and no longer available.
Solution:
http://www.murga.org/~puppy/viewtopic.php?p=30367#30367

Or use Megapuppy:
http://dotpups.de/puppy-releases/1.0.7/ISO/KDE-OpenOffice-and-more.htm

Mark
Back to top
View user's profile Send_private_message Visit_website 
Guest
Guest


PostPosted: Sat 31 Dec 2005, 22:07    Post_subject:  

Yo MU,

Thanks for the reply and suggestions.

I was going to take the first suggestion but was a bit imtimidated to try the manual java install, and the megapuppy usr_more.sfs solution sounded easier for me, not being too linux knowledgeable.

So I downloaded usr_more.sfs from your site to the same dir as pup001, checked the md5 (it was good), and rebooted, and - got nothing at all ( I looked in /usr for the OO dir and for the jre1.50_4 dir and they're not there), ...so, as per your instruction, I moved usr_more.sfs to "/" and rebooted again... and again, nothing happened,

...so I figured ok, I've got to resize pup001; it's too small... so I added 64k to it moving it from 262 k to 326k, and then rebooted again. This time, whatever happened forced xorgwizard to run so I figured, cool, it's working, but after I got xorg reconfigured, and finished booting, again nothing showed up in /usr, ...

... so..., my semi-tec ass is kicked... I'm fresh out of ideas, and am fighting an encroaching bum-trip on New Years Eve. All I wanted to do was go on the weatherunderground site and check the java weather applet, and now, 2 hours and 221 megabytes later, I am sitting here with both my semi-tec thumbs up my semi-tec ascii, and I could sure use another pointer or two to get this Puppy working.

MU, or anybody else out there got any further suggestions?

Most marvelous New Years matsoh-gratsohs in advance to the Puppy Master who can help this poor miserable frustrated newb this cold wet New Years Eve.

-Semi-Tec
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 31 Dec 2005, 23:41    Post_subject:  

GuestToo wants to make a new installer for current java.
I am too tired, just walked 3 hours through Hamburg.

If I don't forget it, I can make one tomorrow if G2 is too busy.
Meanwhile you might try, if the "minijava" in pupget can display the applet.

concerning usr_more.sfs:
I'm without idea actually, what went wrong?
Bombayrockers reported kDE works, I think (but am not shure) he used this file.
I have it running in 107 alpha.

Mark
Back to top
View user's profile Send_private_message Visit_website 
Semi-Tec
Guest


PostPosted: Sat 31 Dec 2005, 23:50    Post_subject: ...update  

MU,

Thanks for the other suggestion ... in the meanwhiles since I last wrote, I was continuing to try different things, and I don't know what I did, but now I do have OO and jre folders in /usr...

...So, I executed the command:

ln -s /usr/local/jre1.5.0_04/bin/java /usr/bin/java

... and then restarted, and then fired up Firefox, but still Java NOWORKY! Arghhh.

So, now in this case, do you maybe have an idea why it won't work?

Thanks yet again,

-Semi-Tec
Back to top
OldNewbie
Guest


PostPosted: Sun 01 Jan 2006, 00:24    Post_subject: Thanks for the help, but...  

First, I would like to thank someone (whose name I don't remember, but it had a "ray" in it) for walking me through trying to install Java in 1.07 on a hard drive. He was the first person who really made sense while giving Linux help.

It seemed to install, but still didn't work.

I've since wiped the entire hard drive and given up on Linux for another year.

Yes, it's great that YOU'RE all command line experts. Hooray for you. But for you guys who all love tossing acronyms around, what about the ROTW? If we're ever going to ditch our Winstuff for a Linux desktop, it has to be a WORKING Linux desktop.

But don't take it personally...I haven't seen ANY distro that worked well on any two consecutive different computer installs without an over-my-head explanation of what to TRY to fix it. And then we have crap like a Mandrake that actually had a line cross the screen saying "Installing gzip support" and then when up and running it didn't know what to do with a .gz file.

Until next year, thanks to all who've tried to help - and to all those who believe that anyone who doesn't know command line Linux has no business using it, you can rest assured that your shares in Microsoft will only increase in value over time.
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 01 Jan 2006, 01:20    Post_subject:  

If you want propritary software like SUN-Java, you will tumble in such problems.
I even don't know if it is 100% legal I added it to usr_more.sfs (but SUN seems to tolerate that if I look at other projects).

The problem with GuestToos installers simply is, that SUN has deleted the download-links from their servers.
I might upload a working JRE on dotpups.de, with a consistent name like jre.tgz
Then when I replace it on my server with newer versions, the installers still would work.

Btw., why did you not have that idea a year ago? Wink

Mark
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 01 Jan 2006, 01:25    Post_subject:  

Semi-Tec,
fine.
Maybe in Firefox you must enable Java in the options?
I just use Mozilla, Dillo and Opera.

If noone else can help you, I might try to install FF myself tomorrow.
Time2go2bed...
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 01 Jan 2006, 02:38    Post_subject:  

Our good ghost was faster than me Smile
Java-dotpup:
http://www.murga.org/~puppy/viewtopic.php?t=5024

Mark
Back to top
View user's profile Send_private_message Visit_website 
Semi-Tec
Guest


PostPosted: Sun 01 Jan 2006, 14:41    Post_subject: Thanks, that worked!  

MU,

Thanks, that worked. Thanks to G2 too

Happy New Year all,

Semi-Tec
Back to top
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0595s ][ Queries: 12 (0.0049s) ][ GZIP on ]