Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 18:09
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
printing from Puppy 4.2.1
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
ravensrest


Joined: 22 Feb 2008
Posts: 321
Location: Hood Canal, WA

PostPosted: Tue 12 May 2009, 19:22    Post subject:  printing from Puppy 4.2.1  

I just upgraded to Puppy 4.2.1. and successfully installed my Lexmark E312 laser printer using CUPS. Now I can not print from some of my apps. I CAN print from Inkscape, any of the OpenOffice apps, Abiword, Seamonkey, and GIMP (if I use Print with Gutenburg).

I cannot print from Geany or Leafpad no matter what I do. And I can print from MTPaint if I set the printer to /usr/bin/lpr %f, but I get no interface -- just direct to printer (I think that is correct when using the command line?).

When I ask Geany, Leafpad, or GIMP to print, I get a screen that offers only the 'Print to file' option. With Geany, if I set the 'Use an external command for printing' to the default /usr/bin/lpr %f (that works with MTPaint), nothing at all happens. I can find no way to alter whatever Leafpad tries to do.

When I run these same apps directly from my earlier Puppy 4.2 CD, the 'Print to file' option initially shows up, but a split second later my laser printer is added as the default.

What is going on and how do I fix it.

Edit: just went back and checked all this again with a clean Puppy 4.2.1 CD => pfix=ram and got same results as with the upgrade.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8932
Location: Stratford, Ontario

PostPosted: Tue 12 May 2009, 23:16    Post subject:  

I am currently using 4.2.1RC2 and I can confirm your problem. However, I was able to print in Leafpad and Geany by going to Print Preview. This loaded the document into the PDF viewer, which then printed it.

In Geany, I was able to set the external command to /usr/bin/lpr and print successfully, provided that I had saved the document first. This is how previous versions of Geany and Leafpad handled printing.

In Geany's printing preferences, there is the statement that GTK printing is only available if Geany is compiled against GTK 2.10. But it looks like Puppy is only using GTK 2.0.

I don't understand how there could have been a change in behavior between 4.2 and 4.2.1. Did the version of Geany change between these two releases?
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 13 May 2009, 03:28    Post subject:  

rcrsn51 wrote:
I don't understand how there could have been a change in behavior between 4.2 and 4.2.1. Did the version of Geany change between these two releases?

Nope. Both 4.2 and 4.2.1 use Geany-0.16 from the same dotpet in my Unleashed tree. What did change was Gtk+ which was modified by Pizzasgood to support xinput when using a foreign language keyboard. Could that be responsible?

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8932
Location: Stratford, Ontario

PostPosted: Wed 13 May 2009, 08:43    Post subject:  

Quote:
Could that be responsible?

I don't know. But I compiled the current Leafpad 0.8.16 in a Puppy 4.1.2 environment and it detects the installed printers correctly.

[Edit] I also compiled the latest Geany in 4.1.2 and it runs correctly. So there is definitely something different about 4.2.1. I notice that 4.2.1 has a newer version of /usr/lib/libgnomeprint - 2.18.5 versus 2.18.2.
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 13 May 2009, 16:22    Post subject:  

rcrsn51 wrote:
I notice that 4.2.1 has a newer version of /usr/lib/libgnomeprint - 2.18.5 versus 2.18.2.

Ah, yes! That was upgraded as part of the CUPS-1.4.2b package fixes. I can roll that back. Please post the request in the 4.x Bugs section CUPS thread so I don't have to search for it when building the next release.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sun 17 May 2009, 02:21    Post subject:  

Weirder and weirder. I rolled back 4.2.1RC3 to libgnomeprint-2.18.2 and applied a Geany patch supplied by aragon, and I can now print from Geany but only if I do a Print Preview and choose to print from there. Printing directly from the application with no print preview doesn't show the printer in the list! Confused

OTOH, I have a build of Puppy-4.2.1 with the libgnomeprint-2.18.5 and I directly applied the Geany patch from aragon; so now I can print straight from Geany with no print preview required. Rolling Eyes

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0520s ][ Queries: 12 (0.0032s) ][ GZIP on ]