Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 07:42
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Puppy 4.2 RC4 Deep Thought - Bugs & Fixes
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 30 [449 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 28, 29, 30 Next
Author Message
capoverde


Joined: 28 Jun 2006
Posts: 233
Location: Sanremo (Italy) with fine seaview

PostPosted: Sun 22 Mar 2009, 04:11    Post subject:  

It seems that only some of the AbiWord fonts have problems, TrueType fonts from Win's directory work right (tho I haven't tried all 569 in there).
Then for a quick fix it would suffice to substitute some of the royalty-free TTFs to the buggy fonts in Abiword's set -- not elegant but effective, just an idea.
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sun 22 Mar 2009, 06:00    Post subject:  

Patriot wrote:
Hmmm ...

Finally, Joe has got wind of us !

Smile


Build 445 is out.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 22 Mar 2009, 06:02    Post subject:  

coolpup found the fix for Abiword crashing, Man well at least its fixed, I must of compiled 500MB worth of stuff trying to fix it, and Coolpup did it with a 126kb pet:)
excellent job, well thats one down and 2 maybe 3 to go.
cups
latest seamonkey
only one instance of alsaplayer when selecting a station with streamtuner.

here's coolpups fontconfig.

ttuuxxx
fontconfig-2.6.0-prescott.pet
Description 
pet

 Download 
Filename  fontconfig-2.6.0-prescott.pet 
Filesize  125.98 KB 
Downloaded  420 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 22 Mar 2009, 06:08    Post subject:  

panzerpuppy wrote:
Patriot wrote:
Hmmm ...

Finally, Joe has got wind of us !

Smile


Build 445 is out.

and here it is
jwm-445-i386.pet
Description 
pet

 Download 
Filename  jwm-445-i386.pet 
Filesize  69.24 KB 
Downloaded  454 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7831
Location: qld

PostPosted: Sun 22 Mar 2009, 06:12    Post subject:  

Quote:
Hmmmm .... Coolpup..... posts=0... input=∞


Thanks Coolpup!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 22 Mar 2009, 07:39    Post subject:  

If anyone wants to take a break and enjoy a real good youtube video, here's one.
http://www.youtube.com/watch?v=_0dYPnui3rM Very Happy
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 22 Mar 2009, 10:12    Post subject:  

hey WhoDo

Are You still Planning on having the full Seamonkey+Mail as default? If So, I've been compiling the latest full release and I'll try to finish it tonight Smile
Boy this thread is going slow tonight, thats a good sign Smile when its a bug related thread Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Sun 22 Mar 2009, 11:00    Post subject:  

ttuuxxx wrote:
If anyone wants to take a break and enjoy a real good youtube video, here's one.
http://www.youtube.com/watch?v=_0dYPnui3rM Very Happy
ttuuxxx

Hillarious!

Quote:

panzerpuppy wrote:
Quote:
Patriot wrote:
Hmmm ...

Finally, Joe has got wind of us !

Smile


Build 445 is out.

and here it is


Awesome! Looks great!

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Sun 22 Mar 2009, 13:15    Post subject:  

@jayargent: Okay, looks like I was right, my changes themselves worked, but Xorg doesn't like your setup for some reason. I have noticed that on my system, Xorg will behave wrongly with both cards active (my DRI won't work on the primary card when the secondary is enabled) and sometimes will hang, if I have the wrong combination of drivers installed. So I was beginning to doubt the wisdom in having it automatically set up the second screen, and your experience has reinforced that.

For now I think it would be best if the official Puppy didn't include my xorgwizard patch. It needs some improvements.

EDIT: Disregard the following request, see my next post in this thread.
@WhoDo: You should use the copy of /usr/sbin/xorgwizard that was posted earlier in this thread (but possibly not the .mo files, due to the bug I noticed. I'm assuming those are older copies than the ones already in RC4).
END OF DISREGARDED STUFF



Meanwhile: jayargent, your monitor is plugged into the Nvidia card, right? Try booting 4.2.1 and running xorgwizard. When it finishes, run this command:
mp /etc/X11/xorg.conf
Use the arrow keys to scroll down to the part that looks like this:
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Place a # in front of the line for Screen1, like so:
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   #Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Now press [Ctl]-[s] to save, and [Ctl]-[q] to quit. Now run startx and see if X will start. If not, attach the new copy of the Xorg.0.log file.

If it does work, try it in RC4 also, to verify that this still works even if my patch has been applied. (My plan is to further patch xorgwizard to disable the second screen entry in the server section by default, but still add the missing screen section, so that it only takes the removal of one # sign to enable the second screen by hand.)

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib


Last edited by Pizzasgood on Sun 22 Mar 2009, 23:59; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
XiaolinDraconis


Joined: 24 Feb 2009
Posts: 19

PostPosted: Sun 22 Mar 2009, 13:42    Post subject:  

so no final yet eh? well i like it so far... i have samba shares now that i couldnt do in 412 and i believe cups works for me but im not sure how to use cups yet so ill get to work on reading about that next and then ill get xorg dri and my nvidia driver and give that a go... anything else i can test?
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7831
Location: qld

PostPosted: Sun 22 Mar 2009, 16:51    Post subject:  

buen día todos

Well, been testing Joe´s latest JWM and so far so good! Patriot seems happy but still considers it beta. Would love Pizzasgood or Dougal´s opinion... ziggy is absent as seems Hairy. MU?

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 22 Mar 2009, 17:00    Post subject:  

JWM enhancement giving no problems on my RC4
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 22 Mar 2009, 17:18    Post subject: Support for 3+ sfs files at boot in 4.2  

Will this solution be applied standard in a future release of 4.2?
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Tui

Joined: 27 Sep 2006
Posts: 380
Location: Wellington New Zealand

PostPosted: Sun 22 Mar 2009, 18:23    Post subject: Over shading on desktop backgrounds !  

I have included a screenshot of what I am on about, is this fixed
for final release?
What script do I need to change now to fix this problem?

Thanks Tui
bugpix2.png
Description 
png

 Download 
Filename  bugpix2.png 
Filesize  100.82 KB 
Downloaded  479 Time(s) 
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7831
Location: qld

PostPosted: Sun 22 Mar 2009, 18:32    Post subject: Re: Over shading on desktop backgrounds !  

Tui wrote:
I have included a screenshot of what I am on about, is this fixed
for final release?
What script do I need to change now to fix this problem?

Thanks Tui


Hello Tui Smile

Don´t you like a movable clock? Well you can turn this feature off easily.

Go to /root/.xonclockrc (hidden file) and find the line ¨movable = true¨ and change to ¨movable = false¨. That will do what you want (if I understand your diagram correctly Cool )

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 17 of 30 [449 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 28, 29, 30 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0947s ][ Queries: 13 (0.0099s) ][ GZIP on ]