Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 20:22
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon Multifunction PIXMA MP610 (Solved!)
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [17 Posts]   Goto page: Previous 1, 2
Author Message
gerry

Joined: 26 Jul 2007
Posts: 946
Location: England

PostPosted: Mon 13 Oct 2008, 16:58    Post subject:  

Given what you've done already, I don't expect Ted to work either.

You've got a very deep problem, which baffles me. Usually I have trouble with postscript files, ie those produced by Open Office, Abiword, and so on. However, Firefox prints a raster image, and so I think does the Cups test page. These work much more often- they use different software than postscript files do.

Gerry
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1012
Location: Australia

PostPosted: Fri 06 Feb 2009, 02:19    Post subject:  

Wooohooooo!!!! Yes!!!! Finally got the printer going without TurboPrint Very Happy No more printing in Windows!!! Need a bigger grin here Very Happy

Even though I haven't been posting I've been working on trying to get this printer going for the longest time browsing around and testing, and eventually I got it down to the printer saying it would print and nothing happened. Then I tried Wow's puplet (Exton) which is based on 4.11 and for some reason it printed! Yes! I did want it to work in Pup 3 but at least it's now going in something other than Windows and preferentially in a Puppy derivative.

I'm afraid I never figured completely what the problem was but this is basically what I did for those who are following up this trail:

1.Unrpm Cannon's official packages to / in this order:
cnijfilter-common-2.80-1.i386.rpm
cnijfilter-mp610series-2.80-1.i386.rpm
They can be found here.

2.Fix the missing symlinks by copying and pasting the following:
Code:
ln -s /usr/lib/libcnbpcmcm327.so.6.61.1 /usr/lib/libcnbpcmcm327.so
ln -s /usr/lib/libcnbpcnclapi327.so.3.3.0 /usr/lib/libcnbpcnclapi327.so
ln -s /usr/lib/libcnbpcnclui327.so.3.3.0 /usr/lib/libcnbpcnclui327.so
ln -s /usr/lib/libcnbpess327.so.3.0.9 /usr/lib/libcnbpess327.so
ln -s /usr/lib/libcnbpo327.so.1.0.3 /usr/lib/libcnbpo327.so
ln -s /usr/lib/libcnbpcnclbjcmd327.so.3.3.0 /usr/lib/libcnbpcnclbjcmd327.so


3.Then install the printer normally through Cups just taking care to select "USB printer #1 with status readback for canon ij (Canon MP610 series)" when asked what device and you should have one working printer. Yes!!!

Thanks Muggins for all your help!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [17 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0436s ][ Queries: 12 (0.0044s) ][ GZIP on ]