Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 00:05
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
SOLVED: Any way NOT to load Puppy in RAM at boot ??
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [23 Posts]   Goto page: Previous 1, 2
Author Message
GeexBoxer

Joined: 22 Nov 2007
Posts: 17

PostPosted: Tue 20 Jan 2009, 01:16    Post subject:  

Pizzasgood wrote:
The kernel line, and it's 'pfix=noram', at least in 4.1.2. So in your case, it would look like this:
Code:
title Puppy Linux 4.1.2
kernel (hd0,0)/puppy412/vmlinuz PMEDIA=idehd PDEV1=sda1 psubdir=puppy412 pfix=noram
initrd (hd0,0)/puppy412/initrd.gz
boot


puppy is still being copied to ram even after I added the command. so is there any other way to prevent puppy from being copied to ram?

if initrd.gz has to be edited how can it be done for puppy linux for 4.1.2?
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 20 Jan 2009, 01:31    Post subject:  

Not sure if it makes a difference; but pfix=noram should be
at the end of the kernel line.
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Tue 20 Jan 2009, 03:03    Post subject:  

It looks like if Puppy realizes you use an internal harddrive and that you have more than 280MB of ram, then it decides to ignore your wishes and copy into ram anyways.

If you really don't want it to, you could edit the initrd.gz file to adjust it.

To do that, you need to make an empty directory somewhere out of the way. I like to use /tmp/NewDir. Copy the initrd.gz file into that. Open a terminal inside that directory by either pressing the backquote key (up at the top left, just below the Esc key), or by right-clicking and going to "Window->Terminal here".

In that terminal, run these commands:
Code:
mkdir initrd-tree
cd initrd-tree
zcat ../initrd.gz | cpio -d -i

That will create a directory named 'initrd-tree', and if you go inside it you'll see all the files that were in the initrd.gz file. We're interested in the one named "init". Open that with a text editor. Press <CTRL><F> to bring up the "Find" box. Type "definitely worth" and press enter. That should bring you to the lines of code responsible. Change this:
Code:
 #v405 fast media plus more than 256MB ram then definitely worth copying to ram...
 [ "`echo -n "$FASTPARTS0" | grep "$PUPSFSDEV"`" != "" ] && [ $RAMSIZE -gt 280000 ] && COPY2RAM="yes"
to this:
Code:
 #v405 fast media plus more than 256MB ram then definitely worth copying to ram, unless the user doesn't want to.
 [ "`echo -n "$FASTPARTS0" | grep "$PUPSFSDEV"`" != "" ] && [ $RAMSIZE -gt 280000 ] && [ "$PNORAM" != "yes" ] && COPY2RAM="yes"

Now save the file. Open a terminal inside the initrd-tree directory, where the init file is. Run these commands:
Code:
rm ../initrd.gz
find . | cpio -o -H newc | gzip -9 > ../initrd.gz

That will remove the copy of the initrd.gz file you made earlier and replace it with a new one including the changes you just made. Go back to the directory where you placed the initrd.gz file and copy that one over the original one that Puppy uses (you might want to back up the original first). Now reboot, and the pfix=noram option should work. I haven't tested this myself though, so there might be another line causing problems too. So let me know if it doesn't work and I'll look deeper.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 20 Jan 2009, 03:18    Post subject:  

Uh

He added Solved to his post after correcting the kernel linejavascript:emoticon('Laughing')
Back to top
View user's profile Send private message 
GeexBoxer

Joined: 22 Nov 2007
Posts: 17

PostPosted: Tue 20 Jan 2009, 23:24    Post subject:  

rjbrewer wrote:
Uh

He added Solved to his post after correcting the kernel linejavascript:emoticon('Laughing')


what? dude I didn't added solved to the post. This is not even my post, my question was related to this post so I asked it here. too much posting posts. Mr. Green
Back to top
View user's profile Send private message 
GeexBoxer

Joined: 22 Nov 2007
Posts: 17

PostPosted: Wed 21 Jan 2009, 13:14    Post subject:  

Pizzasgood wrote:
It looks like if Puppy realizes you use an internal harddrive and that you have more than 280MB of ram, then it decides to ignore your wishes and copy into ram anyways.

If you really don't want it to, you could edit the initrd.gz file to adjust it.
I haven't tested this myself though, so there might be another line causing problems too. So let me know if it doesn't work and I'll look deeper.

First of all, thank you for writing very detailed instructions. I did what you told me to but puppy still copies to ram. btw I didn't create a pup_save file yet. could that be a problem? or maybe I should add pfix=noramsfs?
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Wed 21 Jan 2009, 23:16    Post subject:  

Yeah, I think that the lack of a pup_save.2fs file might be the problem. I'm saying that from foggy memory, without looking at the code. There are a number of exemptions scattered around, and one of them had to do with the first boot.

I'll look into it tomorrow evening and try to get it working on my end.

It definitely isn't pfix=noramsfs. I just checked (using grep) and the string 'noramsfs' doesn't occur at all in the init script.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
GeexBoxer

Joined: 22 Nov 2007
Posts: 17

PostPosted: Thu 22 Jan 2009, 17:49    Post subject:  

You are right Pizzasgood. It was the lack of pup_save file and now it is working. Thank you for your help, I appreciate it.

So the rough procedure was
1) edit initrd.gz file
2) adding "pfix=noram" to menu.1st file at the end of the kernel
3) make sure pup_save file exists.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [23 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0756s ][ Queries: 13 (0.0150s) ][ GZIP on ]