Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 13:02
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
wireless / wifi cards confirmed to work in puppy - OLD LIST
Post_new_topic   Topic_locked View_previous_topic :: View_next_topic
Page 11 of 13 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13 Next
Author Message

Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Thu 09 Oct 2008, 12:24    Post_subject:  

I have been having an 'interesting' time getting my Broadcom BCM9 43xxx chipset to work in Pup. Firstly, Pup (4.1) recognizes the chipset correctly. Brilliant. For me that is the first time I have used a 'free' linux distro that can do this. Having had so much trouble with this chipset in the past (ndiswrapper etc), I figured I would need to configure the connection myself. WRONG! Trying to do so led to all manner of problems, and no connection. Here is how I found works best: after boot, just WAIT until the network connected icon appears in the systray. This takes about a minuite. Dont be fooled. Pup has recognised the interface and loaded it, but you still wont have a connection. SO, from the menu, or a desktop icon if you set one up, run Pwireless Network Scanner. This should pick up and list your network. Highlight the one you want to connect to if more than one is listed and hit the 'connect' button. Pup will then acquire a network address from you router and log you in. Done!
I wish I could get those last stages to happen automatically, but nothing I try makes it happen. Still, no biggie, and brilliant for recognising and supporting this known to be difficult chipset. Great great Distro Smile
Back to top
View user's profile Send_private_message 

Joined: 24 Jun 2006
Posts: 36

PostPosted: Sun 12 Oct 2008, 19:11    Post_subject:  

Thank you for this list of working WIFI cards! I picked up a Netgear WG311v3 PCI card today and it works like a charm with the windows driver wrapper under TeenPup 2008.

Now this PC can go back to my bedroom at the other end of the house without having to run almost 100 feet of cable.
Back to top
View user's profile Send_private_message 

Joined: 14 Oct 2008
Posts: 7

PostPosted: Thu 16 Oct 2008, 05:38    Post_subject:  

Netgear WG111v2 USB stick works flawlessy in Puppy 4.1 without any manual work. It contains the RTL8187 chipset, which seems to be natively supported by the kernel.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 28 May 2008
Posts: 122
Location: MIAMI

PostPosted: Thu 16 Oct 2008, 16:58    Post_subject: TRENDNET USB Dongle TEW-424UB H/W:3.OR now works in Dingo
Sub_title: Recent online driver extracted form presents .inf file that works in ndswrapper.

See my post here:

Get Trendnet driver here:
Back to top
View user's profile Send_private_message 

Joined: 07 Oct 2008
Posts: 44

PostPosted: Sat 25 Oct 2008, 19:29    Post_subject: ASUS WL-100G PCMCIA b/g
Sub_title: Great card for older laptops

Asus WL_100G PCMCIA wireless card.

This card works GREAT with an old HP Omnibook 800ct, with a fast Pentium 166 MMX processor and 80mb of ram! I'm using it now. Does WAP, WEP, etc. Puppy 4.1 regular and retro picked it up in the wizard instantly. Uses the "b43" driver. A lot of other cards put too much load on the CPU. I'd tried a Netgear WG511T that worked great on another laptop with Puppy that had a 650 mHz processor. But while recognized on the Omnibook, would never hook up. This ASUS card isn't bleeding edge, but has wireless g and the security I wanted. Found it on Amazon for less than $20.

Back to top
View user's profile Send_private_message 

Joined: 10 Nov 2008
Posts: 8

PostPosted: Tue 11 Nov 2008, 02:19    Post_subject:  

Airlink AWLH6070 150n pci card works out of the box with 4.1, but with no support for encryption
Back to top
View user's profile Send_private_message 

Joined: 11 Nov 2008
Posts: 1

PostPosted: Tue 11 Nov 2008, 11:25    Post_subject:  

experimented with puppylinux 4.1

a Packard Bell Imedia 4050 machine with a intern DLink DWL-G150 only worked with WEP

a tiny experiment with the same machine provided with a dlink dongle dwl-g132 did not seem to work
Back to top
View user's profile Send_private_message 

Joined: 05 Aug 2008
Posts: 75

PostPosted: Tue 11 Nov 2008, 11:55    Post_subject: Puppy 4.1 and 4.1.1
Sub_title: Laptop/Netbook and USB Wireless that works well

I have also experimented with Puppy 4.1 and 4.1.1 wireless WPA2 TKIP. The ones that worked consistently well, including auto re-connect on boot, installed with Puppy's wizard and ndiswrapper or mod as indicated include:

1) Acer 3003 Laptop, internal wifi, wizard
2) Hewlett Packard DV6833us laptop, internal wifi, wizard
3) ASUS Eee PC 1000HA netbook, internal wifi, madwifi for Eee
4) ZyXEL AG225H, USB dongle with built in sniffer and more, wizard
5) Airlink AWLL3028 USB dongle (Fry's sale item at $ 8 ), ndiswrapper
6) Airlink AWLL3055 USB dongle with 10dB gain antenna, (Fry's sale item at $15), wizard
7) Airlink AWLL6070 USB dongle, (Fry's sale item at $15), ndiswrapper
8 ) Linksys WUSB100, ndiswrapper

I know there are many many more that also work, but several of the USB dongle units that I tried above are among the lowest cost USB wireless adapters I have found at various local sales. Hope this information is helpful to others.
Back to top
View user's profile Send_private_message 

Joined: 14 Apr 2008
Posts: 174

PostPosted: Mon 17 Nov 2008, 14:56    Post_subject: Confirm work Belkin
Sub_title: Belkin G+ i working in puppy 4.1.4

I'm happy to see that this usb wirless Belkin G+ was already recognized ..
was easy to configurean -ip etc. in linux puppy. Amazing!
I yous istall 4.1.1 fro a version of tux (dowlod the iso called nov08 )

It is amazing no to search for drivers. Tanks linux comunity, thank barry & tux and all the puppy friends.

Installing hardware, operating system is not easy anyway, at least puppy always give me dissatisfaction.

Yust let you know that for use the same device bekin c+ in winXP, with the original diskette , take me few hours. with puppy did work in a flash!
Back to top
View user's profile Send_private_message 

Joined: 08 Dec 2008
Posts: 73

PostPosted: Thu 18 Dec 2008, 23:44    Post_subject:  

under Puppy 4.1.2

Gigafast WF-748 usb - puppy autodetects the driver, so no need to manually load. (uses the zd1211rw driver) Works unencrypted. WEP and WPA both work perfectly. this unit is discontinued and no longer in production. Disk that came with it had Linux drivers as well.

Retail Plus usb wireless- same chipset as above. works just like the gigafast. Got mine for under $25. Comes with a disk including Linux drivers...

Zonet -ZEW2502 usb- must use ndiswrapper (I was successful with the windows xp driver). Works unencrypted. Tried WPA but didn't work. WEP was untried.
Back to top
View user's profile Send_private_message 

Joined: 25 Nov 2005
Posts: 2183
Location: Lincolnshire, England

PostPosted: Wed 31 Dec 2008, 07:43    Post_subject: Edimax  

Ive tried several edimax wifi adaptors, they work with the R73 usb driver under puppy 2.15ce (needs to be loaded first). Puppy 4.12 picks them up straight away. I havnt tested them with other versions of puppy, but I do know that WEP works with them (havnt tried WPA)

the EDIMAX EW-7318USg comes with an external antanea that is detachable and gives superior range (weve used it commercially for some time now to get round some tight spots). I understand you can also connect different antennas to get better range or "focus the beam" in certain areas. I believe pringles cans are useful? As is chinese cookware.

In britain you can get one for about ten pounds

Puppy Linux's Mission

Sorry, my server is down atm!
Back to top
View user's profile Send_private_message Visit_website MSNM 

Joined: 03 Feb 2008
Posts: 47

PostPosted: Fri 09 Jan 2009, 16:49    Post_subject: Wi-Fi connection in WOOF  

For the first time my wi-fi (RTL8187B) was recognized. After loading it said I was online. Saddly, this wasn't the case. I have always used NDISWRAPPER befor with success, but the drivers provided will not work for the "b" version. Tried blacklisting but to no avail, apparently reloads the linux driver again. Any ideas or can I go back to a different version of the networking wizard as I am command line challanged. Thanks....
Back to top
View user's profile Send_private_message 

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Fri 09 Jan 2009, 18:25    Post_subject: Re: Wi-Fi connection in WOOF  

straypup wrote:
the drivers provided will not work for the "b" version.

Try the proprietary "r8187" driver from here
Back to top
View user's profile Send_private_message 

Joined: 29 Nov 2005
Posts: 103
Location: Pelham, AL

PostPosted: Thu 15 Jan 2009, 19:16    Post_subject: $11.99 at meritline  


REALTEK 8187 Chipset, works with Puppy 4.1.1 on my notebook.

They run coupons periodically where you can buy this for $10 shipped in the US...
Back to top
View user's profile Send_private_message Visit_website 

Joined: 15 May 2005
Posts: 112
Location: Sydney, Australia

PostPosted: Thu 15 Jan 2009, 21:44    Post_subject: Works with Netcomm NP544
Sub_title: Wireless connection

I have discovered that the Netcomm NP544 USB dongle has Ralink chipset RT2501USB.
This can be found at www.atlantis-land.com (which is in Italian, but the specs are in English).
The specs also show as:
RT2501USB (RT2508+RT2571W)

I got wireless to work with Pup4.11.
However, I had to by-pass Ndiswrapper in the wizard, and instead, downloaded a NetcommXP set for NP544, which contains SiS163u.INF, and executed the following lines (case is significant):
ndiswrapper -i SiS163u.INF
ndiswrapper -l
modprobe ndiswrapper
Seems to work.
If I have any problems I'll post again.

"It is forbidden to kill; therefore all murderers are punished unless they kill in large numbers and to the sound of trumpets." - Voltaire
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 11 of 13 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13 Next
Post_new_topic   Topic_locked View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0886s ][ Queries: 13 (0.0087s) ][ GZIP on ]