Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 00:01
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
SOLVED: Wireless Works on CD, but not in Frugal Install
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
vtpup


Joined: 15 Oct 2008
Posts: 1134
Location: Republic of Vermont

PostPosted: Sun 28 Dec 2008, 13:23    Post subject:  SOLVED: Wireless Works on CD, but not in Frugal Install  

I have a frugal install of 4.1.2 retro that is acting strangely.

I can set up two different wireless cardbus cards if I boot off of the 4.1.2 retro CD. Both will work with WPA encryption on my wireless router.

The cards and modules are:
D-Link DWL-G650 rev. B using athpci module
and
Edimax EW-7108PCG using rt61 module for Ralink 2561 chip

However, neither will work from my frugal install.

The Edimax card will get recognized and successfully scans the access point, but can't negotiate WPA prpoerly.

The D-link card now causes extreme problems -- Network Connect Wizard won't open, and on attempted shutdown the computer hangs and I have to remove power to shut down (as well as remove the battery) on this T30 Thinkpad.

I have tried to pfix=fsck and pfix=clean, but nothing has cured these wireless problems with the frugal install.

Oddly, the D-Link card WAS working last week with the install. I don't know what has changed. The other card never did grt past the WPA associating stage.

Any suggestions for troubleshooting would be appreciated.

Obviously both cards CAN work, since they do while running from the CD in pfix=ram.

Thanks!

Last edited by vtpup on Sun 28 Dec 2008, 17:18; edited 1 time in total
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1134
Location: Republic of Vermont

PostPosted: Sun 28 Dec 2008, 17:15    Post subject:  

Things got worse and worse:

I tried copying the pup_412.sfs file from the CD to the frugal HD install.

That didn't help.

I tried pfix=purge

That didn't help. It did knock out all of my old settings -- which I did know it would. I'd gone that route once before. It takes qite a while to restore them -- particularly email accounts and getting back your old messages.

Still no wireless. It was incredibly frustrating to be able to boot up in pfix=ram and use either network card, yet by now, neither worked in my frugal install -- even though it had supposedly been "purged, cleaned fscked" and poked in the butt with a cattle prod set to STUN.

I couldn't even get the connection wizard to open up.

I was wondering if I should just dunk the laptop in a bucket of cold water. Or torrent ripoff a copy of Windows XP for reliability sake. Well, no....I'd rather go back to paper and pencil, than that.

I guess I knew that if you stick with it and push every button, sooner or later something will fall out. Maybe a little moth -- which according to computer mythology, was the first "bug".

My laptop by now wouldn't even shut down from 4.1.2 with a network card in place (cardbus). It would hang after "Puppy is shutting down..." And I couldn't even close it with the power button. I had to pull the plug AND pull the battery. Without a card in place, I could shut down, however. So obviously it was the interraction of the software with the cards that was the problem.

I decided to see if I could blacklist the RT61pci module for some reason, I can't remember why, so I went to bootmanager and did it.

I then, for perversity sake, plugged the card that needed that driver in, and booted up. Naturally it wasn't recognized. But I was able to open the network wizard. It didn't show up there, but I was able to choose rt61pci as a module to add, and I was then able to proceed all the way through the wizard, and eventually connect!!!!!! Very Happy

Gingerly, I sneaked into bootmanager and removed the blacklist for rt61pci.

Quietly I opened the menu, eased past shutdown, and clicked reboot, with fingers crossed. . .this last was difficult physically.

The computer rebooted. I clicked on the Browse icon. Seamonkey opened up and I navigated here to this very post and started typing.

And here we are.


So the moral(s) of this story is:
1.) You CAN NOT solve wireless module problems with pfix=clean or purge.
2.) You should try to connect any troublesome wireless card with pfix=ram because it is possible it can work there even if it won't in a HD installation, -- even a frugal one
3.) If it works in pfix=ram, then blacklist the appropriate module, reboot, and walk through the network connection wizard again. If you get a connection this way, then also remove your module from the blacklist, and you should be good to go.
4.) Misbehaving wireless modules can screw up your shutdown process.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0476s ][ Queries: 12 (0.0041s) ][ GZIP on ]