Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 11:40
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Unnamed pupplet (puppy411 kernel-2.6.27.5 Xorg-7.4 LXDE)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 17 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 14 Dec 2008, 17:17    Post_subject:  

wow has uploaded two more sfs, mesa 7.2 and xinput apps.
He will anounce it on his own, mwith more info I think, I just want to let you know, that the files are already there.
So if you have a graficscard that has no 3D accelleration in the main iso itself, try the mesa sfs.
http://puppyisos.org/isos/2008-07-to-12/Puppy-4-K2.6.27.5/iso-01/
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
magerlab

Joined: 08 Jul 2007
Posts: 731

PostPosted: Mon 15 Dec 2008, 02:18    Post_subject:  

i have problems with keyboard keys recognition
first, arrows do not work at all
and when i add ru keyboard layout it stays only until the next X restart and i have to run keyboard wizard again
also the boot time is a bit slow due to kernel event manager
whatis it for? and is it possible to skip it or load it after x loaded?

_________________
skype: desafimager
Back to top
View user's profile Send_private_message 
eightbitz


Joined: 06 Dec 2008
Posts: 19
Location: Where Hell froze over AKA- Michigan

PostPosted: Mon 15 Dec 2008, 09:48    Post_subject: Wireless?  

Any news on adding the wireless drivers?
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Mon 15 Dec 2008, 18:26    Post_subject:  

More SFS's (you can found the package list and configure options in <sfs file> /usr/doc/<sfs filename>.txt)
    SOLVED: [read more] reported by MU and confirmed by me:xorgwizard resulted in a black screen when I chose "xorg" So, don't load these SFS files with Bootmanager, please only copy the files you need from them (double click on a .sfs file browse and copy drivers to the filesystem) I'll convert these sfs to .pet soon to avoid this problem.

framebuffer-drivers-k2.6.27.5-i686.pet
Description  Support for framebuffer devices, install this if you want 3D acceleration with the open source DRI drivers.
pet

 Download 
Filename  framebuffer-drivers-k2.6.27.5-i686.pet 
Filesize  374.99 KB 
Downloaded  469 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Mon 15 Dec 2008, 19:07    Post_subject:  

magerlab wrote:
surprisingly pcmanfm can mount drives and correctly shows russian file names on vfat

ROX-Filer should have no problems with filenames in vfat too Smile

zygo wrote:
It's not just a matter of compiling Xorg 7.4 is it?

Installing a new intel driver on Puppy-4.xx could fix it. Sometimes those xorg video modules requires to update even more libs.

@magerlab: About the boot time... I added 3 service scripts (for: hal 0.5.11, dbus-1.2.3 and udev-1.30) to the rc.sysinit file, I compiled Xorg with HAL enabled for xinput hotplug (try to add/remove/swap keyboard, mouse, or any other input device while X is running and it will be autodetected and autoconfigured) PCmanfm uses hal and udev(kernel event manager) to mount and unmount devices.
You said that arrow keys doesn't work at all? it happens any time or only with certain apps? Please tell me more.

@eightbitz : I'm downloading ndiswrapper-1.53 right now and will try to make a pet later.
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Mon 15 Dec 2008, 19:13    Post_subject:  

For the people asking for desktop icons, copy and paste these commands in a terminal window.
Code:
mkdir ~/Desktop
cp /usr/share/applications/Wizard-Wizard.desktop ~/Desktop
cp /usr/share/applications/Resize-personal-storage-file.desktop ~/Desktop
cp /usr/share/applications/Puppy-universal-installer.desktop ~/Desktop
cp /usr/share/applications/petget.desktop ~/Desktop
cp /usr/share/applications/pprocess.desktop ~/Desktop
cp /usr/share/applications/obconf.desktop ~/Desktop
cp /usr/share/applications/Network-Wizard.desktop ~/Desktop
cp /usr/share/applications/lxrandr.desktop ~/Desktop
cp /usr/share/applications/lxsession-edit.desktop ~/Desktop
cp /usr/share/applications/Chooselocale-country-localisation.desktop ~/Desktop
cp /usr/share/applications/BootManager-configure-bootup.desktop ~/Desktop
cp /usr/share/applications/lxappearance.desktop ~/Desktop


Back to top
View user's profile Send_private_message 
iscraigh

Joined: 03 Sep 2006
Posts: 276

PostPosted: Mon 15 Dec 2008, 23:22    Post_subject:  

How can I stop lxpanel running and use fbpanel (it has auto hide). I have installed fbpanel and can killall lxpanel and run fbpanel but I would like to have fbpanel startup automatically.

Thanks

Craig
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 Dec 2008, 03:14    Post_subject:  

Craig,
the desktop is run in /usr/bin/startlxde.
You could edit it, e.g. replace lxsession with fbpanel.

---------------------------------
I had more time to check the iso out.
Installed the new xorg/mesa sfs.

Edited xorg.conf from "vesa" to "ati".
Now my desktop started with 1680x1050 pixel, and 3D is accellerated.
Unfortuntely Xorg 7.4 did not solve the crashes of my Radeon 9250 with DRI enabled, I think it is a hardware-defect/conflict.
Oh, and with this resolution, shadows are very slow again, so I had to "killall xcompmgr" to stop them.

Then I replaced again the Radeon with my Nvidia geforce2.
Edited xorg.conf to "nv".
Now I have stable and fast X, but no 3D, the nv driver supports no 3D accelleration.

Note: in both cases, xorgwizard resulted in a black screen when I chose "xorg".
I have not checked yet, if this is due to the mesa/xorg sfs, or to the devx sfs I also activated (that from Puppy 411).
So I edited xorg.conf by hand with mp.

I then tried to compile NVIDIA-Linux-x86-71.86.06-pkg1.run with this patch for 2.6.27:
http://www.nvnews.net/vbulletin/showthread.php?t=120971
nvidia-71.86.06-2.6.27.patch.txt (11.1 KB)

I extracted from Kernel.org linux-2.6.27.5.tar.bz2.
For a first test, without Puppy patches.
But got this error:
Quote:
# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.27.5/kernel/drivers/video/nvidia.ko): Invalid module format
#


I then applied the patches described by wow here:
http://www.murga-linux.com/puppy/viewtopic.php?t=34341

But I still get the same error.
So it seems, there has something that changed with the Kernel, an different patch?
Tomorrow I'll continue to compile the whole Kernel.

I created an archive with the patches I used.
It includes a very detailed instruction, how I patched the Kernel.

We should continue the Kernel-related stuff in that thread, there you also can download the patches:
http://www.murga-linux.com/puppy/viewtopic.php?p=258097#258097

----------------------------
oh yes, with Opera and Muppy-Filer/Quickmount I really enjoy this puplet Smile
Time to build some own SFS files soon.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 Dec 2008, 05:08    Post_subject:  

I think I sorted out how to compile a nvidia kernelmodule without running the installer.

Instructions:
download:
http://dotpups.de/diverse-tgz/nvidia-kernelmodule-71.86.06.tgz

Extract it in /root/
Backup your own nvidia-module, /lib/modules/2.6.27.5/kernel/drivers/video/nvidia.ko.

Then type:
cd /root/nvidia-kernelmodule-71.86.06/nv
./MU-compile


Then please zip and attach the resulting
/lib/modules/2.6.27.5/kernel/drivers/video/nvidia.ko

Then restore your backupped module.

If that works, we could easily compile new nvidia kernelmodules for the existing pets.
Thanks, Mark

_________________
my recommended links

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 Dec 2008, 06:45    Post_subject:  

Also added:
http://dotpups.de/diverse-tgz/nvidia-kernelmodule-100.14.19.tgz
patched for 2.6.27, see:
http://www.nvnews.net/vbulletin/showthread.php?p=1819350
nvidia-drivers-100.14.19-kernel-2.6.25+26+27-compat.txt (54.4 KB)

http://dotpups.de/diverse-tgz/nvidia-kernelmodule-177.82.tgz
This compiles without a patch.

The matching Nvidia pets can be found here:
http://www.murga-linux.com/puppy/viewtopic.php?t=34001
So we just need to compile the modules now with a working kernelsource.

And I made a small pet that adds freememapplet-tray to /root/Startup.
So you can see the free diskspace in the panel.
I attach it.

Mark
Freememapplet-tray.pet
Description 
pet

 Download 
Filename  Freememapplet-tray.pet 
Filesize  8.49 KB 
Downloaded  443 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 Dec 2008, 08:51    Post_subject:  

ok got it.
I had to compile the full kernel.
It seems, I needed /usr/src/linux-2.6.27.5/Module.symvers
This was created then.
Now nvidia.ko loads after I recompiled it Very Happy

I did not run X with it yet, need some sleep first.
But you can download it here:
http://dotpups.de/diverse-tgz/Nvidia-Kernelmodule-71.86.06-for-k2.6.27.5.pet

Install it, and the
NVIDIA-71.86.06-k2.6.25.16.pet for prehistoric cards
from: http://www.murga-linux.com/puppy/viewtopic.php?t=34001
Then pray that it works Smile
I'll report back with more details tomorrow.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 Dec 2008, 09:03    Post_subject:  

oh darned Sad

/var/log/Xorg.0.log

Quote:
(II) Loading /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/X11R7/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)


The kernelmodule loads, but the Xorg module is incompatible with Xorg 7.4.
That is closed source, so I doubt there will be a patch?

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
techtype

Joined: 16 Nov 2008
Posts: 181

PostPosted: Tue 16 Dec 2008, 14:07    Post_subject: Quad Core  

Just a note for you that this pup seems to only recognize 2 cores on a quad core. That is all that show in conky anyway. Great pup though!! I have not figured out how to configure lxde yet. Can't change the global font, wallpaper or position of the menu panel to the bottom.
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 16 Dec 2008, 22:22    Post_subject:  

Quote:
NDISwrapper is a free software driver wrapper that enables the use of Microsoft Windows drivers for wireless network devices (cards, USB modems, and routers), on Unix-like operating systems, for devices sharing the same architecture only, namely either the Intel x86 architecture or x86_64. NDISwrapper works by implementing the Windows kernel and NDIS APIs, and dynamically linking the driver to this implementation.


ndiswrapper for this kernel, WARNING: many windows driver will not work...


I will try to compile a newer version(ndiswrapper) later...
ndiswrapper-svn-r2673-k2.6.27.5.pet
Description  Source code updated on december 24 2008
pet

 Download 
Filename  ndiswrapper-svn-r2673-k2.6.27.5.pet 
Filesize  111.88 KB 
Downloaded  419 Time(s) 
ndiswrapper-1.53-k2.6.27.5.pet
Description 
pet

 Download 
Filename  ndiswrapper-1.53-k2.6.27.5.pet 
Filesize  111.61 KB 
Downloaded  446 Time(s) 

_________________


Edited_time_total
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 16 Dec 2008, 23:10    Post_subject:  

@magerlab: "arrow key not work at all"
Ok, it happens when you change keyboard model with 'xkbconfigmanager' in Xorg-7.4
To fix it comment out 'Option "XkbModel" "pc102"' in /etc/X11/ don't worry about removing this, Xorg-7.4 will autoconfigure your keyboard.
Code:
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
#    Option         "XkbModel" "pc102"
    Option         "XkbLayout" "es" #xkeymap0
EndSection
I edited ~/.xinitrc to read the keyboard layout from /etc/keymap, 'cause X always try to use the 'us' layout. Please use 'input-wizard'>'Choose keyboard layout for your country' to fix this.
_________________________________________________________________

@iscraigh: Edit /etc/xdg/lxsession/LXDE/autostart more info: http://wiki.lxde.org/en/LXSession

@techtype: My Conky cofig file only add the 2nd cpu if detected. To add more edit: /etc/conky/conky.conf Example(untested):
Code:
...
TEXT
${font Zekton:size=20}puppy linux ${pre_exec head /etc/puppyversion -c 3 | sed 's/[0-9]/&./'}
${font Zekton:size=14}$alignr${execi 4 expr `calcfreespace.sh` / 1024} MB Free
${font Zekton:size=10}
${pre_exec cat /proc/cpuinfo | grep 'model name' | sed -e 's/model name.*: //' | head -1}}
CPU 1: ${cpu cpu1}%
${color lightgray}${cpubar cpu1 7,168}$color
${if_existing /proc/acpi/processor/CPU1/info}CPU 2: ${cpu cpu2}%
${color lightgray}${cpubar cpu2 7,168}$color
$endif
${if_existing /proc/acpi/processor/CPU2/info}CPU 3: ${cpu cpu3}%
${color lightgray}${cpubar cpu3 7,168}$color
$endif
${if_existing /proc/acpi/processor/CPU3/info}CPU 4: ${cpu cpu4}%
${color lightgray}${cpubar cpu4 7,168}$color
$endif

RAM: $memperc%
...


@MU, I used to have a GeForce2, it works with the 96.xx.xx driver. BTW, try to extract the kernel module source code from nVidia installer with something like:
Code:
sh NVIDIA-Linux-x86-96.43.07-pkg1.run -x

Go to NVIDIA-Linux-x86-96.43.07-pkg1/src and look for any text file explaining how to compile the kernel module.

I'm downloading NVIDIA-Linux-x86-96.43.07-pkg1 (new legacy) driver, I'll make a dotpet tomorrow (22:03 here)

Use 'lxsession-edit' to get rid of xcompmgr and conky at startup (Menu>Preferences>Desktop Session Settings)

_________________

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 17 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1071s ][ Queries: 13 (0.0082s) ][ GZIP on ]