Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 00:02
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
AbiWord 2.6.4 - Upgrade wanted
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [25 Posts]   Goto page: 1, 2 Next
Author Message
davids45


Joined: 26 Nov 2006
Posts: 627
Location: Chatswood, NSW

PostPosted: Wed 15 Oct 2008, 21:09    Post subject:  AbiWord 2.6.4 - Upgrade wanted
Subject description: for those communicating with the docx world
 

G'day.

Abiword 2.6.4 is able to open MS 2007 docx format files whereas the Abi older versions in Pup cannot, or the pet plug-in to do it, I can't find.

Abiword seems not to want the lay person (like me) to install it in Linux, but to pass the job onto the "distribution".

Could "the distribution" create a Pup of 2.6.4 and its associated bits, please?

Abiword 2.6.4 is fine in XP, so I could use it in wine I suppose.

David S.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6424
Location: Auckland, New Zealand

PostPosted: Thu 16 Oct 2008, 05:26    Post subject:  

2.6.3 supports docx doesn't it?
So you could upgrade your Puppy or try just installing the .pet from the Puppy repository...

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 627
Location: Chatswood, NSW

PostPosted: Thu 16 Oct 2008, 20:32    Post subject:  

G'day,
I thought it did too, but when I tried on a couple of Pup installs, both gave rubbish whereas my full & fresh 2.6.4 XP install read the docx file.
It may be just the plug-in for 2.6.3 I need then?
David S.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 17 Oct 2008, 05:53    Post subject:  

heres a free online converter
http://www.docx2doc.com/
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
disciple

Joined: 20 May 2006
Posts: 6424
Location: Auckland, New Zealand

PostPosted: Fri 17 Oct 2008, 19:52    Post subject:  

I suspect you just need to install the "Abiword plugins" package from petget... it probably just isn't included in the Puppy iso.
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
malderson


Joined: 15 Nov 2007
Posts: 45
Location: Wisconsin, USA

PostPosted: Thu 11 Dec 2008, 12:26    Post subject: Abiword PET for Puppy 3.01?  

I'm using Puppy 3.01 as a full HD install, and since I've got it tweaked the way I want it, I'd just as soon not upgrade. I would like to upgrade Abiword to a version that can handle docx files.

Is there a PET for Abiword 2.6.3 that will work on 3.01? The only one I find in the repositories is for Dingo; will that work in 3.01?
Back to top
View user's profile Send private message 
ecomoney


Joined: 25 Nov 2005
Posts: 2183
Location: Lincolnshire, England

PostPosted: Wed 29 Apr 2009, 09:49    Post subject:  

Do you guys realise the trouble you caused posting this.... Very Happy
_________________
Puppy Linux's Mission

Sorry, my server is down atm!
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 02 May 2009, 03:32    Post subject:  

I got my existing abiword in 4.2 opens docx correctly & also on click..

first docx mime types pet from tuuxx from official 4.2 deep thought official patches&updates thread

and I use this plugin (pet below) also I downloaded the /usr/share/abiword-2.6 from official ubuntu jaunty deb (follow the link from abiword homepage)

that's all I did
abiword_plugins.pet
Description 
pet

 Download 
Filename  abiword_plugins.pet 
Filesize  857.55 KB 
Downloaded  685 Time(s) 

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 02 May 2009, 03:44    Post subject:  

screenshot below> and I did download plugins from pet get, but somehow it didn't work
docx.jpg
 Description   
 Filesize   43.3 KB
 Viewed   2250 Time(s)

docx.jpg


_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 02 May 2009, 04:25    Post subject:  

I don't get why your all doing that? have you tried the fix I made like over a month ago?
http://www.puppylinux.asia/tpp/ttuuxxx/puppy420/release/programs/abiword-2.6.3-updated.pet
and
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=16845
if you click on a docx file it should open up straight away.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 02 May 2009, 04:30    Post subject:  

ttuuxxx wrote:
I don't get why your all doing that? have you tried the fix I made like over a month ago?
http://www.puppylinux.asia/tpp/ttuuxxx/puppy420/release/programs/abiword-2.6.3-updated.pet
and
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=16845
if you click on a docx file it should open up straight away.
ttuuxxx


I don't know also Laughing but my abiword was not working before ..tried here and there...and also found this thread complaining...so I figure I post my experience..that's all......I don't know about your fix, and this is one example of scattered infos and fixes...

should I just delete it then?

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 02 May 2009, 05:35    Post subject:  

trio wrote:
ttuuxxx wrote:
I don't get why your all doing that? have you tried the fix I made like over a month ago?
http://www.puppylinux.asia/tpp/ttuuxxx/puppy420/release/programs/abiword-2.6.3-updated.pet
and
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=16845
if you click on a docx file it should open up straight away.
ttuuxxx


I don't know also Laughing but my abiword was not working before ..tried here and there...and also found this thread complaining...so I figure I post my experience..that's all......I don't know about your fix, and this is one example of scattered infos and fixes...

should I just delete it then?


I don't know, this is the one in puppies 4.2 v2 and works well, it opens docx files and makes every format that abiword offers, its just a bit older version that I updated with the latest plugins compiled on 4.2.
really there wouldn't be any difference between the latest version and this version other than this version doesn't need TYMES font enabled by default. Which I tried to enable Tymes font as the main system default font, but it looks like its really embedded into puppy.
I even deleted the usr/share/fonts folder and replaced it with tymes fonts and also changed configs in root and in etc/ and still it reverts to the original fonts, Thats why I like this version above I posted, it just works out of the box, no messing around with system defaults for fonts etc.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
ecomoney


Joined: 25 Nov 2005
Posts: 2183
Location: Lincolnshire, England

PostPosted: Sun 03 May 2009, 00:29    Post subject:  

What Im saying Ttuxxx, is that these were the only guys on here who needed the "Upgrade" of Abiword to get the .DocX support, with the result that no one could open almost ALL Word Docs created on Windoze (except devs)....and a whole heap of trouble besides.

If Abiword had been a .pet, that had been compiled, released through .petget, tested, and the bugs ironed out there before it was included in the main Distro, a lot less people would be smarting now.

Same goes for the the CUPS and Seamonkey that was included having just been compiled.

I do understand that there is no warranty/is free/no responsibility on the part of the programmer etc

Just a thought for the future

_________________
Puppy Linux's Mission

Sorry, my server is down atm!
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 03 May 2009, 00:52    Post subject:  

Just a thought for the future, stop saying there is something wrong with Seamonkey when its running 100% perfect, It displays a security warning because a newer version is out. That is how its designed, its not a flaw, it works perfect. Mozilla designed it that way, to remove a security feature because it displays once and you can tick it so it doesn't display again is wrong,thats up to the user and does not warrant a "flaw", So take that out of your bag of complaints on here. Its bad enough with abiword and Cups, no need to add extras that aren't actually faults, I'm actually very proud of that Seamonkey I put into 4.2, a lot of work, effort, time went into it and also made me put Seamonkey on the same level as Firefox for once, it used to be on the bottom of list of browsers I liked, I hated the GUI,look and overall feel, now its just as good, if not better than a default Firefox install.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
disciple

Joined: 20 May 2006
Posts: 6424
Location: Auckland, New Zealand

PostPosted: Sun 03 May 2009, 06:45    Post subject:  

Since we're complaining about abiword again, I'll mention again that Abiword in 4.x has always tended to not display half the text in a document (at least .doc, I'm not sure about other formats). Around here the fact the version you blame Ttuuxxx for worked even less often than usual isn't even an issue, because it was broken in the first place Sad
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [25 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0801s ][ Queries: 13 (0.0049s) ][ GZIP on ]