Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 05:57
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon LBP460 Linux Driver
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Hugh


Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Wed 02 Apr 2008, 20:00    Post_subject:  Canon LBP460 Linux Driver
Sub_title: Can this be adapted to Puppy?
 

A Linux driver for my Canon LBP460 laserprinter is available here:

http://www.boichat.ch/nicolas/lbp660/

While I've enjoyed using Puppy Linux 2.14 very reliably as an add-on to my Win98 system, there are some things I've not yet figured out.

Is there any way to install this driver into Puppy?

Would it need to be converted to a form compatible with Puppy?

If it is possible to get it going in Puppy then I'd be completely WinFree!

Edited_time_total
Back to top
View user's profile Send_private_message 
Ray MK


Joined: 05 Feb 2008
Posts: 765
Location: UK

PostPosted: Thu 03 Apr 2008, 03:59    Post_subject:  

Hi

Being a n00bie I dont know the answers to your questions - but suspect they may be yes.

However until someone more knowledgeable advises, you may wish to consider a look at an alternative way of achieving a result.

This may or may not work, wont do any harm, will enhance your experience with Puppy and might even be fun.

If you are running 2.14 std issue alongside Win98 as a frugal install it is easy to make a backup copy of your save_file and tuck it away in a safe NewDir temporarily or just rename it or (belt & braces) do both.

Now your save_file is safe you can try a couple of alternative puppy's that may do the job.

!) 2.14r is a revisited and revised 214 and has probably more drivers included than any other puppy around so well worth a look.

2)TeenPup 2008 is another reworked and considerably enhanced 214 based puppy and again well worth a look - I suspect that when you see this it will make you want to flush 98 almost instantly.

3) Dingo4_alpha7 is a testing puppy but has the very latest canon, epsom, hp and other printer drivers available.

Hope the above helps and is of some interest - should at least be a fun something to try.

Best regards - Ray MK
Back to top
View user's profile Send_private_message 
Hugh


Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Thu 03 Apr 2008, 21:45    Post_subject: PUPPY Printer Driver options  

Ray MK,

Thank you for the suggestions for a possible work-around.

With the exception of the LBP460 problem, PUPPY 2.14 has been so reliable I hadn't considered the possibility of an upgrade of this version.

I'll try your recommended procedure and come back with a report.
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Thu 03 Apr 2008, 22:54    Post_subject:  

Hugh,

I've made a zip, of the file you linked to above. Try unzipping this and let us know whether it works or not. You'll need to have cups installed for it to work though. Extract the attached file to /.

The zip file contains the drivers for both the 660 & 460, but, not having either to test with, I'm unable to verify this works.
lbp660-0.3.1.zip
Description 
zip

 Download 
Filename  lbp660-0.3.1.zip 
Filesize  118.64 KB 
Downloaded  533 Time(s) 
Back to top
View user's profile Send_private_message 
Hugh


Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Sat 05 Apr 2008, 20:36    Post_subject: CUPS and LBP460  

Thank you Muggins,

I've downloaded the file you've offered and will see if I am able to install CUPS to try it out.

I'll try this before attempting the other options suggested by Ray MK.

If all goes well perhaps I can postpone upgrading to a newer version.
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Sat 05 Apr 2008, 20:54    Post_subject:  

Hugh,

another possible option, if things don't work out using the method described in your link, is to use pakt's cups package, & the included .ppd file. Let us know how you go.
Back to top
View user's profile Send_private_message 
Hugh


Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Fri 05 Dec 2008, 22:07    Post_subject: LBP460 install progress update
Sub_title: Is a manual installation of the files possible?
 

I've upgraded to Puppy 3.01 and ran the Puppy 4.1 upgrade so it appears at bootup I've got a little of both. In any case it works very well and boots up noticably faster (Frugal Install with Win98).

I've attempted to install the LBP460 driver (See Muggins post above) and CUPS reported success, but still no success in getting anything to the printer.

Where in Puppy's file system should I look to find if the .ppd has been installed?

If the .ppd file isn't in its proper location would manually copying to the proper folder to make the installation right?
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Fri 05 Dec 2008, 22:28    Post_subject:  

Hugh,

the attached .zip, if extracted to /, will deposit Canon-LBP-460-lbp460.ppd & Canon-LBP-660-lbp660.ppd to directory /usr/share/cups/model.

If you run the CUPS printer wizard, and try adding a printer, do these two .ppd files show up as options?
Back to top
View user's profile Send_private_message 
Hugh


Joined: 24 Jun 2006
Posts: 136
Location: Imperial Warmongering Dystopia of Amerika

PostPosted: Sat 06 Dec 2008, 03:55    Post_subject: CUPS and the LBP460  

When I run the Printer Wizard to add a printer I'm not able to connect to localhost:631 directly but am able to get there through this page.

Then I'm able to do the on-line install process and select the appropriate .ppd file, LPT1, etc...

It finally reports that the install is complete, the printer is idle accepting jobs; so then I attempt to print a test page and the job fails.

The version of CUPS it reports is 1.2.11

The .ppd file is properly located at /usr/share/cups/model.

I'm wondering if anyone has successfully installed the LBP460 in Puppy and how they've gotten it to print.

Here I'm stuck.

Clearly, more research is in order...

I truly appreciate all the help you've provided. Many thanks!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0609s ][ Queries: 13 (0.0070s) ][ GZIP on ]