Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 10:20
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
CF-IDE Adapter Report
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
kethd

Joined: 20 Oct 2005
Posts: 451
Location: Boston MA USA

PostPosted: Thu 24 Nov 2005, 15:18    Post_subject:  CF-IDE Adapter Report  

KethdAdapters -- CF-IDE Adapter Report

KethD Adapter Reports

===Nov 2005 kick-lee===
I received my assortment of four CfIde CF-IDE adapters from kick-lee (eBay ID) in Hong Kong.
The price and service were quite good. Seven days from when I paid via Paypal until receipt of the Air Mail Small Packet registered-signature, HK to US.
(The only downside of purchasing from him is that he refuses to sell directly, so combined S/H for larger orders gets ever more unreasonable. Does anyone know of a better source for these standard generic China-made adapters, that WILL sell directly?)

The four CF-IDE adapters I got were:
* CF-IDEmale label: Dual CF to IDE ADAPTER V1.0
* dualCF-IDEmale label: HX-2108
* dualCF-IDEfemale label: SINTECH CF-IDE40 V.E0 (Double/DMA/3 LED)
* CF-IDEmale44pin label: SINTECH CF-IDE44/2.0mm ADAPTER V.B1

The quality of the soldering looks good. (Use a magnifying glass -- I received some from another source that were badly soldered.) All tested OK in a Compaq DP2000 P-233MMX. Having an activity LED is quite nice; having power LEDs to reassure you is even nicer. Only the 44pin adapter lacked any LED.
The silk-screen labelling was somewhat screwy; some said DUAL but were single, and vice-versa!
The fanciest one also has a jumper for 5V/3.3V operation. I don't understand when this would be good or bad, on IDE channels -- I would think everything would be operating on an old 5V TTL signal standard.
The only thing that did not work was, one of the duals that had a master/slave jumper. On a properly working single adapter, you remove the jumper for Slave mode (I have not actually tested this.) I am guessing that a CF pin is grounded to tell the card to act like a Master hard drive. On a properly designed and working dual adapter, this is a 3-pin header, and you move the jumper to change from Master/Slave to Slave/Master mode.
One of the duals was built with just a two-pin jumper, so with the jumper on it acts as Master/Slave, but with the jumper removed it probably acts as Slave/Slave. Not good, but not really very important.

SPEED TESTS
My compact flash cards are not labelled with speed. (12X, 40X, etc. -- 1X=150KB/s??)
HWINFO gives these results:
8MB 1,536 CHS 248/2/32 KB/s Samsung
64MB 7,288 CHS 490/8/32 KB/s SanDisk
128MB 2,672 CHS 978/8/32 KB/s SanDisk
These are surprising results. The SanDisk appear to be very similar SDCFB-family parts. Why is the smaller one three times faster?

HWINFO is a very nice simple DOS program that gives hard drive hardware information, CHS parameters etc. What is most super special is that it is usually able to give this information about all connected IDE hard drives, even if they have not been recognized/configured by the BIOS! (Which then helps you know how to get the BIOS parameters set properly.)

I did not test booting Puppy on these, but I did test that they would boot something.
They are nice and small, and the female versions that plug right into a mainboard are very cute, if they work out well with the way your mainboard is laid out (nothing in the way).
The 44pin version is very small, would certainly fit in a laptop in place of a 2.5-in drive -- although the one I was sent had a plastic shell around the male connector, which I trimmed off.

No Power Needed?
I discovered by accident that the compact flash cards seem to work fine, at least reading/executing, with the power cable unplugged. (Is this safe?)

2.5in-3.5in Adapters
I have quite a number of 44pin 2.5in to 40pin 3.5in IDE adapters, which allow laptop hard drives to be used in desktops. (Very handy for rescuing files from broken laptops.) They are commonly available for $5 each or less. There are various styles; sometimes they come with mounting brackets, which you mostly don't need. Often they are not well labelled with pin-1 -- you might want to add a dot of white-out or finger-nail polish for visual orientation. There are two ways IDE connectors are keyed, to prevent mis-plugging -- one is a plastic notch/key in the middle of one edge, and the other is a missing pin. But sometimes that pin is NOT missing, which makes a problem when you try to mate with a socket where the hole has been plugged. (Then you can cut off the pin or try to unplug the hole -- or search for another cable that does not have a plugged hole.)
Anyways, these adapters are quite simple, just connecting the pins straight through from the 2mm 44pin world to the 2.54mm 40pin world, and adding a power connection. So what could go wrong? I had one poorly made one that seemed to have some solder bridges, which I cleaned off. But I have at least two of them that look fine, look just like others that DO work, that DON'T work. I am baffled. All my ohm-meter checks say they are fine, but they just don't work. I'm going to have to make some fancier test jigs to track down all the possible shorts and opens. Very frustrating.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11068
Location: Arizona USA

PostPosted: Thu 24 Nov 2005, 17:54    Post_subject:  

That's nice, but it's not clear if you tested these to work in Puppy. That's the purpose of this forum. Smile

Also, when you've tested them, could you make a separate post for each one, with its name in the subject line, to make searching the forum easier?

Thanks. Wink
Back to top
View user's profile Send_private_message 
kethd

Joined: 20 Oct 2005
Posts: 451
Location: Boston MA USA

PostPosted: Thu 24 Nov 2005, 18:53    Post_subject: Sorry, I have not tested any of these specifically with Pup  

No, Sorry, I have not tested any of these specifically with Puppy yet... (Just this basic testing took a whole day, with some confusing things going wrong -- hard to believe, that simple things are so much work.) But I think they are very relevant to Puppy (cheap, small, appropriate capacity, mobile, usable many different ways) -- and I don't know of any Puppy-specific issues (yet).
If the CF-IDE Adapters boot at all, they are functioning as full emulators of hard drives, and the install should be the same -- except for the subtle generic issues that apply to all flash media, wanting to be mounted in a way that minimizes writes... I need to learn how to keep Puppy from trying to use one for swap space!
The adapters that allow using a 2.5in hard drive in place of a 3.5in hard drive have even fewer Puppy-specific concerns -- it is just a form-factor matter. But again, I think quite relevant to Puppy -- I'd guess that I am not the only Puppy user wanting an agile Pup that can cross-transplant between as many different computers as possible -- that's one of the big potential attractions of Puppy.
Back to top
View user's profile Send_private_message 
mskuma

Joined: 13 Nov 2005
Posts: 25
Location: Australia

PostPosted: Thu 24 Nov 2005, 20:19    Post_subject:  

I've been working in this area recently - so I'll offer some comment. I bought a cheap adapter like the above on ebay - probably via hong kong. I also tried another one from pc engines that wasn't as cheap but not an unreasonable cost. The pc engines adapter is a premium product in my opinion.

I've used both with Puppy. I learned from this experience that some adapters & CF cards support DMA access & some don't. You should know about that to save some grief & possible confusion. The former adapter doesn't support DMA access. So I found Puppy hung on boot up stopping at some DMA reference (excuse me - I'm a newbie) so you either have to use ide=nodma in the syslinux.cfg file (if your card supports DMA like SanDisk UltraII) or use a CF card that doesn't claim to use DMA or use a util that turns of DMA access in the CF card (apparently SanDisk has a tool). The latter card does support DMA access, so no problem using any CF card.

In summary, use an adapter that supports DMA access and you'll have no problem, else be aware of the remedy in the event of a DMA-related boot up issue.

I read somewhere else that some linux distros fall back to PIO access when a DMA issue occurs. Maybe this is something for Puppy to consider in the future.

HTH

Michael.
Back to top
View user's profile Send_private_message 
keenerd

Joined: 20 Aug 2005
Posts: 175

PostPosted: Thu 24 Nov 2005, 23:53    Post_subject:  

Here's where I got mine:
http://www.sealevel.com/product_detail.asp?product_id=821&

I really like this type, since I can use it in any sort of computer, laptop or desktop. Costs a little more than ebay, but it's a quaility piece of serious hardware (not hand soldered!)
Back to top
View user's profile Send_private_message 
kethd

Joined: 20 Oct 2005
Posts: 451
Location: Boston MA USA

PostPosted: Fri 25 Nov 2005, 19:11    Post_subject: Thanks for the comments  

mskuma,
Good to hear about your experiences -- That is very interesting -- and surprising! information...
Does anyone have any idea about what would make a CF-IDE adapter support or not support DMA?
These adapters contain almost no active circuitry, so other than some kind of sloppy oversight or mistake in design of the wiring, it sounds unexpected...
The pc engines adapter is the first one I have ever seen with a big (Molex) power supply connector.


keenerd,
That sealevel adapter looks well made. I really like having both the 44pin and 40pin connectors on one CF-IDE adapter, but that style is very hard to find!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0667s ][ Queries: 12 (0.0039s) ][ GZIP on ]