Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Nov 2019, 19:55
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Trouble with Intel(R) WiFi Link 5100 driver
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Anders

Joined: 20 Nov 2008
Posts: 5

PostPosted: Thu 20 Nov 2008, 17:18    Post subject:  Trouble with Intel(R) WiFi Link 5100 driver  

I have for some days now tried to get my wireless network card working. I am not good with Linux and, but non there less, I've been trying really hard to get my wireless working.

First, my specs:
Puppy version: 4.1.1, released Nov 2008
Computer name: Multicom Compal JHL90+ GeForce® 9600M GT 512MB Centrino 2
# Mobile Intel® PM45 Chipset
# Intel 802.11a/b/g/n ( im not shure if I have this card or this) Intel(R) wireless WiFi Link 5100
It stands on the xp hardware configuration page that I have Wifi Link 5100 but on the manufactures web site, it stands 802.11/a/b/g/n

I've tried:
To wrap the windows inf file
choose some other intel modues.

I have managed to download some files, but not install them:
iwlwifi-5000-1.ucode - Intel Wireless WiFi Link 5000AGN Adapter Series

compat-wireless-2.6-old/ - got this from a linux site.

Hope I've given you enough information so that you could help me and others.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4449
Location: Sydney Australia

PostPosted: Sun 23 Nov 2008, 18:27    Post subject:  

Multicom Compal



////////

My sailboat is becalmed also.

http://www.murga-linux.com/puppy/viewtopic.php?t=35962

:::::::::

I have extracted the bcmwl5.inf file xp driver for this laptop
and the sp39243.cva file.

Open them up with a text editor...maybe this can help us both.
Anders ... If you get a solution ...please post back.
One of my pet peeves....unanswered posts.

Thanks.................Chris.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Tue 25 Nov 2008, 08:00    Post subject:  

The Intel WiFi Link 5000AGN series is not supported in the 2.6.25 kernel of Puppy 4.1.x.
But from the 2.6.27 kernel onwards there is a new driver - "iwl5000".

UPDATE: wow and MU have released a Puppy variant with 2.6.28 kernel -
"Unnamed puplet 1.1 (puppy411 kernel-2.6.28.5 Xorg-7.4 LXDE)"
http://www.murga-linux.com/puppy/viewtopic.php?t=39154

UPDATE 2: Puppy 4.3 and Puppy 5 (uPup) will both have modern kernels.

You must also obtain the necessary "iwlwifi-5000-ucode" firmware from here -
http://www.intellinuxwireless.org/?n=Downloads
and uncompress it into /lib/firmware

Last edited by tempestuous on Sat 22 Aug 2009, 20:37; edited 2 times in total
Back to top
View user's profile Send private message 
Frila

Joined: 10 Jan 2009
Posts: 24
Location: Sweden

PostPosted: Sun 01 Mar 2009, 15:19    Post subject:  

tempestuous wrote:
The Intel WiFi Link 5000AGN series is not supported in the 2.6.25 kernel of Puppy 4.1.x.

But in the 2.6.27 kernel there is a new driver - "iwl5000". MU has released a Puppy derivative with 2.6.27 kernel, which most likely has this new driver. You would just need to obtain the necessary firmware from here -
http://www.intellinuxwireless.org/?n=Downloads
and uncompress it into /lib/modules


I have experienced the same problem with my 2.6.26 kernel of Puppy 4.1.2.
I have downloaded the iwlwifi-5000-1.ucode - Intel Wireless WiFi Link 5000AGN Adapter Series to /lib/modules.
What do do next? I suppose it must be installed in some way? Or have I missunderstood the whole idea of installing firmware and driver Confused
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Sun 01 Mar 2009, 17:13    Post subject:  

Frila wrote:
I have experienced the same problem with my 2.6.26 kernel of Puppy 4.1.2.

No, Puppy 4.1.2 has a 2.6.25.16 kernel. This kernel does not have a driver for the Intel 5000 wifi chipset.

My comments refer to the 2.6.27 kernel in the UltraPup derivative contriubted by forum members wow and MU.
Back to top
View user's profile Send private message 
Azrial

Joined: 22 Mar 2009
Posts: 29

PostPosted: Mon 30 Mar 2009, 10:55    Post subject:  

o sry... wrong topic...pls delete
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0424s ][ Queries: 12 (0.0126s) ][ GZIP on ]