Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 11:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Truecrypt 6.1 for Puppy english
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Stingray

Joined: 12 Sep 2008
Posts: 11

PostPosted: Wed 05 Nov 2008, 02:33    Post_subject:  Truecrypt 6.1 for Puppy english
Sub_title: truecrypt 6.1 compiled for puppy unicode english
 

here the latest truecrypt exectuable version 6.1

it needs to unset the "use kernel crypto library" since puppy has no device manager.

please inform me about possible compiling errors. if you want to compile this by yourself, you need to read the Readme.txt in the truecrypt sourcedirectory.
truecrypt-6.1.gz
Description  puppy truecrypt 6.1 executable standalone english unicode
gz

 Download 
Filename  truecrypt-6.1.gz 
Filesize  1.71 MB 
Downloaded  1768 Time(s) 
Back to top
View user's profile Send_private_message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Sat 22 Nov 2008, 05:24    Post_subject:  

Hi Stingray, thank you for that file.
I'm strongly interested in using truecrypt. Although I use Puppy since about 1 year, I'm not familiar with compiling. So this is my first try of using truecrypt.

I can create a container and get the answer 'The TrueCrypt volume has been successfully created ' but if I try to mount it, I get the answer
'No such file or directory: dmsetup '.
I use Puppy 4.11

Please can you help me to solve this problem?
Rolf

Edit: I found my fault. So now it seems to work fine. Thank you again.

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
pigphish

Joined: 23 Nov 2008
Posts: 1

PostPosted: Sun 23 Nov 2008, 02:55    Post_subject:  

How did you fix the dmsetup issue also. How do we set the option in puppy?
Back to top
View user's profile Send_private_message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Sun 23 Nov 2008, 11:59    Post_subject:  

Settings->Preferences->System Integration-> click on 'Do not use kernel cryptographic Services'.
All other options I let as they were.

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
rrolsbe

Joined: 15 Nov 2006
Posts: 183

PostPosted: Sun 23 Nov 2008, 13:56    Post_subject: Truecrypt 6.1 mounts WDE NTFS Disk readonly from Puppy 4.11
Sub_title: Almost there SOLVED!!!
 

To mount the WDE NTFS drive Read/Write using the TC6.1 GUI do the following:

settings>Preference>Mount Options Then under Filesytem/Mount options: Enter ntfs-3g


First off thanks for Truecrypt 6.1 and the tip about how to disable kernel mode encryption using the Truecrypt 6.1 GUI.

I can now mount my "Whole Disk Encrypted" NTFS Truecrypt volume /dev/sda1 now from Puppy 4.11; however, the volume is mounted read only.


I did not select the read only option when checking the pre-boot authentication option in TC6.1.

The volume Properties in the TC6.1 GUI shows the volume as mounted
Read-Only "No"; however, the mount command shows the volume as mounted Read-Only (See Below)

truecrypt on /tmp/.truecrypt_aux_mnt1 type fuse.truecrypt (rw,nosuid,nodev,user_id=0,group_id=0,allow_other)

/dev/loop2 on /mnt/truecrypt10 type ntfs (ro,uid=0,gid=0,umask=077,nls=iso8859-1,errors=continue,mft_zone_multiplier=1)

BTW, when I mount a truecrypt file container, it is mounted read/write.

Container mount results below:

truecrypt on /tmp/.truecrypt_aux_mnt1 type fuse.truecrypt (rw,nosuid,nodev,user_id=0,group_id=0,allow_other)

/dev/loop2 on /mnt/truecrypt10 type vfat (rw,fmask=0077,dmask=0077,codepage=cp437,iocharset=iso8859-1)

I can mount this same NTFS WDE volume Read/Write using the Windows version of Truecrypt booted from the Bartpe PE environment.

Any Ideas? Sure would be nice to be able to rathole files onto the NTFS volume while using Puppy 4.11.

Thanks Much In Advance
Regards
Ron
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0537s ][ Queries: 13 (0.0083s) ][ GZIP on ]