Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 03:28
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
wlan with ath chipset not working with new puppy
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [30 Posts]   Goto page: 1, 2 Next
Author Message
gschl

Joined: 10 Jan 2007
Posts: 14

PostPosted: Tue 07 Oct 2008, 15:48    Post subject:  wlan with ath chipset not working with new puppy  

as opposed to puppy 4.0 my D-Link-wlan-card with an atheros chip is not working in puppy 4.1 - but using the "retro"-version it does work. Why?

on a msi-laptop with Intersil 2.5-wavelan chipset neither version of puppy 4.1 is working
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Tue 07 Oct 2008, 17:14    Post subject:  

gschl wrote:
my D-Link-wlan-card with an atheros chip is not working in puppy 4.1

Puppy 4.1 gives preference to the new ath5k driver over the ath_pci driver, but ath5k is unreliable. You can reverse these preferences in boot options so that ath_pci will load.
Back to top
View user's profile Send private message 
jonlowe

Joined: 07 Oct 2008
Posts: 44

PostPosted: Tue 07 Oct 2008, 23:54    Post subject:  

Confirm the bug with my Netgear PCMCIA WG511T card with the Atheros chipset. The ath5k driver gets reloaded after a reboot, even if the ath_pci driver is selected and saved. I finally deleted the entire ath5k driver to keep from having to reload the ath_pci driver after each reboot. Do a search for ath5k and delete whatever you find in the way of files.

Why they would include this admittedly development driver (look at its description in Pupscan) to a stable release of Puppy, I have no clue. The ath5k driver recognizes the card, but doesn't work at all. Yeah, the ath_pci is proprietary, but it works.

Jon
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Wed 08 Oct 2008, 00:12    Post subject:  

jonlowe wrote:
I finally deleted the entire ath5k driver to keep from having to reload the ath_pci driver after each reboot.

The correct process, as I said, is to set preference for ath_pci in the boot manager wizard.
Back to top
View user's profile Send private message 
jonlowe

Joined: 07 Oct 2008
Posts: 44

PostPosted: Wed 08 Oct 2008, 00:42    Post subject:  

tempestuous wrote:
jonlowe wrote:
I finally deleted the entire ath5k driver to keep from having to reload the ath_pci driver after each reboot.

The correct process, as I said, is to set preference for ath_pci in the boot manager wizard.


Took me awhile to find it, as it isn't under the Wizards area in the menu. Now that I know it is there, I will use it next time. Sometimes it was loading both of ath_pci and the ath5k drivers.
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Wed 08 Oct 2008, 10:05    Post subject: Puppy 4.1 Acer 5100 Laptop wireless not working  

See my comments also in thread:

http://www.murga-linux.com/puppy/viewtopic.php?t=34159

Cannot get a stable wireless network using Puppy 4.1 (great pity).

So have reverted to 4.00.

Mike
Back to top
View user's profile Send private message 
gschl

Joined: 10 Jan 2007
Posts: 14

PostPosted: Wed 08 Oct 2008, 10:46    Post subject:  

@tempestuous: thank you - ath0 now working.....

and also the chip in eeepc 701 after downloading and installing madwifi...*.pet
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 08 Oct 2008, 14:25    Post subject:  

Maybe not very well known, but the bootmanager config in the System menu is a powerfull tool.

Taking this case, blacklisting the ath5k module would have solved the problem.
Advantage, you can always come back on the blacklist approach.

Another advantage, if for some reason a module isn't loaded, you can force loading it with the button 'click here to add new module'

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Thu 09 Oct 2008, 10:13    Post subject: ath_pci and Puppy 4.1  

Decide to give 4.1 another shot but this time I did a fresh install to a USB stick rather than an upgrade from 4.0. Changed in the BootManager the preference from ath5k to ath_pci. Gave up using either the new Network Wizard (could never get it to scan for networks) or Pwireless (could never get it to show saved profiles in the GUI) as a way of getting my wireless to work.

Just created a file with:

iwconfig ath0 mode managed essid XXXXX key YYYYYYYY ap ZZZZZ channel AA
dhcpcd ath0


Made this executable and then created a Sym link to this in the Startup folder. Now works perfectly every boot!

Pity not to used the hard work of the developer on the Network Wizard and Pwireless but I think my solution is much easier.

Now have Seamonkey email working, midi files playing from a Samba LADdisk attached to my router (using Audacious+plugin's+extra libs).

Don't like the new Pmusic player. You cannot drag/drop files to it. Stick with BMP for mp3 playing (at least on older hardware).

My photos from my Samba LANdisk are displayed like lightning using GQview.

Very pleased with 4.1 now!

-----
Mike
Back to top
View user's profile Send private message 
James186282


Joined: 08 Sep 2009
Posts: 127
Location: Minnesota

PostPosted: Thu 29 Oct 2009, 00:49    Post subject:  

I'm using 4.3 and can't seem to properly blacklist ath5k. It keeps showing up along with ath_pci as well as cfg80211, mac80211 led_class. I've used the bootmanager to blacklist them all yet they still load. Is there not some way to avoid them loading in the first place? I would rather not search and delete out these drivers but.... Truly confused.

- James186282
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 29 Oct 2009, 01:16    Post subject:  

James186282 wrote:
I'm using 4.3 and can't seem to properly blacklist ath5k. It keeps showing up along with ath_pci as well as cfg80211, mac80211 led_class. I've used the bootmanager to blacklist them all yet they still load. Is there not some way to avoid them loading in the first place? I would rather not search and delete out these drivers but.... Truly confused.

- James186282


This thread is a year old, things have changed a little. Smile

If you're using 4.3 with the latest kernel, ath pci is superceded
by ath5k.
4.3 is also available (special puppies) with 2 earlier kernels
that still use ath pci.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
scabz


Joined: 30 Apr 2009
Posts: 302
Location: Tallahassee FL US

PostPosted: Thu 29 Oct 2009, 01:26    Post subject:  

James186282 wrote:
I'm using 4.3 and can't seem to properly blacklist ath5k. It keeps showing up along with ath_pci as well as cfg80211, mac80211 led_class. I've used the bootmanager to blacklist them all yet they still load. Is there not some way to avoid them loading in the first place? I would rather not search and delete out these drivers but.... Truly confused.

- James186282


this is what i do dont know if it is the right way.
go to /etc/rc.d/MODULESCONFIG
open in text editor in SKIPLIST add ath5k and or whatever you want to blacklist.
in PREFLIST add ath5k:ath_pci if you want to have ath_pci take preference.

edit this works for me in 4.2 dont know about 4.3
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
James186282


Joined: 08 Sep 2009
Posts: 127
Location: Minnesota

PostPosted: Thu 29 Oct 2009, 11:57    Post subject:  

Thats the problem. ath5k is already in SKIPLIST and its still loading. This is really frustraiting. Should I seek out ath5k and delete it? I don't know what to do next? All I want is madwifi.
Back to top
View user's profile Send private message 
James186282


Joined: 08 Sep 2009
Posts: 127
Location: Minnesota

PostPosted: Thu 29 Oct 2009, 12:11    Post subject:  

I still see it if i
lsmod | grep ath

It shows...
ath5k 117296 0
mac80211 166056 | ath5k
led_class 4112 | ath5k
cfg80211 64972 2 ath5k, mac80211
ath_pci 233988 0
ath_hal 351392 | ath_pci
wlan 228048 | ath_pci

Its like some perverse combo of ath5k and madwifi SIGH... btw I have all the other ath5k modules such as mac80211 in the skiplist as well.

Evil or Very Mad
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 29 Oct 2009, 22:19    Post subject:  

If you're using 4.3.. with the latest kernel, ath pci is not even
listed.
If you have an earlier kernel;

Go to setup>configure startup>load kernel modules.
Check "give preference to one module......"
If both ath mods are there, switch the order.
You can also black list.

Run connection wizard.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [30 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0857s ][ Queries: 12 (0.0099s) ][ GZIP on ]