Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 18:28
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to adjust keyboard repeat rate? SOLVED
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
Varmint


Joined: 26 Apr 2007
Posts: 71
Location: Ohio, USA

PostPosted: Thu 25 Sep 2008, 20:59    Post subject:  How to adjust keyboard repeat rate? SOLVED
Subject description: Problem Solved, thanks gang!
 

Is anyone aware of a a way to re-adjust the keyboard repeat rate while using x-vesa? I tried this once in x-org, and that doesn't work too well either. Never had this problem with earlier bios, but a real problem in any recent system. I'm using a gateway P-III/450mhz. Dingo otherwise ROCKS!
I've noticed this is a problem with ALL live CD's. Amazing nobody thinks of this when building these distros!


UPDATE: Elsewhere in this thread (my final post) I detailed an elegant solution for this.

Last edited by Varmint on Sat 08 Jan 2011, 13:00; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Fri 26 Sep 2008, 01:30    Post subject:  

Gxset should be in the menu for that. I'm not sure if something replaced it in Puppy 4 or what, but if you can't find anything, run `xset -h` in a terminal and it is fairly straightforward to figure out how to use.
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Fri 26 Sep 2008, 23:06    Post subject:  

Dingo 4.00 has a gui utility but I don't think it holds settings between reboots. A shell script placed in ~/Startup can set the delay and repeat rate on each boot.

This may not look right but it works:

xset r rate 250 32 for a delay of .250 sec and a repeat rate of 32 per sec

Check it, if you want, after Xvesa starts with xset q

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
Varmint


Joined: 26 Apr 2007
Posts: 71
Location: Ohio, USA

PostPosted: Sat 27 Sep 2008, 21:21    Post subject: kbd rate in X-Vesa, not X-org
Subject description: I want to adjust in x-vesa
 

Sorry, guys, but it appears you didn't pay attention to my earlier post. I'm trying to adjust the keyboard rate in X-Vesa. X-org is fine if you have a newer & faster system. It will not work reliably in slower systems than, say, 5000mhz like mine. The utillity for this is readily visable in x-org, and needs little, if any, elaboration. What I can't understand is the absolute absence of such a utility in x-vesa, where it is just as necessary as in faster systems. It is a major oversite, and I just can't understand how it always gets overlooked in virtually EVERY live cd distro I've looked at. Am I the only one that can't type that fast? And why should I have to, anyway?
That said, I appreciate the input from everyone. I'll take a look at the config files for dingo and see if I can find a way to do this here, but it looks like it won't happen.
Back to top
View user's profile Send private message Visit poster's website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 28 Sep 2008, 04:00    Post subject:  

I have setup a virtual (qemu) PC running in xvesa.

If you type Xvesa in a rxvt terminal you get a long list of options. At first quick sight I don't see anything for keyboard rate only setting for autorepeat.

But it could be your starting point.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 28 Sep 2008, 04:10    Post subject:  

pfffft. The double posting problem strikes again.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Sun 28 Sep 2008, 12:20    Post subject: Re: kbd rate in X-Vesa, not X-org
Subject description: I want to adjust in x-vesa
 

Varmint wrote:
Sorry, guys, but it appears you didn't pay attention to my earlier post. I'm trying to adjust the keyboard rate in X-Vesa.


I did and my answer is for Xvesa.

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 28 Sep 2008, 14:14    Post subject:  

My Xvesa virtual machine is lacking the extension "Xfree86-Misc" in Xlib.
So the xset r rate cmd isn't executed.
But should be valid for Xvesa

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Sun 28 Sep 2008, 16:07    Post subject:  

Béèm wrote:
My Xvesa virtual machine is lacking the extension "Xfree86-Misc" in Xlib.
So the xset r rate cmd isn't executed.
But should be valid for Xvesa


Béèm,

I'm on a borrowed Win machine, so I can't do the checking and verifying I'd otherwise do.

I think it is successfully executed. You can check the truth with xset q

The problem is that its execution is good for one X session only, that's why I wrote to put the command in ~/Startup, so it runs one time for each new X(vesa) session.

Check and see if it works that way, OK?

Bruce

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 28 Sep 2008, 17:16    Post subject:  

Ok Bruce I see what you mean.

I made this script and did put it in ~Startup
Code:
#!/bin/sh
xset r rate 250 32
and rebooted. I then executed xset q
Code:
# xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  auto repeat delay:  250    repeat rate:  32
  auto repeating keys:  00ffffffdffffbbf
                        fadfffffffedffff
                        ffffffffffffffff
                        ffffffffffffff7f
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/X11R7/lib/X11/fonts/misc/,/usr/X11R7/lib/X11/fonts/TTF/,/usr/X11R7/lib/X11/fonts/Type1/,/usr/X11R7/lib/X11/fonts/Type1/,/usr/X11R7/lib/X11/fonts/TTF/
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Display is not capable of DPMS
#

It seems that the script did execute properly, as I didn't had the auto repeat delay: statement before.

So your idea seems to be the solution.

EDIT:
Wonder why I did get that long line. Embarassed
It's just a copy/paste from the rxvt terminal.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Sun 28 Sep 2008, 17:49    Post subject: Re: How to adjust keyboard repeat rate?  

Varmint,

By your first post, I thought you wanted to control the delay and rate. I've shown that.

If you want to simply turn it off for no autorepeat, this command:

xset -r

Bruce

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
Varmint


Joined: 26 Apr 2007
Posts: 71
Location: Ohio, USA

PostPosted: Sun 28 Sep 2008, 21:16    Post subject: kbd rpt rate
Subject description: none now...I found it!
 

Thanks Bruce, for your reply. I did modify the argument, however to reflect my intended purpose, thus:

"xset r off" which I typed in the console window. Nice. Real nice. It doesn't turn it off completely, but it sure slows it down considerably, and to my liking. I'm going to do the other command you listed, and try the script also mentioned. As far as I can tell, this should work, or some variant thereof, in just about any distro, which is almost as good as having it controlled in the system bios. The bios solution is, imho, the finest/simplest solution for this, but I'm too lazy to modify/re-burn my bios chip just to tinker with it. Not even certain if it would work on modern systems, but since this seems to work, fine with me! Thanks again!
Back to top
View user's profile Send private message Visit poster's website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 29 Sep 2008, 04:06    Post subject:  

When all is to your liking can you update your initial post and add [SOLVED] to the subject line?
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Varmint


Joined: 26 Apr 2007
Posts: 71
Location: Ohio, USA

PostPosted: Tue 30 Sep 2008, 16:39    Post subject: Solved
Subject description: adjusting kbd rate in x-vesa
 

Thanks for all the quick & helpful replies, gang! Works great now, and is such a simple solution for old/arthritic slow fingers like mine!
Back to top
View user's profile Send private message Visit poster's website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 30 Sep 2008, 16:56    Post subject:  

Glad you're happy with puppy. Very Happy
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0864s ][ Queries: 12 (0.0077s) ][ GZIP on ]