Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 18:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
error: Qt (>= Qt 3.0.3) (headers and libraries) not found.
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Jose

Joined: 23 Apr 2008
Posts: 26

PostPosted: Thu 17 Jul 2008, 17:57    Post subject:  error: Qt (>= Qt 3.0.3) (headers and libraries) not found.
Subject description: missing library?
 

Hello everybody,

I am trying to compile my second program in Puppy (first success was yesterday with Nano editor Wink ) but after I enter ./compile command in the directory with source code, I receive:

Code:
 error: Qt (>= Qt 3.0.3) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


I installed Qt4-4.3.2 library via Puppy Package Manager but still get the same error. Sad

Config.log file looks very confusing to me, I could not make out of it nothing very enlightening.

Does anybody know what to add?

I am running frugall install of Puppy 4.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 17 Jul 2008, 18:12    Post subject:  

the headers are in the devx_xxx.sfs.

Puppy 4 has Qt 4, which is incompatible with Qt3.
You had to compile it in Puppy 2/3, or request someone to compile it for you.
It then would run, if you install the qt 3.3.8 from the Puppy3 packages in Petget.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Jose

Joined: 23 Apr 2008
Posts: 26

PostPosted: Fri 18 Jul 2008, 08:31    Post subject:  

Mark,

thanks for your advice. I uninstalled Qt4-4.3.2, installed Qt3.3.8 from puppy 3 repository, but still get the same message (all done in Puppy 4 system).

I am not sure if I understand you correctly - what do I have to compile (qt4 or qt3) in Puppy 2/3? By Puppy 2/3 you mean older version of Puppy, right? After I compile it, should I use the file in Puppy 4?

Jose
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 18 Jul 2008, 08:48    Post subject:  

you now installed the LIBs.
They are needed to run a compiled program.

But to compile it, you need the HEADERs.
And those are only in devx_301.sfs, the development addon for Puppy 3.

You would run Puppy 3 with this addon.
Then compile like this:

./configure --prefix=/usr
make
new2dir make install

This hopefully creates a working PET.
You now could install this PET in Puppy 4, because you installed the qt 3 LIBs there already.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Jose

Joined: 23 Apr 2008
Posts: 26

PostPosted: Fri 18 Jul 2008, 17:31    Post subject:  

Mark, I moved forward although just a little bit. I installed puppy 3, qt-3.3.8 and successfully run ./configure --prefix=/usr. Smile But when I tried make, I receive this:

Code:
# make
cd . && /bin/sh /root/qgo/admin/missing --run aclocal-1.6
/root/qgo/admin/missing: line 46: aclocal-1.6: command not found
WARNING: `aclocal-1.6' is needed, and you do not seem to have it handy on your
         system.  You might have modified some files without having the
         proper tools for further handling them.  Check the `README' file,
         it often tells you about the needed prerequirements for installing
         this package.  You may also peek at any GNU archive site, in case
         some other package would contain this missing `aclocal-1.6' program.
make: *** [aclocal.m4] Error 1


Uncle google did not help much, neither did Puppy forum. Sad Can you or anybody else?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0515s ][ Queries: 12 (0.0060s) ][ GZIP on ]