Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 04:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
008 Full Installation- Probleme bei Grub Konfiguration
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
derJack

Joined: 19 Jun 2008
Posts: 10

PostPosted: Thu 19 Jun 2008, 10:54    Post subject:  008 Full Installation- Probleme bei Grub Konfiguration
Subject description: Dualboot mit Vista "überspringt" Grub und läßt nur Vista starten
 

Tag zusammen,

ich weiß "grub" ist kein neues Thema aber ich habe schon einiges ausprobiert und bin nicht weiter gekommen.

Ich habe über den Puppy Installationsmanager Minisys auf einer ext3 Partition installiert und den Grub über diese Routine installiert. Aber beim Booten startet Vista sofort.

Meine Konfiguration sieht wie folgt aus:
IBM X41 (Tablet- wäre cool wenn irgendwann der Stift auch funktionieren würde!) 1,5Mhz Centrino, 1GB RAM, 60SATA
SDA1 Vista
SDA2 Backup NTFS
SDA4 3GB ext3
SDA5 FAT32 Multimedia

Grundstzlich läuft die MuppyMini sehr gut vom USB aber der ragt halt 6cm an der Seite raus und ich habe Bedenken ihn ab zu brechen- ist schließlich ein Notebook. Ein optischen LW ist nicht einegebaut weshalb für mich die HDD Installation Sinn macht.

Meine Grub config unter boot/grub:
# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Thu Jun 19 15:15:55 2008
#
# The backup copy of the MBR for drive '/dev/sda4' is
# here '/boot/grub/mbr.sda.23991'. You can restore it like this.
# dd if=/boot/grub/mbr.sda.23991 of=/dev/sda4 bs=512 count=1
#
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Other bootable partition config begins
title Windows (on /dev/sda1)
rootnoverify (hd0,0)
makeactive
chainloader +1
# Other bootable partition config ends
# Other bootable partition config begins
title Windows (on /dev/sda2)
map (hd0,0) (hd0,1)
map (hd0,1) (hd0,0)
rootnoverify (hd0,1)
makeactive
chainloader +1
# Other bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/sda4)
root (hd0,3)
kernel /boot/vmlinuz root=/dev/sda4 ro vga=normal
# Linux bootable partition config ends
# Other bootable partition config begins
title Windows (on /dev/sda5)
map (hd0,0) (hd0,4)
map (hd0,4) (hd0,0)
rootnoverify (hd0,4)
makeactive
chainloader +1
# Other bootable partition config ends
# Other bootable partition config begins
title Windows (on /dev/mmcblk0p1)
map (hd0) (hd1)
map (hd1) (hd0)
map (hd0,0) (hd1,-1)
map (hd1,-1) (hd0,0)
rootnoverify (hd1,-1)
makeactive
chainloader +1
# Other bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,3)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/sda4)
root (hd0,3)
setup (hd0,3)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3223
Location: Chickasha Oklahoma

PostPosted: Thu 19 Jun 2008, 12:19    Post subject:  

Very Happy Hello, hope the translation works.LOL

@ Es hat den Anschein, dass Sie installiert haben, die Dateien grub in den MBR der sda4, rerun grub-Konfiguration und installieren Sie sie an den Haupt-Partition, sda1, wo Ihre Vista ist.
Ihr Computer erkennt sie dort. hope this helps

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Thu 19 Jun 2008, 13:19    Post subject: Re: 008 Full Installation- Probleme bei Grub Konfiguration
Subject description: Dualboot mit Vista "überspringt" Grub und läßt nur Vista starten
 

derJack wrote:
Aber beim Booten startet Vista sofort.

Ja natürlich Wink

Vorschlag:
Code:
# Start GRUB global section
#timeout 30
(...)

ändern wie:
Code:
# Start GRUB global section
timeout 30
(...)

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
derJack

Joined: 19 Jun 2008
Posts: 10

PostPosted: Fri 20 Jun 2008, 07:00    Post subject: Re: 008 Full Installation- Probleme bei Grub Konfiguration
Subject description: Dualboot mit Vista "überspringt" Grub und läßt nur Vista starten
 

erikson wrote:
derJack wrote:
Aber beim Booten startet Vista sofort.

Ja natürlich Wink

Vorschlag:
Code:
# Start GRUB global section
#timeout 30
(...)

ändern wie:
Code:
# Start GRUB global section
timeout 30
(...)


Tag zusammen,

ich habe die Änderung "#" vor dem time out vorgenommen- allerdings ohne Erfolg.

@puppyluvr: I tried the installation of grub two times. First into the sda4 without changes in the recommendet settings.
The second run was into sda1 into MBR. This should work in my opinion.

I try this again ...
Back to top
View user's profile Send private message 
derJack

Joined: 19 Jun 2008
Posts: 10

PostPosted: Wed 09 Jul 2008, 12:47    Post subject:  

Tag zusammen,

nach diversen Versuchen nun ein Endstand:
Die Grubinstallation funktionierte dann irgendwann doch. Sie ließ sich aber NUR unter der SDA4, sprich der linux Partition installieren. NICHT auf der Vista Partition, wie oben vorgeschlagen.
Installiert habe ich den Grub dann nach Standarteinstellungen aber mit MBR, bw in diesen.

Starten ließ sich Mini Mupy aber dennoch nicht. Habe dann alle Ordner außer Boot (indem ja der Grub ist) gelöscht. Dann "frugal" auf die Linux Partition (ext3)installiert und die Grub Menue list wie angegeben ergänzt.

Ergebnis läuft wie sau (wenn ich das mal so salopp ausdrücken darf).


Thema also gelösst, braucht vielleicht mal jemand.

PS: Ich habe auch eine 1GB Swap Partition erstellt. Wenn ich das richtig bei Muppy verstanden habe dann wird diese normalerweise NICHT benötigt solange der Speicher (also bei mir die ext3) nicht erschöpft ist- ist das korrekt?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 09 Jul 2008, 17:40    Post subject:  

Quote:
PS: Ich habe auch eine 1GB Swap Partition erstellt. Wenn ich das richtig bei Muppy verstanden habe dann wird diese normalerweise NICHT benötigt solange der Speicher (also bei mir die ext3) nicht erschöpft ist- ist das korrekt?


Nein, mit dem ext3 hat es nix zu tun.
swap vergrössert das Ram, indem es selten benötigte Dinge auf die Festplatte auslagert.
Swap sollte i.d.R. 256 MB sein.
Grösser kann Muppy verlangsamen, jedenfalls wenn man das "Standard" Iso verwendet (dann wird das komplette msy_083.sfs geswapt).

Ob überhaupt swap nötig ist:
ab 1 Gigabyte Ram sicher nicht, ausser man arbeitet z.B. mit grossen Bildern in Gimp.
Wenn der Rechner plötzlich sehr träge reagiert oder einfriert, kann eine 256 MB Swap-Partition Wunder wirken.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
derJack

Joined: 19 Jun 2008
Posts: 10

PostPosted: Wed 09 Jul 2008, 17:56    Post subject:  

Tag zusammen,

ich habe das Mini mit 130MB und Open Office und 1GB RAM.

Werde SWAP dann mal verkleinern.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0739s ][ Queries: 12 (0.0060s) ][ GZIP on ]