Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 20:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Firefox 3.6, 3.5.6 and Firefox 2.0.0.20 and Firefox 1.5.0.12
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 13 Posts_count   Goto page: 1, 2, 3, ..., 11, 12, 13 Next
Author Message
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 17 Jun 2008, 17:09    Post_subject:  Firefox 3.6, 3.5.6 and Firefox 2.0.0.20 and Firefox 1.5.0.12
Sub_title: Web Browser
 

Firefox 3.6:
Note: Firefox replaces defaultbrowser (internet icon on desktop) with firefox. (firefox will update to the latest version automatically.) (Prefetch-next disabled for security, and fonts made bigger for webpage and menus.)

firefox-3.6.pet
md5sum

-----------------------

Firefox 3.5:
Note: Firefox replaces defaultbrowser (internet icon on desktop) with firefox. (firefox will update to the latest version automatically.) (Prefetch-next disabled for security, and fonts made bigger for webpage and menus.)

firefox-3.5.6.pet
md5sum

-------------------------

Firefox 2.xx:
Note: Firefox replaces defaultbrowser (internet icon on desktop) with firefox, also has flash 9 crash fix. (firefox will update to the latest version automatically.) (Prefetch-next disabled for security, and fonts made bigger for webpage and menus.)

firefox-2.0.0.20.pet
md5sum

----------------------------

Firefox 1.5.xx:
Note: Firefox replaces defaultbrowser (internet icon on desktop) with firefox. (firefox will update to the latest version automatically.) (Prefetch-next disabled for security, and fonts made bigger for webpage and menus.)

firefox-1.5.0.12.pet
md5sum

----------------------------

Java for your firefox.
Flash Player for your firefox.

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.

Edited_times_total
Back to top
View user's profile Send_private_message 
alcy

Joined: 04 May 2008
Posts: 144

PostPosted: Tue 17 Jun 2008, 17:29    Post_subject:  

Sorry for sounding stupid , but why is a .pet required ? It works just after extracting the files .
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 17 Jun 2008, 18:10    Post_subject:  

a pet is required for other users who like to have is simple, usually new users, then we usually repackage it with java, and flash, and then both combined, because java is tricky on puppy and most can properly install it by themselves.

Wolf Pup you bet me to the draw, I was packaging it also, but with the other options I usually do, like make it default browser, and a Icon change. Oh well maybe I'll just make a quick bling fix.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 17 Jun 2008, 18:31    Post_subject:  

Hey ttuuxxx, firefox is made the defaultbrowser, i kinda forgot to put the notes on top. Embarassed
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 17 Jun 2008, 18:37    Post_subject:  

Wolf Pup wrote:
Hey ttuuxxx, firefox is made the defaultbrowser, i kinda forgot to put the notes on top. Embarassed


Yes I downloaded it and it is default , excellent job! Smile
here's the black icon set I usually use.
ttuuxxx

ps. I also was packaging all the missing gnome libs stuff but it was over 5MB and I gave up, it was endless.
firefoxblack.pet
Description 
pet

 Download 
Filename  firefoxblack.pet 
Filesize  81.4 KB 
Downloaded  3225 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Tue 17 Jun 2008, 18:42    Post_subject:  

Just curious, What is the Flash 9 "fix". I was using RC2 and it crashed alot. I was kind of disappointed that after downloading the official Mozilla version that the Final and the RC2 versions were the same (md5sums matched).

JB
Back to top
View user's profile Send_private_message YIM 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 17 Jun 2008, 18:49    Post_subject:  

JB4x4 wrote:
Just curious, What is the Flash 9 "fix". I was using RC2 and it crashed alot. I was kind of disappointed that after downloading the official Mozilla version that the Final and the RC2 versions were the same (md5sums matched).

JB


Just download the latest version
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=shockwaveFlash

extract it and place it in /root/.mozilla/plugins
if you have any other flash files in there delete them
if you don't have that folder make it
.mozilla is a hidden folder
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
stevenbinion


Joined: 24 Aug 2007
Posts: 180
Location: Pittsburgh, PA - United States

PostPosted: Tue 17 Jun 2008, 19:12    Post_subject:  

Nice work as always wolf_pup. Smile
_________________
[Home of Wolf Pup Linux]
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
ICQ 
stevenbinion


Joined: 24 Aug 2007
Posts: 180
Location: Pittsburgh, PA - United States

PostPosted: Tue 17 Jun 2008, 19:25    Post_subject:  

I just wanted to update you on the firefox-3.0.pet it works and thats what counts, and it's just some easy fixes. but after installing on a fresh puppy setup there were the following missing dependenices.

Code:
These dependencies required by firefox-3.0 package are missing:
File /usr/lib/firefox/firefox-bin has these missing library files:
 libjemalloc.so libxul.so
File /usr/lib/firefox/plugins/libnullplugin.so has these missing library files:
 libxul.so
File /usr/lib/firefox/libssl3.so has these missing library files:
 libnssutil3.so
File /usr/lib/firefox/libnssdbm3.so has these missing library files:
 libnssutil3.so
File /usr/lib/firefox/libfreebl3.so has these missing library files:
 libnssutil3.so
File /usr/lib/firefox/libxpcom.so has these missing library files:
 libxul.so
File /usr/lib/firefox/libnss3.so has these missing library files:
 libnssutil3.so
File /usr/lib/firefox/components/libdbusservice.so has these missing library files:
 libdbus-glib-1.so.2 libdbus-1.so.3
File /usr/lib/firefox/components/libbrowsercomps.so has these missing library files:
 libxul.so
File /usr/lib/firefox/components/libnkgnomevfs.so has these missing library files:
 libgnomevfs-2.so.0 libgconf-2.so.4 libORBit-2.so.0
File /usr/lib/firefox/components/libmozgnome.so has these missing library files:
 libgconf-2.so.4 libORBit-2.so.0 libgnomevfs-2.so.0 libgnome-2.so.0 libbonobo-2.so.0 libbonobo-activation.so.4
File /usr/lib/firefox/libsoftokn3.so has these missing library files:
 libnssutil3.so libsqlite3.so
File /usr/lib/firefox/libxul.so has these missing library files:
 libsqlite3.so libnssutil3.so
File /usr/lib/firefox/libsmime3.so has these missing library files:
 libnssutil3.so
File /usr/lib/firefox/crashreporter has these missing library files:
 libgconf-2.so.4 libORBit-2.so.0

The PETget package manager does not know what package/s has/have these libraries.


To fix this I simply did the following.
Code:
# cd /usr/lib/
# ln -s firefox/lib* .


I re-tested the dependencies and got the following:
Code:
These dependencies required by firefox-3.0 package are missing:
File /usr/lib/firefox/components/libdbusservice.so has these missing library files:
 libdbus-glib-1.so.2 libdbus-1.so.3
File /usr/lib/firefox/components/libnkgnomevfs.so has these missing library files:
 libgnomevfs-2.so.0 libgconf-2.so.4 libORBit-2.so.0
File /usr/lib/firefox/components/libmozgnome.so has these missing library files:
 libgconf-2.so.4 libORBit-2.so.0 libgnomevfs-2.so.0 libgnome-2.so.0 libbonobo-2.so.0 libbonobo-activation.so.4
File /usr/lib/firefox/crashreporter has these missing library files:
 libgconf-2.so.4 libORBit-2.so.0

The PETget package manager does not know what package/s has/have these libraries.


I'm going to presume these are the missing libs ttuuxxx spoke of. I have most of these, but there are dependencies I know are needed. so I'll need to take some time on a fix.

_________________
[Home of Wolf Pup Linux]
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
ICQ 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 17 Jun 2008, 19:44    Post_subject:  

Very Happy
Thanks for providing Firefox 3 on Firefox download day - been using on Dingo - Puppy 4
http://www.mozilla.com/en-US/firefox/?p=downloadday

You are illustrating how Puppy is on the cutting edge of the very best that open source has to offer . . .

We started using the term organic to describe Puppy
Mozilla is now using the term too
http://www.mozilla.com/en-US/firefox/organic/

_________________
Puppy WIKI

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
koolie

Joined: 12 Mar 2007
Posts: 556

PostPosted: Tue 17 Jun 2008, 21:43    Post_subject:  

FWIW

Firefox worked in Puppy 2.17.1 up to v3.beta3.
Then Mozilla changed the GTK+ requirement to =>2.10.

Later releases, including todays release, work without error on Puppy 4.00 which has GTK+ 2.12. I dont know about Puppy3.
Puppy 2.17.1 only had GTK+ 2.8.
Back to top
View user's profile Send_private_message 
edoc


Joined: 07 Aug 2005
Posts: 4390
Location: Southeast Georgia, USA

PostPosted: Wed 18 Jun 2008, 00:07    Post_subject:  

Just read this review of Firefox 3 and came here to ask when it might be ready for Puppy and y'all were way ahead of the curve ... again! Congrats!

I am, of course, a little confused by this thread and maybe there is a helpful piece of data that should accompany all posts to this Forum - the relevant Version Number of the Puppy being discussed.

There are three conflicting/confusing assertions being made in the first page of this thread:

1. A PET is now available for Puppy (version info missing) that works.

2. The PET sorta works and sorta doesn't due to missing dependencies, lots of them.

3. The PET works in Version 4 but it is unknown if it works in any other version.

Should Firefox 3 for Puppy be considered in Alpha or Beta vs Release status?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send_private_message Visit_website 
puppyluvr


Joined: 06 Jan 2008
Posts: 3227
Location: Chickasha Oklahoma

PostPosted: Wed 18 Jun 2008, 00:19    Post_subject:  

Very Happy Hello Very Happy

Have tested Firefox 3 on Puppy 2.17 / 3.00 /3.01 / 398
seems to work well on all, even missing lots of dependancies

Oh, and the new Opera 9,5 works great too...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 
shankargopal

Joined: 03 Dec 2005
Posts: 295

PostPosted: Wed 18 Jun 2008, 01:06    Post_subject:  

Hi

Any chance of an SFS like the one that stevebinion made earlier with FF3 beta 5 (has Java and Flash as part of it)? I use that SFS right now and it's great. Would love it if someone could make the same for FF3 Final. I would do it myself but time very very short right now... Smile
Back to top
View user's profile Send_private_message 
stevenbinion


Joined: 24 Aug 2007
Posts: 180
Location: Pittsburgh, PA - United States

PostPosted: Wed 18 Jun 2008, 07:32    Post_subject:  

shankargopal wrote:
Hi

Any chance of an SFS like the one that stevebinion made earlier with FF3 beta 5 (has Java and Flash as part of it)? I use that SFS right now and it's great. Would love it if someone could make the same for FF3 Final. I would do it myself but time very very short right now... Smile


Actually, I can release an sfs for firefox3. I'll get that posted here later today.

_________________
[Home of Wolf Pup Linux]
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
ICQ 
Display_posts:   Sort by:   
Page 1 of 13 Posts_count   Goto page: 1, 2, 3, ..., 11, 12, 13 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1051s ][ Queries: 13 (0.0127s) ][ GZIP on ]