Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 00:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
création de pet
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
limax

Joined: 30 Mar 2008
Posts: 21

PostPosted: Mon 05 May 2008, 14:58    Post subject:  création de pet  

bonjour à tous

Donc je débute réellement avec toutou linux. Je souhaite disposer de vlc avec certain supports (voir voir la tv sur la freebox notamment ) et j'essaye de compiler vlc (aïe c'est pas le plus simple).

Il y a donc tout un tas de paquets à compiler et installer.
Plustôt que de les installer avec # make install je me demande s'il n'y a pas une manière propre de créer un pet et ainsi facilité la désinstallation ou l'upgrad.

deuxième question (qui n'a rien à voir). Ils sont où les log de X ? Àprès m'être délogguer startx ne veut rien savoir et je ne trouve pas les log de X
Quote:
# ls /var/log/
cups messages samba setup sh-httpd.log wtmp

Finalement j'ai pu repartir X sans réellement comprendre.

Merci par avance.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 05 May 2008, 18:22    Post subject:  

1.)
new2dir make install
Cela va créer un .pet.

2.)
/var/log/Xorg.0.log
si tu utilise Xorg, et pas Xvesa.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Tue 06 May 2008, 10:56    Post subject:  

Bonjour Limax,

J'ai des conseils à te demander pour l'utilisation de VLC (qui fonctionne mieux que GXINE sur ma machine, Gxine ne fait que geler).

J'ai installé la version 0.86 :

1 - Est ce que l'on peut la mettre par défaut pour l'ouverture des vidéos ?
2 - Est que l'on peut franchiser la version en rajoutant un fichier langue ?
3 - Est ce que tu as désinstallé gxine (j'ai lu quelque part qu'il a des bibliothéques communes nécessaires au fonctionnement de Toutou).

Si tu as un minute pour me répondre, ce serait avec plaisir que je pourrais te lire.
Wink

+++


Prof
Back to top
View user's profile Send private message 
limax

Joined: 30 Mar 2008
Posts: 21

PostPosted: Tue 06 May 2008, 16:07    Post subject:  

@ mu Merci mu effectivement le fichier de log de X ce trouve là.
À dire j'y accédé par chroot depuis ma debian et lorsque toutou est arrété il n'y plus de de fichier /var/log/Xorg.0.log

@prof bonjour prof

tu l'as pris où le fichier vlc ? parceque j'ai une tonne de chose à compiler avec.
J'en suis à ffmpeg, j'ai bien trouvé un pet pour ffmpeg mais lors de la compilation de vlc il cherche un fichier ffmpeg.h qui est introuvable.

As tu installé beaucoup de .pet en même temps que vlc?

Pour l'ouverture par défaut des video par vlc tu fais un clic droit sur la video -> fixer l'action d'exécution -> et tu mets vlc
Il faut le faire pour tous les types video (mpg, mpeg avi ogg etc........)

à +
Back to top
View user's profile Send private message 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Tue 06 May 2008, 18:54    Post subject:  

Back to top
View user's profile Send private message 
limax

Joined: 30 Mar 2008
Posts: 21

PostPosted: Wed 07 May 2008, 07:02    Post subject:  

Prof wrote:
J'avais bien compris pour l'ouverture par défaut de passer par fixer l'action d'exécution mais cela ne fait qu'ouvrir VLC et pas démarrer la lecture de la vidéo, d'où ma question ?
Peut être, simplement un problème de configuration de VLC ?

Pour lire une vidéo, il faut que j'ouvre VLC et que j'aille chercher un fichier par Quick Open File par exemple et hop la vidéo démarre sans souci.
As tu bien mis: vlc "$@"

Je vais essayer ton lien pour vlc et voir si je peux avoir la tv par ma box.
Back to top
View user's profile Send private message 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Wed 07 May 2008, 08:38    Post subject:  

Re,

Il me semble qu'il existe des plugins pour VLC pour voir la TV mais je sais plus où j'ai vu cela. Je suis pas trop concerné par ce genre de chose vu que je fonctionne encore en RTC (l'ADSL n'existe pas chez nous). Je te dis, j'ai fait tellement de sites pour trouver une librairie qui me manque (libvga.so.1) pour faire fonctionner Supertux que je sais plus à force ce que j'ai trouvé ou pas.
Je vais regarder dans mes liens si je trouve quelque chose. Je te tiens au courant.

Pour vlc "$@", la commande shell y était d'office.
Je pense que c'est plus un problème de VLC que de Toutou. Le lecteur démarre très bien mais il ne lit pas la vidéo et en cliquant sur lecture il ouvre une fenêtre pour rechercher un fichier à lire.
Enfin j'en sais rien, je vais chercher encore.

++

Prof
Back to top
View user's profile Send private message 
goju

Joined: 17 Mar 2008
Posts: 29
Location: sarthe, france

PostPosted: Mon 26 May 2008, 12:47    Post subject:  

J'ai eu un problème similaire avec XMMS avec thunar

la commande passer a XMMS étais incorrecte, il falais que je précise %f pour que cela fonctionne. Je connais pas bien ROX (j'utilise XFCE et Thunar) mais c'est peut être un problème similaire. Quand vous avez fixer l'action d'exécution, il n'y avais pas des marqueur générique comme %f ou %D que l'on pouvais passer en même temps que la commande ?
Back to top
View user's profile Send private message 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Wed 28 May 2008, 04:56    Post subject:  

Bonjour,


Pour Limax, j'ai essayé une version de puppy qui s'appelle TEENpup, on la trouve assez facilement sur le net, dedans il y a un soft qui permet je pense de regarder la TV, il s'appelle TV y a une icône sur le bureau. Tu devrais peut être regarder si ça peut pas te dépanner.

Pour Goju, je pense que tu as raison cela doit être un problème similaire. Je vais essayer les %f ou %D mais pour le moment je suis dans les choux suite à une mise à jour qui a mal tournée, j'ai du réinstaller ma distro et j'ai pas encore eu le temps de remettre VLC.
Dés que je peux je fais des essais et je post.
Merci de votre réponse.


+++


Prof
Back to top
View user's profile Send private message 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Thu 29 May 2008, 16:18    Post subject:  

Bonsoir,


J'ai effectué plusieurs essais pour VLC.

Donc en fixant l'action d'exécution pour un fichier comme par exemple un avi, j'ai d'office le "$@" qui fait bien lancer VLC mais en fait la lecture ne démarre pas automatiquement et si je clique sur play, VLC me propose de chercher le fichier à lire par l'exploration.

J'ai tout essayé run-vlc "$@", VLC "$@", %f, %D et je crois de plus en plus à un problème de paramétrage de VLC qu'a un problème du à ROX.

Mais bon, faut trouver un spécialiste de VLC dans la salle.
Ce qui m'étonne c'est que LIMAX ne rencontre pas de difficultés apparement.

Je sais pas bien ce qu'il faut faire.


Bonne soirée.


++++


Prof
Back to top
View user's profile Send private message 
goju

Joined: 17 Mar 2008
Posts: 29
Location: sarthe, france

PostPosted: Tue 03 Jun 2008, 12:38    Post subject:  

Ne disposent pas moi même de carter tuner tv ou autre, je n'ai pas l'utiliter d'utiliser vlc (de plus, je préfaire mplayer)

si non, vous avez essayez de lancer le dit fichier avec VLC depuis la ligne de commande ? (en générale : vlc CheminDuFichier) Si sa se lance, c'est plus un problème de rox, si sa le lance pas, c'est VLC qui ne fonctionne pas

en effet, je suppose que rox, comme thunar, se contente simplement de démarrer le logiciel comme on le ferais a la ligne de commande, donc si cela ne fonctionne pas le problème viens de VLC, tout simplement
Back to top
View user's profile Send private message 
Prof

Joined: 31 Mar 2008
Posts: 103
Location: Near Lyon (Ain) FRANCE

PostPosted: Wed 04 Jun 2008, 09:53    Post subject:  

Bonjour,


Je n'ai pas moi non plus de carte tuner ou TV mais Gxine plante lamentablement avec ma config lorsque je veux regarder une vidéo.
J'ai donc essayé mplayer et j'ai des trucs bizarre comme des lignes rouges sur l'écran. Seul VLC fonctionne correctement.

En ligne de commande je démarre VLC mais il faut aussi rechercher le fichier à lire pour voir la vidéo.
Il y a peut une commande du type run-VLC (nom du fichier à lire) mais je ne suis pas un expert en ligne de commande.

Je suis toujours dans l'idée mais peut être que je me trompe du fait que le problème correspond à une mauvaise configuration de VLC mais là aussi je peux me tromper. je vais chercher sur le net si je trouve de la doc.

Merci de votre réponse.

++++


Prof
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0870s ][ Queries: 12 (0.0176s) ][ GZIP on ]