Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 12:51
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Hilfe mein Muppy läuft weg !!!
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Nightowl59


Joined: 15 May 2007
Posts: 31
Location: Eppstein, Hessen, Germany

PostPosted: Sun 01 Jun 2008, 06:32    Post subject:  Hilfe mein Muppy läuft weg !!!  

Hallo Muppy/Puppy Fans mein Muppy 008 ist weggelaufen !!

Im Ernst Crying or Very sad

Nachdem ich von MU den Tip mit der IRQPOLL Startoption bekommen habe, die auch einwandfrei funktioniert, habe ich für meinen Bekannten den Panasonic CF27 mit Dualbootoption Windows2000/Muppy008 fertiggemacht. Nachdem ich Muppy gut 2 Stunden installiert (Frugalinstallation), umkonfiguriert (Opera 9.27 dtsch, MPlayer weil GXine mit Fehler aussteigt, warum?) den Notebook 3 mal rebootet habe, lief ALLES. Mit WLAN, Sound usw. Das letzte was ich wohl gemacht habe ist 2 Puppy-Wallpapers (space und cosmoginy)aus dem WinNT-Verzeichnis nach usr/share/backgrounds zu KOPIEREN. Habe alles gespeichert und sah alles super aus. Als ich bei meinem Bekannten ankam und ganz stolz Muppy008 vorzeigen wollte sagte Grub: No such files. Unter Windows nachgeschaut und da war das komplette Standard puppy080-Verzeichnis weg !!! Einfach so. Wie geht das denn??? Habe schon erlebt das kopieren von Muppy nach Windoof wohl nicht mehr so einfach funktioniert. Muppy tut so als würde es kopieren aber die Files sind unter Windows nicht da! Aber gleich das ganze Verzeichnis löschen. Hat jemand eine Idee was da passieren könnte, oder hat jemand die gleichen Erfahrungen gemacht???

Gruß Nightowl

P.S. Win2000 läuft unter FAT32 weil der Rechner nur ein MPentium 300Mhz ist.
Back to top
View user's profile Send private message 
egar

Joined: 29 Apr 2008
Posts: 8

PostPosted: Sun 01 Jun 2008, 18:39    Post subject: muppy mit füsse...  

hi,
also es ist so, dass du einen verspäteten aprilscherz machst???
ok, welpen habe vier pfoten und auch füsse. stimmt. Wink
mehr fällt mir dazu erst mal nicht ein.
denke aber, die lösung würde die gemeinde schon interessieren.

MfG egar
Back to top
View user's profile Send private message 
srbo

Joined: 16 Nov 2007
Posts: 28
Location: Melle, Germany

PostPosted: Sun 01 Jun 2008, 21:44    Post subject: Hilfe mein Muppy läuft weg !!!  

Hallo Nightowl59,
einen ähnlichen Fall hatte es mit Puppy 3.0 bei uns vor einiger Zeit gegeben. Damalige Ursache war allerdings nicht in Puppy zu finden, dass Filesystem wies durch eine nicht ordnungsgemässe Beendigung von Windows 98 (Fat32) einen inkonsistenten Zustand auf. Dieses Fehlverhalten war sehr schwer zu reproduzieren, in einem von 10 Fällen konnten wir einen Datenverlust nachweisen.

Daher meine erste Bitte an Dich: Überprüfe in Windows 2000 das Dateisystem und poste das Ergebnis.

Weiterhin sind folgende Angaben wichtig:
Welche Muppy-Fassung verwendest Du ?
(Release-Stand / Sprache / Mini / Std.)
Größe des Hauptspeichers
Festplattentyp

Bei einem (NoName) Notebook konnten wir folgendes "Phänomen" feststellen:
Wurde über einen Softlink einer frugalen Muppy/Puppy Installation auf lokale Festplatten zugegriffen / geschrieben (Reiserfs / Fat32), so verhielt sich beim nächsten Boot Grub äusserst merkwürdig. Bis Grub seinen Dienst aufnahm vergingen mitunter mehrere Minuten, gelegentlich half nur mehrmaliges Abschalten und wieder Einschalten des Notebooks um Grub zum Arbeiten zu bewegen. Dieses Problem haben wir bis heute nicht lösen können, kommt aber nur auf diesem einen Notebook vor.

Obwohl MINISYS-Muppy als OpenSource Betriebssystem kostenfrei verfügbar ist, führen wir dennoch selbstverständlich ein QM Verfahren durch. Dabei wäre ein solch schwerer, wie von Dir beschriebener Bug, sofern er in Muppy seinen Ursprung hätte, höchstwahrscheinlich aufgefallen und vor Freigabe gefixet worden. Will damit sagen, dass wir Deine Meldung selbstverständlich als sehr ernst einstufen und entsprechend behandeln werden.

Gruß
Stefan
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 03 Jun 2008, 04:52    Post subject:  

Hallo,
Ich selbst hatte solch einen Fehler bislang noch nicht selbst, und kann daher nur vermuten.
Eventuell wurde Win2000 nicht sauber heruntergefahren.
Dann wurde Muppy installiert.

Beim nächsten Start von Win2000 hat dieses ein Backup der Partitionstabelle verwendet, mit den alten Verzeichniseinträgen.
Windows nutzt intern 3 verschiedene Tabellen.

Ich würde empfehlen, sicherzustellen, daß Win sauber runterfährt, bevor ein weiteres Systemhinzugefügt wird.
Wurde Muppy dann installiert, unbedingt den Muppy-Ordner sichern, auf CD oder USB-Stick, falls eine andere Ursache vorliegt, und das Problem wiederholt auftritt.
Dann läßt es sich im Falle eines Verlustes durch einfaches kopieren wieder restaurieren.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Nightowl59


Joined: 15 May 2007
Posts: 31
Location: Eppstein, Hessen, Germany

PostPosted: Wed 04 Jun 2008, 04:46    Post subject:  

Hallo,

ich glaube ich weiß jetzt wo mein Muppy hingelaufen ist! Wink Idea

Marks Hinweis mit den 3 Dateitabellen (Masterfiletables) unter Windoof hat mich darauf gebracht.

PC-Besitzer mit alten 366Mhz-Laptops, so wie ich, sind ja ungeduldig und faule Hunde (das mit dem Puppy hat sich bei mir persönlich erledigt!) Laughing

Also habe ich den Laptop unter Win2000 in den "sauberen" Ruhezustand gebracht. Was ich nicht bedacht habe, Windows legt wohl eine Kopie des MFT (Masterfiletables), zumindest aber der Verzeichnisstruktur, mit in die Savedatei. Nachdem ich jetzt Muppy installiert hatte, hat ja erst mal alles funktioniert, also booten, konfigurieren, WLAN, also alles. Wenn man jetzt unter Grub wieder Windows aktiviert und es aus dem Dornröschenschlaf erwacht, kopiert es "seinen" MFT wieder an den Platz und stellt die nach "seiner Meinung" richtige Verzeichnisstruktur wieder her. Es gibt jetzt aber zumindest 2 MFT-Dateien und wen diese unterschiedlich sind (einmal die von der Muppyinstallation geänderte und einmal die von Windoof zurückkopierte) wird es inkonsistent Crying or Very sad

Ich konnte mir nämlich nicht erklären warum auf meinem Dell CPiA366 Windows2000 läuft, meine Frugal-Muppyinstallation (Muppy 008-de) und die Puppy 4.0 NOP einfach verschwindet. Ich bekam von Grub die Meldung das unter Puppy 4.0 NOP das Filesystem inconsistent sei.
Habe Muppy008 gestartet (lief und läuft einwandfrei auf diesem NB, scheinbar hatte ich da Windows vor der Installation ganz beendet) und es gab den Ordner puppy400 mit einem gelben Dreieck! Nochmal Windows erweckt und der puppy400-Ordner war weg (samt msy_save.2fs auf C:\)!!

Also der "Schuldige" ist also der Ruhezustand von Win2000 (oder der DAU der vor dem notebook saß Laughing) oder wahrscheinlich auch WinXP, denn da gibt es den Ruhezustand auch. Die Puppy/Muppy-Version ist wohl nicht entscheidend.

Habe folgendes mittlerweile ausprobiert, was scheinbar auch funktioniert:

Entweder, Windoof sauber beenden (kein Ruhezustand) ist die allerbeste Möglichkeit,
oder wenn bekannt das zukünftige Muppy/Puppy-Verzeichnis unter Windows erstellen. Habe es mit Muppy-Mini-008.3 probiert und es geht. Habe unter Windows das Verzeichnis C:\puppy083 erstellt, dann Muppy 008.3 installiert und es läuft jetzt alles. Win2000, Muppy 008-de und Muppy-Mini-008.3 wieder friedlich vereint als wäre nichts geschehen Wink

Gruss Nightowl
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0587s ][ Queries: 12 (0.0036s) ][ GZIP on ]