Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 25 May 2015, 01:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 08 Dec 2007
Posts: 412

PostPosted: Fri 23 May 2008, 22:34    Post_subject:  xf-prot-SOLVED
Sub_title: Virus Scanner

According to the Puppy Manual, we have a virus scanner at our disposal. I looked at my Puppy 3.01 disc and I have xf-prot under my utility menu. So I started it, it gives me a warning that I am running as root. I click OK. Then I get a window pop up saying

Unable to stat
no such file or directory

I click the OK button and get:


So, being in the position as are a lot of people I imagine, and that being I know someone dead in the water because their windows machine crashed and they want to know if they have a virus because windows won't load up, or maybe they have a worm but they can't use their packaged protection software because they are dead in the water, I have been looking for a linux distro with virus and worm scanners. I've downloaded some other distros and am currently running the distro std using the virus scan program ClamScan on one of the windows machines here, but I would rather have a Puppy security disc. I mean after all, Puppy does everything else, why not a
white-hat security and vulnerability disc? But I digress. Anybody know what I should do to get xf-prot to work like the manual says?

Back to top
View user's profile Send_private_message 

Joined: 20 Jan 2006
Posts: 6698
Location: lisbon

PostPosted: Sat 24 May 2008, 04:47    Post_subject:  


I just downloaded the pup3 xf-prot package, rebooted into pup3.01, installed it, clicked the OK for license, then tried, unsuccessfully, to run a scan. Very quickly a console window pops up and, after doing this several times, I could see it was telling me the virus definitions were out of date. Xf-prot has an update button, but as I haven't set up that pup for any net access, that was as far as my experimentation got. It sounds like you're not even getting this far. Did xf-prot come with your version of pup3.01? Is it even installed? Maybe you need to download the xf-prot package from ibiblio? You could also look at donwloading & installing the free version of Avast.
Back to top
View user's profile Send_private_message 

Joined: 08 Jul 2006
Posts: 2291
Location: Winsted, CT - USA

PostPosted: Sat 24 May 2008, 11:33    Post_subject:  

I downloaded and compiled f-prot from source with Puppy v2.12. Though command line only, it works well, so perhaps the reported problem lies in the GUI implimentation thereof ...
hangout: ##b0rked on irc.freenode.net
diversion: http://alienjeff.net - visit The Fringe
quote: "The foundation of authority is based upon the consent of the people." - Thomas Hooker

Back to top
View user's profile Send_private_message 

Joined: 11 Nov 2005
Posts: 1475
Location: florida

PostPosted: Sat 24 May 2008, 21:23    Post_subject:  

I made a fprot package with a GUI a year or so ago. It's here:


Just tried it in Puppy 4.0. Works fine. After installing and restarting JWM, you'll find it under Utility in the menu. When you first run the GUI click on update to download the virus def files. Then scan what you want.
Back to top
View user's profile Send_private_message 

Joined: 08 Dec 2007
Posts: 412

PostPosted: Sat 24 May 2008, 23:47    Post_subject:  

I found where to download it "from the forum" and went ahead and downloaded it, ran it and rebooted. I now have two menu listings of XF-Prot. I clicked on the newly added one and ran the program without a hitch. I don't know what or why but it now works. I would swear that it came with the iso I downloaded of 3.01 but it just didn't work. So thanks for the affirmation guys.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0510s ][ Queries: 12 (0.0040s) ][ GZIP on ]