Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 11:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Bootproblem mit Mini-Muppy
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [21 Posts]   Goto page: Previous 1, 2
Author Message
Broadway

Joined: 08 Mar 2008
Posts: 21

PostPosted: Mon 07 Apr 2008, 12:09    Post subject:  

urban soul wrote:
Im Terminal
Code:
alsaconf
eingeben. Dort kannst du ALSA konfigurieren (also welche Karte default ist).


Vielen Dank für den Tipp, aber jetzt bin ich wieder am Ausgangspunkt meines Problems:

Für die aktuelle Sitzung ist die USB-Karte dann "default". Nach dem nächsten Booten ist der Onboard-Chip allerdings wieder "default".

Somit muß ich nach jedem Booten ALSACONF ausführen, um die USB-Karte einzubinden.

Irgendwie muß man es doch Muppy/Puppy beibringen können, die USB-Karte statt des Onboard-Chips als "Default" einzubinden, sprich die USB-Karte als "0" und die Onboard-Karte als "1".
Back to top
View user's profile Send private message 
urban soul


Joined: 05 Mar 2008
Posts: 276
Location: "Killing a nerd is not as much fun as ist sounds" B.Simpson

PostPosted: Sat 12 Apr 2008, 21:35    Post subject:  

oje, jetzt weiss ich auch nicht mehr weiter. Natürlich geht das, aber mit alsa's config-dateien kenn ich mich zu wenig aus. Wenn jemand weiter weiss (MU?) bitte kurz den richtigen Tipp geben. Oder im englichen Forum fragen.
Back to top
View user's profile Send private message Visit poster's website 
Broadway

Joined: 08 Mar 2008
Posts: 21

PostPosted: Wed 16 Apr 2008, 10:00    Post subject:  

urban soul wrote:
Wenn jemand weiter weiss (MU?) bitte kurz den richtigen Tipp geben.


Darüber würde ich mich freuen.

urban soul wrote:
Oder im englichen Forum fragen.


Hier im englischen Hardware-Audio-Forum warte ich leider seit dem 8.3.08 vergeblich auf Hilfe.

Vielen Dank, Urban, für Deine Hilfe bis hierhin.
Back to top
View user's profile Send private message 
Broadway

Joined: 08 Mar 2008
Posts: 21

PostPosted: Sun 20 Apr 2008, 13:27    Post subject:  

So, nach weiterem Herumprobieren habe ich eine Lösung gefunden. Ob es eine "saubere Lösung ist" weiß ich nicht, aber ich erreiche mein Ziel.

Ich habe die modprobe.conf von den Sound-Einträgen gereinigt und dann wie folgt manuell ergänzt:

alias snd-card-1 snd-via82xx
alias sound-slot-1 snd-via82xx
options snd-via82xx index=1

alias sound-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio
options snd-usb-audio index=0

#alias snd-card-0 snd-via82xx
#alias sound-slot-0 snd-via82xx

Auf die Zeilen "options... index=" bin ich in einem anderen Forum gestoßen. Die beiden Zeilen nach den # wurden nach dem Booten automatisch hinzugefügt. Die # habe ich dann davor gesetzt. Jetzt läuft es. Die USB-Karte ist default nach jedem Booten - und nicht mehr der Onboard-Soundchip.

Falls es auch eine Lösung über ALSA gibt, bin ich dafür nach wie vor dankbar.
Back to top
View user's profile Send private message 
urban soul


Joined: 05 Mar 2008
Posts: 276
Location: "Killing a nerd is not as much fun as ist sounds" B.Simpson

PostPosted: Sat 26 Apr 2008, 17:54    Post subject:  

Klar ist die Lösung 'sauber'. Ab und zu wird modprobe.conf halt vom 'System' oder anderen Programmen überschrieben. Es ist wohl so gedacht, dass das Abspielprogramm die Soundkarte anwählt. (z.b. Audacity kann das...)

Zumindest in Puppy gibt es keine Möglichkeit die Default-Soundkarte einzustellen. Man müsste sich mal abgucken wie diese Problematik in grösseren Distributionen gehandhabt wird. Schliesslich konnte man ja schon in W95 einstellen, worüber die BOINGS und BÄNGS ausgegeben werden.

Ich denke JACK ist da die Lösung. Das gbts übrigens als dotpup. JACK ist im wesentlichen eine virtuelle Patchbay mit einem Audioserver, damit mehrere Quellen auf den selben Ausgang zugreifen können...

Urban
Back to top
View user's profile Send private message Visit poster's website 
Broadway

Joined: 08 Mar 2008
Posts: 21

PostPosted: Sun 27 Apr 2008, 10:44    Post subject:  

urban soul wrote:
Klar ist die Lösung 'sauber'.

Prima, danke für die Bestätigung.

urban soul wrote:
Man müsste sich mal abgucken wie diese Problematik in grösseren Distributionen gehandhabt wird.

Den Hinweis zu der "options=..."-Zeile habe ich aus einem ubuntu-Forum.

urban soul wrote:
Ich denke JACK ist da die Lösung. Das gbts übrigens als dotpup. JACK ist im wesentlichen eine virtuelle Patchbay mit einem Audioserver, damit mehrere Quellen auf den selben Ausgang zugreifen können.

Ah, gut, dann werde ich mich als nächstes mal damit beschäftigen. Danke!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [21 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0553s ][ Queries: 12 (0.0039s) ][ GZIP on ]