Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 11:18
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
NIC not working in MINISYS MUPPY008 full HD install!!!!!!!!!
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
taichifu

Joined: 08 Dec 2006
Posts: 48

PostPosted: Thu 27 Dec 2007, 06:55    Post_subject:  NIC not working in MINISYS MUPPY008 full HD install!!!!!!!!!  

Hi

Just downloaded Minisys Muppy008 run fine from livecd, can access internet. But on full HD install can't connect to internet. Netwotk wizard can't see my network card (VIA Rhine), tried to install it manually without any success, Has anyone had this problem before. I have install Muppy008 at least four times same problem.

NCI works fine with any version of Puppy and Muppy 007 HD install, but not Minisys Muppy008.

Cheers
Back to top
View user's profile Send_private_message 
sicfishe

Joined: 09 Jan 2008
Posts: 2

PostPosted: Wed 09 Jan 2008, 14:12    Post_subject:  

I have the same problem. Muppy 008 works fine when booting off the CD, but will not find my onboard ethernet (viaRhine) after doing an install to the hard drive.

I would love to be able fix this problem because I really liked all the features of Muppy 008.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 09 Jan 2008, 15:38    Post_subject:  

try this:

Insert and mount the CD.
Now type:
Code:
mkdir /root/mount
mount -o loop /mnt/cdrom/zmsy_080.sfs /root/mount
cp -ax /root/mount/lib/* /lib/
sync
umount /root/mount


If the CD is not mounted in /mnt/cdrom , then you must adapt that line.

This should do:
mount the .sfs with all Kernel-Modules.
Copy them to the harddisk.

It might be, that the Installer did not copy these.
Does that solve it?
Mark
Back to top
View user's profile Send_private_message Visit_website 
taichifu

Joined: 08 Dec 2006
Posts: 48

PostPosted: Thu 10 Jan 2008, 14:47    Post_subject:  

Hi

Tried the code mentioned but can't carry on the necessary procedure. Instead I copy all the LIB folder from the CD Live onto the hard drive and all work fine after a reboot. I also notice that Google Earth install without a hitch and work 1st time, whereas I tried to install Google Earth on Puppy 3.01 without any success.

This version of Muppy is a breeze an lightning fast all in all very impressed.

Thanks for your help.

Taichfu
Back to top
View user's profile Send_private_message 
sicfishe

Joined: 09 Jan 2008
Posts: 2

PostPosted: Tue 22 Jan 2008, 11:49    Post_subject: Still unable to find and networking devices  

I tried the above stated fix without any success. I have even downloaded and installed 008.1. When I try to setup networking and internet connection the networking wizard indicates that it did not find any networking devices. If I boot off the CD it is able to find my ethernet card. I thought this HD install bug would have been fixed by now. Any ideas on how to fix? I would love to use Muppy008.
Back to top
View user's profile Send_private_message 
taichifu

Joined: 08 Dec 2006
Posts: 48

PostPosted: Tue 22 Jan 2008, 12:04    Post_subject:  

Hi

Had the same problem and did what I said in my last post and did work for me. All I did was copy copy all the LIB folder from the CD Live onto the hard drive and all work fine after a reboot.

try it again should work.

Cheers
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 22 Jan 2008, 12:25    Post_subject:  

If it does not work as for taichifu, I cannot help at moment.
I had a closer look at the universal installer, and there seems to be no full code for the Driver-addon on full Harddisk installation in Puppy.

This is one of the reasons, why I added the warning-message, that minisys.org does not recommend this type of installation.
Be aware, you might encounter other irregularities.

This point is also not high on the ToDo list.
We just have a limited amount of developer resources.
We do not want to clone another Distro.
We want to enhance the points, that make Puppy so unique and special.

One of these points is the use of sfs and 2fs files.
Here, also things have to be enhanced, and that has main priority at moment.

So as far as I can help with tips as above, I'll do, but I will not start to write my own universal installer for full harddisk-installations.

Mark
Back to top
View user's profile Send_private_message Visit_website 
n1n31nchn41l5

Joined: 21 Mar 2008
Posts: 107

PostPosted: Fri 18 Apr 2008, 11:29    Post_subject:  

is it possible to do a frugal install of mupy008?
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4800
Location: GB

PostPosted: Fri 18 Apr 2008, 12:54    Post_subject:  

The issue of NIC drivers has been dealt with in detail earlier. You have to copy them from the CD when running under pfix=ram. Works for me. The same was true for one of BK's releases. He fixed it subsequently. It isn't primarily a fault of the PUI, per se, just an oversight on one line of code as I understood it? Due to ignorance, with Muppy I copied directories across willy-nilly until it worked! No doubt one of the smarter folk around here will remind us all which directory is mission critical. As for Mark, once we know the chapter and verse, all that should be necessary is to use a newer PUI. But then, ignorance is a wonderful shield against wisdom and truth.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0589s ][ Queries: 12 (0.0042s) ][ GZIP on ]