Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 00:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Sound ES18xx auf Armada 1700 Puppy3.01
Moderators: MU
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
aborg

Joined: 31 Mar 2008
Posts: 4
Location: Jena

PostPosted: Mon 31 Mar 2008, 05:47    Post_subject:  Sound ES18xx auf Armada 1700 Puppy3.01
Sub_title: Kein Sound mit Onboardchip ES1869 auf Notebook Compaq Armada 1700
 

Hallo

Ich bin neu bei Linux.
Teste deshalb verschiedene Distries auf meinen Notebook (Armada 1700, 300MHz, 288MB, 40GB).
Einzig Muppy-Puppy ist wirklich performant.

Muppy gefällt mir besser wegen der umfangreicheren Software und der anpassbaren lustigen Oberfläche (ICEWM).
Muppy 008 hat meinen PCMCIA RT2500 Wlan Adapter nicht erkannt.
Upgrade auf Puppy 3.01, jetzt geht's, aber dafür wieder in ENglish.

Meine Soudkarte erkannte bisher nur KANOTIX (ist zu langsam).
Habe unter Muppy-Puppy3.01 Alsaconf mit ES18xx laufen lassen. ->kein Sounddevice?!

Ich könnte mir die IRQ und DMA vom Computer-Setup besorgen.
Kann ich damit was anfangen?
Eventuell alsa.conf editieren?

Danke für Muppy-Puppy,
Andreas
Back to top
View user's profile Send_private_message 
cat


Joined: 09 Apr 2008
Posts: 52
Location: out of place

PostPosted: Thu 10 Apr 2008, 10:45    Post_subject:  

Hi Andreas,
ich hab zwar 'n Armada 1500 mit Puppy, aber bei mir hat's so funktioniert:

Quote:

On the bootup screen I used the bootcode 'puppy pnpbios=off', cause ALSA obviously had some trouble with this (it said something like that in the 'dmesg' I looked in when it didn't work)

After bootup I set up the soundcard manually using modprobe in the console. After fiddling around with the parameters, my final setup looks like this:
'modprobe snd_es18xx isapnp=0 port=0x220 mpu_port=0x330 dma1=1 dma2=1 irq=5 fm_port=0x388'


Der Einfachheit halber mal in Englisch, hoffe das ist OK.
Evtl. musst Du 'n bisschen rumprobieren, sollte aber eigentlich gehen.

Viel Erfolg!
Back to top
View user's profile Send_private_message 
aborg

Joined: 31 Mar 2008
Posts: 4
Location: Jena

PostPosted: Mon 14 Apr 2008, 15:45    Post_subject:  

danke Cat,

hab leider keinen Schimmer, wo man das Plug and Play-Bios mit "puppy pnpbios=off" ausschaltet.
Als boot-Option steht es nicht zur Verfügung, wenn ich mit 'c' in die Eingabeaufforderung komme nimmt er's auch nicht ???

Tschüss,
Andreas
Back to top
View user's profile Send_private_message 
cat


Joined: 09 Apr 2008
Posts: 52
Location: out of place

PostPosted: Thu 17 Apr 2008, 16:44    Post_subject:  

Kommt drauf an, wie Du Puppy laufen lässt. Wenn Du's als Live-Version von CD startest, kannst Du einfach beim Boot-screen (wo die anderen Beispiele für Boot-Optionen stehen)

puppy pnpbios=off

eingeben, auch wenn's da nicht als Option angeboten wird.
Wenn Du's als Frugal-Installation laufen hast, kannst Du diesen Befehl in der menu.lst datei deines Bootloaders hinter die Kernel-Zeile schreiben. Hab hier 'ne etwas andere Konfiguration als gewöhnlich, aber eigentlich müsstest Du diese Datei im Verzeichnis /boot/grub/ finden, wenn Du grub benutzt.

Hoffe ich hab Dir weitergeholfen. Nicht aufgeben, irgendwie klappts schon Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0432s ][ Queries: 12 (0.0036s) ][ GZIP on ]