Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 04:43
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
puppy-400alpha7-397 does not have ldconfig
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
bde

Joined: 29 Mar 2008
Posts: 25

PostPosted: Fri 04 Apr 2008, 23:18    Post subject:  puppy-400alpha7-397 does not have ldconfig  

Posted here thinking this may be a bug; but, not sure if this is, and could not delete it and post in a different forum. My difficulty is with library setup. Need to use Keepass, and am getting library error.

Installed qt-3.3.8 libraries, trying to solve the 'libqt-mt.so.3: cannot open shared object file: No such file or directory' when running keepass.

I checked that /usr/lib/qt/lib has libqt-mt.so.3 linked to libqt-mt.so.3.3.8 in the same directory. Checked that /etc/ld.so.conf has /usr/lib in it. When trying to run ldconfig in order to update the library setup, found out that ldconfig is absent (ldconfig: command not found). I downloaded http://dotpups.de/dotpups/System_Utilities/ldconfig.pup, and installed it.

Ran ldconfig. ldconfig -p command does not print any of the libraries in /usr/lib/qt/lib. Don't know what I am doing wrong.

Thanks for help.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 05 Apr 2008, 10:00    Post subject:  

I think I had the same error with qt when I built Muppy-Embryo, a stripped down Puppy with Opera, that even ldconfig did not recognize the libs.
I had to reboot so that the changes were active.

Before the reboot, I could test things by typing this in the consoe, I ran the program from:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/qt/lib

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0747s ][ Queries: 12 (0.0319s) ][ GZIP on ]