Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 05:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Java 1.6u17
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [50 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 18 Mar 2008, 18:56    Post subject:  Java 1.6u17
Subject description: Java Runtime Environment
 

Note: Adds java support to firefox, flock, iceape, icecat, iceweasel, mozilla, opera, and seamonkey, for seamonkey/mozilla one must enable it, start seamonkey/mozilla, click edit > preferences > Advanced > Click to checkmark enable java.

java-1.6u17.pet
md5sum

Test your Java Here.

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.

Last edited by Wolf Pup on Thu 17 Dec 2009, 20:14; edited 13 times in total
Back to top
View user's profile Send private message 
ravensrest


Joined: 22 Feb 2008
Posts: 321
Location: Hood Canal, WA

PostPosted: Wed 02 Apr 2008, 19:16    Post subject: Need help with java 1.6u5
Subject description: java run time environment
 

I tried to install this in Dingo 394 and got a list of missing libraries a mile long and no indication in Seamonkey that it knows about it. However, there are really only six missing dependencies listed. They are:

libmawt.so
libjvm.so
libXp.so.6
libXi.so.6
libodbcinst.so
libodbc.so

But libjvm.so is installed by your pet in /usr/java/lib/i386/client and server.

And libmawt.so is installed in /usr/java/lib/i386/xawt, motif21, and headless.

The remaining four are not present on my computer and not listed in the repository.

Also, the pet installer reports that it has added 'java' entries for every heading in the menu, which, of course it has not; there are no menu entries because there are no new files in the /applications/ folder.

I tried installing it in Puppy 3.01. In this case the libXi and libXp files are present so are not reported as missing. The libodbc and libodbcinst are NOT present but are NOT reported as missing. There is still a string of missing dependencies, all libjvm and libmawt.

Tried again with Puppy 4.0beta. Same result. Has anyone gotten this Pet to install correctly?

BS

Last edited by ravensrest on Thu 24 Apr 2008, 12:36; edited 5 times in total
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 02 Apr 2008, 19:51    Post subject:  

Spyware?
Spyware-2008-04-03_014929.JPG
 Description   
 Filesize   24.23 KB
 Viewed   22559 Time(s)

Spyware-2008-04-03_014929.JPG


_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Wed 02 Apr 2008, 20:43    Post subject:  

na, tis me signature. Smile
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Thu 03 Apr 2008, 05:47    Post subject:  

I don't like that my IP is publically shown.
I hope you can take some action to avoid this in the future.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Thu 03 Apr 2008, 09:24    Post subject:  

alright, i took off the ip and ISP. now just shows OS and browser.
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Thu 03 Apr 2008, 12:16    Post subject: Re: Java 1.6u5
Subject description: Java Runtime Environment
 

Wolf Pup wrote:
Note: This java automatically adds java for firefox/opera/flock, for seamonkey/mozilla one must enable it, start seamonkey/mozilla, click edit > preferences > Advanced > Click to checkmark enable java.

Java-1.6u5

md5sum


Hey Wolf_Pup

I am downloading now
thanks for making this available Cool

I just made the latest non Beta firefox + flash and this is the perfect compliment to it
I'll keep you posted

also thanks for your work in
http://puppylinux.ca/bugs/

test your java here
http://www.java.com/en/download/installed.jsp
it checked out fine for me Wink


ohh almost forgot Wolf_ Pup would "MainAlt4.jpg" ring a bell? good4.jpg would be better Laughing

big_bass
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sun 06 Apr 2008, 10:11    Post subject:  

Béèm wrote:
I don't like that my IP is publically shown.
I hope you can take some action to avoid this in the future.


"Béèm" You can take action yourself Wink

edit your post remove the attachment image you posted too Cool

https://addons.mozilla.org/en-US/firefox/addon/10


big_bass
dont worry be happy .png
Description 
png

 Download 
Filename  dont worry be happy .png 
Filesize  31.87 KB 
Downloaded  2813 Time(s) 
Back to top
View user's profile Send private message 
cartz

Joined: 08 Apr 2008
Posts: 85

PostPosted: Wed 14 May 2008, 17:10    Post subject:  

Has anybody made a pet of a working java work Puppy 4.00?

As per the ravensrest post above, this pet doesn't work in dingo.

Thanks,

cartz.

UPDATE:

Found the excellent post "HOWTO install Java the hard way" and will take that option instead, see http://www.murga-linux.com/puppy/viewtopic.php?t=21505
Back to top
View user's profile Send private message 
dfcool

Joined: 20 Jan 2008
Posts: 60
Location: Connecticut, USA

PostPosted: Sun 08 Jun 2008, 15:36    Post subject:  

i am just as confused as ravensrest.
_________________
Idea I Hope this Newbie Knowledge Helps You Idea
Exclamation Thank You For All your Help, I REALLY Appreciate It!! Exclamation
Back to top
View user's profile Send private message Visit poster's website 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Sun 22 Jun 2008, 23:14    Post subject:  

Java updated to 1.6u6
Added "Java Control Panel" to system menu.

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 22 Jun 2008, 23:24    Post subject:  

The java SDK is now Open Source
RedHat is the first distro with a working environment

We do have ways of using their package management system - will we be the second?

Tiny Puppy
Big Java

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
steve0

Joined: 09 May 2008
Posts: 8

PostPosted: Mon 23 Jun 2008, 00:49    Post subject:  

That's good !Thank you for share it !
Back to top
View user's profile Send private message Visit poster's website 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Wed 25 Jun 2008, 18:43    Post subject:  

DOH!

I just installed the old java 1.5 dotpup from dotpup.de. Then I found this thread. It was a good learning experience anyway to see how the dotpup went. Installed Ok. Using Puppy 4.0

Is it still debatable whether the java .pet files here work with Puppy4? Would it be recommended to try it?

If so, should my java 1.5 be uninstalled first?

Cartz, did the "hard way" work? Looks nasty.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Wed 25 Jun 2008, 21:11    Post subject:  

ken_cat,

just use the package managet to uninstall the java .pup, then install the java .pet. Java shouldn't care which pupversion you're using.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 4 [50 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0660s ][ Queries: 13 (0.0047s) ][ GZIP on ]